Posts that Caljyody is monitoring

Subscribe to Posts that Caljyody is monitoring 29 post(s) found

← Previous 1
Jul 19, 2010
Avatar gl 25 post(s)

Topic: 2.1pre7 not retrieving watched items.

I’ll read the rest more carefully later, but re. the clock sync, I disagree – I’m not interested in a ‘perfect’ solution as it has never materialised, but rather one that works.

As a compromise, why not simply offer the option to sync 5 mins before auction end? You can disable it by default, and let people like me try it out. I guarantee you all my sync problems will disappear as I have a 100% success rate with doing it manually. Don’t get me wrong, I’m a purist myself, but after years of having to manually sync, I just don’t want the hassle anymore.

I also genuinely think the real problem is that other apps might by syncing the time (eg. the OS time sync), so you simply cannot control this or rely on your own sync to stay correct (and that applies equally to Ebay’s servers). The only sane solution is to sync (again) near the auction end.

 
Jul 14, 2010
Avatar Morgan Schweers 1,204 post(s)

Topic: 2.1pre7 not retrieving watched items.

Greetings,
Yes, sorry, I skimmed them, and didn’t notice the request to remove your email.

I’ll do that. I’ve been heavily occupied with trying to find a new job, so I haven’t been doing much JBidwatcher development lately. Let’s see if I can roughly respond to your questions…

  1. I’ll poke at the completed auction handling for My eBay searches; it’s possible that it’s marking them as sticky (i.e. on completion they don’t move from the current tab), but it shouldn’t be.
  2. One interesting report I got recently pointed out that I’m checking time drift between before I start the network request, and the time that eBay shows when the request comes back. They made the point that this could be skewed by abnormally long startup times for the network request, and that it might be more accurate to check time drift by grabbing a time snapshot after the request for the time page has returned. I’ll poke at that. I’ve always resisted the ‘synch 5 minutes before snipe’, because if your clock is drifting 1-2 minutes every 40 minutes, JBidwatcher isn’t going to be able to adjust for that sanely. It means that in the 5 minutes left from the sync, your clock will drift by (on average) about 11 seconds. That’s a broken computer, in my opinion, and so I don’t believe that’s the problem for most folks, and thus the ‘sync’ solution may seem right, but it’s not actually addressing the underlying problem.

I thought I’d fixed the delete problem in 2.1pre8, actually.

JBidwatcher is actually a heavily multi-threaded program, and the number of threading issues (left) in it are surprisingly few. I’m actually kinda proud of that. :) The older version was a nightmare to manage, mainly. It didn’t support large auction sets, it was terribly factored, it was really, really frustrating to code on. I added the database, and several other features, to bring it up to a level that I was comfortable developing at, but the interface between the old all-in-memory code and the new as-much-as-possible-in-database code is still admittedly shaky. The deletion issue is resolved, though, I’m pretty sure of that.

I’d need to see your logs for the steps you took, to see exactly what’s caused JBidwatcher to believe the login failed, but that message is VERY specific. If you’re seeing: “eBay (or the link to eBay) appears to be down for the moment.”, it means that eBay responded to an item-view attempt with the very specific message: “Our Site is Temporarily Unavailable”.

The login status display in the upper right has three distinct components. The time, the username, and the icon which indicates login status.

If the login status is green, it’s logged you in. You don’t need to worry about it at that point. If the username and time are struck out, it means it’s having trouble talking to eBay. (God I suck at user-facing UI paradigms; JBidwatcher’s UI needs a serious overhaul.) The strikeout there meant that it tried to read an auction, and got the ‘temporarily unavailable’ message. It doesn’t mean you’re not logged in, just that it thinks eBay might be down. (Not being logged in is usually is shown by a red login status icon, and ‘Not logged in…’ in the username space.)

Updating your login cookie changes the hover text, because it’s a successful network operation, but only a successful listing retrieval can clear the strikeout.

I hope this makes some sense. It all made sense to me as I built it, but when it’s all together it’s…obviously not sufficient.

— Morgan Schweers, CyberFOX!

 
Jul 12, 2010
Avatar gl 25 post(s)

Topic: 2.1pre7 not retrieving watched items.

Did you ever read my last two messages (above) Morgan?

 
Jun 17, 2010
Avatar gl 25 post(s)

Topic: 2.1pre7 not retrieving watched items.

BTW, sorry about the slow response, I never get email notifications about replies here, even though ‘Monitoring Topic’ is ticked? So I just stumble on them.

 
Jun 17, 2010
Avatar gl 25 post(s)

Topic: 2.1pre7 not retrieving watched items.

Hey Morgan,

I appreciate your position, I’m a programmer too & long time beta tester so I understand the value of good reports from both ends. I’m happy to beta test my issues full-on if you have the time.

Some notes, using pre8 .exe on Windows7-64:

1. Yes the problem is that completed items are not sorted into the ‘complete tab’, so every time you get your items you have to delete a whole bunch of entries. Manually choosing ‘Update’ doesn’t move them there either. They do show as ‘Listing has ended’ via Show Information, with the correct end time & date (as usual).

2. I don’t know why the time drift happens, but a possible reason is the OS (Windows here) updating the clock from a time server inbetween jBid’s updates. I leave this enabled as I want accurate clocks. And/or the Ebay server is slightly changing its time for similar reasons, or drifting a little. It doesn’t matter though – if you could add some logic that synchronizes the time 5mins before a snipe is due, it all resolves itself. As I said I do this manually, and it works every time (and if I don’t, it almost always snipes 1-2 mins ahead of the end). It may also correct the many reports you get about timing issues with snipes. 40mins is a long time in computing : ).

As for your database/memory solution, there do seem to be some problems there. For many versions now, deleting a whole bunch of entries often results in one or several not being deleted, sometimes listings don’t show unless you restart the app etc., so I do think there are some bugs there (note I’m not sure this still affects pre8 as I use pre6 for reliability reasons). Many versions ago this worked fine. Was the older solution really so bad performance-wise? If not I’d be tempted to just go back to that, it seems you have added some complexity that’s hard to debug (similar to threading issues in multi-threaded programming?).

re. the struck out email address, I just tried pre8 again and it’s working this time. … nope, it just failed again. Steps:

- Ran pre8, got my items. Email address was OK.
- Deleted all the completed ones (to see if I could get the ‘some items are left behind’ issue mentioned above – worked OK this time).
- Then tried to get my items again – now my email address is struck out. The status bar reports “Ebay (or the link to eBay) appears to tbe down for the moment…”. Hovering over the struck-out emails gives me “Login was unsuccessful. Communications failure talking to the server”.
- I try getting the cookie again, the status bar reports “Done getting the sign in cookie for ebay.co.uk …”, however my email is still struck out. But hovering over it says “Last login was successful”?

I’ve never noticed this happening on pre6.

 
Jun 11, 2010
Avatar Morgan Schweers 1,204 post(s)

Topic: 2.1pre7 not retrieving watched items.

Greetings,
@gl – Thanks for the detailed report! I’m sure something’s flaky there, and I agree JBidwatcher needs a good bug pass. I’m trying to reduce the ticket count in Lighthouse to something reasonable, so I can actually use it as a bug tracker. Currently it’s kind of acting as an auxiliary forum. :( The big problem is that I don’t know all the actual current bugs. A lot of bug reports are, ‘It doesn’t work!‘, essentially, without item numbers, descriptions, logs, or even what platform or JBidwatcher version. Then there are bug reports (sometimes really detailed!) that are still MPTNMI’s (stolen from the Passenger project, that stands for Mysterious Problems Than Need Massive Investigations) which I don’t always have the resources to do.

Often it takes someone dedicated who’s having the problem, working in a tight loop with me, sending them test versions which expose different debugging parts of the system, getting their logs, tweaking my version, and sending it back to them.

For example, your issue of getting your ebay username ‘crossed out’, is usually a communications failure talking to eBay. (Hovering over the strikeout will tell you what happened.) The log file will also often identify the issue; sometimes it’s because eBay’s just being stupid.

Sometimes it’s JBidwatcher being stupid. :)

One of my biggest concerns right now is that JBidwatcher is ‘partially database backed’, which means that it caches a lot of the items in memory, and I’m worried about parts of the program that might get out of sync with each other because they use the cache, or use the database and bypass the cache. I’m unsure about going to ‘everything that talks to an AuctionEntry uses the database’, because that’s probably not performant, so I’ve been trying to get everything to use the cache (which does the lookup on cache-misses) for read, and write-through when necessary.

For the two issues you raise:

  1. JBidwatcher will download completed listings from your My eBay; it’s part of the information in My eBay, so it considers it important. They should move to the ‘completed’ tab, though. At the very least, if you select them, right-click, and choose ‘Update’, it should move them then.
  2. For time sync, JBidwatcher synchronizes the time every (roughly) 40 minutes; I can’t imagine that it’s getting out of sync in that amount of time…? JBidwatcher starts the snipe 2 minutes early, but doesn’t submit the confirmation form until the snipe time. If the bid is under at the two minute mark, JBidwatcher will report it at that time, and cancel the snipe (because it can’t win, or even be submitted to eBay). Could that be what you’re seeing?

— Morgan Schweers, CyberFOX!

 
Jun 6, 2010
Avatar mhackney 4 post(s)

Topic: 2.1pre7 not retrieving watched items.

Morgan – using OS X 10.6.3 and pre-prerelease8! As of now all is right in the world of jbidwatcher! Thanks. Cavet to all- I’m only listening on ebay, have not sniped yet

 
Jun 6, 2010
Avatar gl 25 post(s)

Topic: 2.1pre7 not retrieving watched items.

… after restarting the app, the strange single watched item finally appeared in the Recovered tab. My email is now no longer crossed out, and all listings are downloading again (completed ones are still stuck in Current however). Something is intermittently flakey somewhere.

 
Jun 6, 2010
Avatar gl 25 post(s)

Topic: 2.1pre7 not retrieving watched items.

Re. downloading watched items, I spoke to soon. On the first item sync, they all came down. I then deleted them, and cleared deleted item tracking. Now it’s only finding 1 item (it should be ~35), but nothing is actually downloaded in any tab.

I also note that my ebay email is crossed out – even if I manually refresh the sign-in cookie (which is reported to be successful) it stays crossed out?

BTW, sorry about sounding frustrated in my last post, I realise this is free software and has been a massive project for you (I’m a programmer myself) – jBid is awesome, it’s just a couple of these issues have been slowly driving me crazy for too long : ). It would be great if you could device a plan that allows you to spend some time fixing jBid bugs only. I’d certainly donate to get the two issue I mentioned above taken care of.

I think every program gets to a point where it could use a bug-fixing phase and jBid is there imo. Name your price to make it worthwhile and let’s all pitch in to make it happen.

 
Jun 6, 2010
Avatar gl 25 post(s)

Topic: 2.1pre7 not retrieving watched items.

Pre8 does download my watched items again – but it still keeps downloading completed listings and leaves them in the ‘Current’ tab. This started happening a few versions ago (ever since the new tabs like ‘My Ebay’ were introduced) & has been really annoying for a long time now – is there some configuration I need to change or is it a bug?

Also one thing I would love for you to address is snipe timing. For as long as I can remember (years now?), I found that unless I manually synchronize the clock a few minutes before an auction closes, it tends to snipe a minute or two too early. Regardless of the cause, that tells me that jBid is probably not doing an automatic time sync before an auction is due to end. Could you please add that, say auto-synchronize when there’s 5 or 10 minutes remaining on a snipe, and if it hasn’t been done very recently?

Basically I’ve gotten into a horrible routine where I’m constantly synchronizing manually to avoid this (which works every time), but often I’m not sure I’m around for the end of a snipe, so I end up synchronizing over and over just in case – I would love to be able to trust jbid to do this for me.

 
Jun 6, 2010
Avatar Plex 5 post(s)

Topic: 2.1pre7 not retrieving watched items.

Installed the pre8 pre-release and the first thing I noticed is that once it auto-logged in it said, “Done getting the sign in cookie for ebay.co.uk,” even though the Configure shows just ebay.com, which is what I use.

I did “get my eBay items” and got all of them!! I then deleted them using both the trash icon and right-click delete and both worked.

Dragging from browser window to JBW nothing appears until after I switch tabs, i.e. go to “complete” tab and then back to “current” tab. Then they are there.

Using the menu, “add auction” I get the same thing, but the status messages shows, “Added [auction name and stuff].” Again switching windows and there it is! “Paste auction” behaves the same ….. but see issues below

Ahhh! And now the delete problem resurfaces. The thumbnail is gone but the auction lingers until closing JBW and relaunching it …. And now the dragging auction from browser is dead ….. until I quit and relaunch …….. pasting now reports an error that auction already exists when I have none showing ….. dragging produces nothing, no error and no auction added. But, after quitting and restarting every shows up, but minus their thumbnails until after auction is updated.

No snipes for now will advise when I get them. Thanks!!

 
Jun 6, 2010
Avatar seah0rse 5 post(s)

Topic: 2.1pre7 not retrieving watched items.

Hi Morgan,

Thanks for the patched version. All good now for me on OS X 10.6.3 – searches and getting my ebay watch list is working.

Cheers Tim

 
Jun 6, 2010
Avatar Hoddy 108 post(s)

Topic: 2.1pre7 not retrieving watched items.

Hi Morgan, Just tried the 2.1.pre8 Windows Standalone version and it’s still not finding the Watched Items (0 watched items found).

UPDATE I deleted my .jbidwatcher folder and tried again – it now finds all my Watched items but does NOT find the items I am bidding on or the items I have already won!

Regards
Hoddy

 
Jun 6, 2010
Avatar Morgan Schweers 1,204 post(s)

Topic: 2.1pre7 not retrieving watched items.

Greetings,
I messed this one up. I fubared all forms of search, unfortunately, while trying to resolve an infinite loop that could happen if your search returned a result set that exactly equalled the page size. :(

I’d like you to try out a pre-prerelease, and let me know if it resolves your issues. (It may warn about a ‘newer version’, 2.1pre7. Ignore it.)

Standalone Windows: http://www.jbidwatcher.com/download/JBidwatcher-2.1pre8.exe
Disk Image (Mac OS X): http://www.jbidwatcher.com/download/JBidwatcher-2.1pre8.dmg
Linux .jar: http://www.jbidwatcher.com/download/JBidwatcher-2.1pre8.jar

As per usual, please let me know in as much detail as you can, about any issues you run into! This isn’t necessarily an official 2.1pre8 release, but I’m hoping to make it official real soon, unless there are widespread showstoppers in it.

Here’s the unofficial changelog:

JBidwatcher 2.1pre8

  • The last release was a bit hurried to fix sniping issues, so this is the ‘fix what broke due to rushing it out’ release.
  • Bugs fixed
    • Searches (including Get My eBay Items) work again
    • Fixed a failure to start the internal web server if you shut it down and tried to restart it
    • Auctions with Buy It Now and Fixed Price listings are once again distinct
    • For many users JBidwatcher was failing to save configuration settings during shutdown
    • Make displayed bid values more consistent, and try to reduce the number of ‘null’ prices that are displayed.
    • When deleting rows, sometimes they would be replaced with ‘*’ and would cause all kinds of problems until you shut down and restarted JBidwatcher. This should be resolved.

— Morgan Schweers, CyberFOX!

 
Jun 6, 2010
Avatar seah0rse 5 post(s)

Topic: 2.1pre7 not retrieving watched items.

Same problem here – I rest everything and still no luck. OS X 10.6.3 and same log file as Plex. The workaround adding items manually does work for me too.

 
Jun 5, 2010
Avatar Plex 5 post(s)

Topic: 2.1pre7 not retrieving watched items.

I didn’t want to start a new thread, but on MacOS 10.6.3 with the new pre-release (2.1pre7-29-g519c99a) I’m not having the same issues as reported by other Mac users. Snipes fire, the Seller name is now correct, I get logged in.

I too can NOT “get my eBay items.” JBW reports “Found 0 watched items.” The log reports as follows:

Sat Jun 05 09:16:50 PDT 2010: Loading page 1 of My eBay for user ***********
Sat Jun 05 09:16:50 PDT 2010: URL: http://my.ebay.com/ws/eBayISAPI.dll?MyEbayBeta&SortOrder=ASCEND&GotoPage=1&View=WatchingNext&Column=EndTime&CurrentPage=MyeBayNextWatching
Sat Jun 05 09:16:53 PDT 2010: Bad input tag (ignoring): button id=“EditButton_4698” class=“sfbtn” onclick=“return vjo.dsf.EventDispatcher.run(this,event,‘click’)”
Sat Jun 05 09:16:55 PDT 2010: Bad input tag (ignoring): button id=“EditButton_9552” class=“sfbtn” onclick=“return vjo.dsf.EventDispatcher.run(this,event,‘click’)”
Sat Jun 05 09:16:55 PDT 2010: Loading page: http://my.ebay.com/ws/eBayISAPI.dll?MyEbayBeta&CurrentPage=MyeBayNextBidding
Sat Jun 05 09:16:55 PDT 2010: No items on page!

What errors/bugs I am seeing are that completed auctions do not move from “current” tab to the “complete” tab. Also, to delete a completed snipe/auction, I have to select the auction, then delete but all that happens is the Thumbnail is deleted. To remove the listing I must shutdown JBW and restart.

 
Jun 4, 2010
Avatar Dominik Schmid 14 post(s)

Topic: 2.1pre7 not retrieving watched items.

Here’s a workaround that I used last night successfully:

- add the auctions you want to snipe/bid on manually
- right click “update auction” manually to make jbw set the correct “time left”
- now it’s possible to set a snipe, and it actually fires (tried with two auctions which i actually also won)

 
Jun 3, 2010
Avatar Scotty G 5 post(s)

Topic: 2.1pre7 not retrieving watched items.

Same problem here. :-(
-Scott

 
Jun 3, 2010
Avatar wookiemail 2 post(s)

Topic: 2.1pre7 not retrieving watched items.

If one pastes the auction into the window, it updates
with time left. SNIPE is grayed out. Test login works.

Dead in the water.

Bill Hale

 
Jun 3, 2010
Avatar dreyfoos 1 post

Topic: 2.1pre7 not retrieving watched items.

Also have failure to get watched items.

 
Jun 3, 2010
Avatar Dominik Schmid 14 post(s)

Topic: 2.1pre7 not retrieving watched items.

same problem here, jbw lastest 2.1pre7, os x 10.6.3

also if i add auctions manually they show time left not like usually but with the full date and time as if the auction was already finished.

 
Jun 2, 2010
Avatar wookiemail 2 post(s)

Topic: 2.1pre7 not retrieving watched items.

I’m having the same problem. Can’t download watched items.
Windows 7. pre7. I can pass the log in test. ebay.com us.

I tried reloading 2.0.1-825 which has worked in the past
but no soap with it either.

:-( This has been a good application. Consistently downloading
the watched items has been the only hassle as it is today.

ebay 69wookie

Bill Hale
Donor.

 
Jun 2, 2010
Avatar woold 2 post(s)

Topic: 2.1pre7 not retrieving watched items.

I am also having this problem on ebay.co.uk (Mac OS 10.6.3). Is it possible to download a copy of the previous version as I didn’t keep it.

 
Jun 1, 2010
Avatar mobiusclimber 1 post

Topic: 2.1pre7 not retrieving watched items.

Having the same problem. I’m using Mac OSX and ebay.com.

 
Jun 1, 2010
Avatar BugMagnet 26 post(s)

Topic: 2.1pre7 not retrieving watched items.

I’ll confirm this behavior. on winXP 2005 MC, I tried both the .jar and .exe and both fail to get watched items. I filed a bug report already (#1157) on this and another issue I detected.

da BugMagnet
supporter and donor

← Previous 1