Posts that Hoddy is monitoring

Subscribe to Posts that Hoddy is monitoring 217 post(s) found

Jul 24, 2009
Avatar RCalistan 37 post(s)

Topic: Get My eBay Items stopped working

Well, I can confirm that BUY works – at least on my PC. I haven’t auto-dismissed the confirmation dialogs so I OK’d both and the BIN was processed A-OK.

On the downside, however, a new parsing error has cropped up when scraping the Watchlist….

Fri Jul 24 14:58:47 EDT 2009: For input string: "Refund: Full refund if not satisfied. See details."
Fri Jul 24 14:58:47 EDT 2009: PMQ Caught exception: java.lang.NumberFormatException:
For input string: "Refund: Full refund if not satisfied. See details."
For input string: "Refund: Full refund if not satisfied. See details."
java.lang.NumberFormatException: For input string: "Refund: Full refund if not satisfied. See details."
	at sun.misc.FloatingDecimal.readJavaFormatString(Unknown Source)
	at java.lang.Double.parseDouble(Unknown Source)
	at com.jbidwatcher.util.db.Table.setColumn(Table.java:429)
	at com.jbidwatcher.util.db.Table.setPreparedUpdate(Table.java:410)
	at com.jbidwatcher.util.db.Table.updateMap(Table.java:280)
	at com.jbidwatcher.util.db.Table.insertOrUpdate(Table.java:253)
	at com.jbidwatcher.util.db.ActiveRecord.saveDB(ActiveRecord.java:116)
	at com.jbidwatcher.auction.AuctionInfo.saveDB(AuctionInfo.java:544)
	at com.jbidwatcher.auction.server.ebay.ebayAuction.parseAuction(ebayAuction.java:459)
	at com.jbidwatcher.auction.server.AuctionServer.doParse(AuctionServer.java:273)
	at com.jbidwatcher.auction.server.AuctionServer.loadAuction(AuctionServer.java:217)
	at com.jbidwatcher.auction.server.AuctionServer.create(AuctionServer.java:138)
	at com.jbidwatcher.auction.AuctionEntry.prepareAuctionEntry(AuctionEntry.java:241)
	at com.jbidwatcher.auction.AuctionEntry.(AuctionEntry.java:276)
	at com.jbidwatcher.auction.AuctionEntry.construct(AuctionEntry.java:293)
	at com.jbidwatcher.ui.JBWDropHandler.loadDroppedEntry(JBWDropHandler.java:77)
	at com.jbidwatcher.ui.JBWDropHandler.messageAction(JBWDropHandler.java:51)
	at com.jbidwatcher.util.queue.PlainMessageQueue.run(PlainMessageQueue.java:55)
	at java.lang.Thread.run(Unknown Source)

The item # isn’t shown in the log but by comparing the watch list manually and the listing in jbw, I was able to determine it’s auction # 360142442758 causing the above. Manually inserting the auction into jbw causes the same error and the import never succeeds. Also, when jbw hits this item in the list it silently errors out while displaying no errors on the screen; indeed, you get the “Don synchronizing” message in the status box and the yellow bar recognizes the new entry. But it never makes it into the DB and its beiing in the watchlist casues future scrapes to fail (silently) as well.

 
Jul 23, 2009
Avatar ricekin 1 post

Topic: Get My eBay Items stopped working

On 2.1pre3-982 when doing “Bid”. Sniping doesn’t work either.
Runnning Sun Java Platform Standard Edition Runtime Environment (JRE) 6 on Ubuntu Jaunty.
Thanks and keep up the good work!

Thu Jul 23 14:26:26 CEST 2009: PMQ Caught exception: java.lang.NullPointerException
java.lang.NullPointerException
	at com.jbidwatcher.auction.server.ebay.ebayBidder.getBidInfoURL(ebayBidder.java:182)
	at com.jbidwatcher.auction.server.ebay.ebayBidder.getBidForm(ebayBidder.java:109)
	at com.jbidwatcher.auction.server.ebay.ebayBidder.bid(ebayBidder.java:314)
	at com.jbidwatcher.auction.server.ebay.ebayServer.bid(ebayServer.java:497)
	at com.jbidwatcher.auction.AuctionEntry.bid(AuctionEntry.java:1262)
	at com.jbidwatcher.auction.AuctionBid.execute(AuctionBid.java:23)
	at com.jbidwatcher.auction.AuctionActionImpl.activate(AuctionActionImpl.java:44)
	at com.jbidwatcher.auction.server.ebay.ebayServer.bidMsg(ebayServer.java:278)
	at com.jbidwatcher.auction.server.ebay.ebayServer.messageAction(ebayServer.java:202)
	at com.jbidwatcher.util.queue.PlainMessageQueue.run(PlainMessageQueue.java:55)
	at java.lang.Thread.run(Thread.java:619)
 
Jul 22, 2009
Avatar Dominik Schmid 14 post(s)

Topic: Get My eBay Items stopped working

2.1pre3-982 does seem to get my ebay items, but what’s up with the bidding on items located in other countries? ebay obstructing international trading big time or what? someone should send the WTO after them…

 
Jul 21, 2009
Avatar zappram 290 post(s)

Topic: Get My eBay Items stopped working

I have also discovered that (CERTAIN) seller’s item are not added to JBW no matter what. I’d tried to drag and drop from Firefox which worked for any other sellers, but not for this one. I am watching on eBay about 20 items from that seller but I cannot add any of their items to JBW. I don’t know why, but I read someone else had the same issue.

I can, and had been winning auction in the past 24 hours using JBW once the item is added to the list and set to snipe. Still happy when I win some auction items on eBay ;)

I am running Mac OS 10.5.7 with latest update on all SW as of today, Intel Core2Duo 2.66Ghz iMac, 1TB/4GB, Firefox 3.5.1

 
Jul 20, 2009
Avatar RCalistan 37 post(s)

Topic: Get My eBay Items stopped working

just realized i forgot to post ps detail….

Win XP SP3
JRE:
java version “1.6.0_13”
Java™ SE Runtime Environment (build 1.6.0_13-b03)
Java HotSpot™ Client VM (build 11.3-b02, mixed mode, sharing)

 
Jul 20, 2009
Avatar RCalistan 37 post(s)

Topic: Get My eBay Items stopped working

Well, 8 hours later and several automated Get My eBay runs and some commo errors that would drive jbw into a CPU-chomping loop have occurred and jbw is purring along and taking only .015 of a second of CPU every 6-10 seconds (assume that’s the lazy polling cycle going on).

{thumbs up}

 
Jul 19, 2009
Avatar RCalistan 37 post(s)

Topic: Get My eBay Items stopped working

v963 seems to have solved my #1 issue – maxed-out CPU usage. Previously, when jbw would hit an error (commo timed out, auction not found, whatever), it would eat all the CPU it could and never break out of whatever loop it was in; most times right at 50% CPU. Recently, I discovered I could force the loop condition by doing a “Get MyEbay items”. It got to the point in the last couple weeks that I just turned off the saved job and would run jbw only when needed. Also, around the same timeframe I started buying some stamps online and many of the auctions are foreign-based sellers (seems to matter to the returned pages format/content). It’s obviously related to parsing the new pages being returned and I knew you were working on it.

Downloaded 963 this afternoon and it does a a Get MyeBay just fine. I’ve turned the saved search back on but will have to wait a bit for it to auto-run. Manually running via a double-click in the search window and from the eBay menu item in the GUI work fine. I have some debug logs of both 2.0.1 and 963 if you want to see them.

Also….

The (unknown) seller problems seems to have been fixed.

Snipes work fine – did a half-dozen with it and it worked fine (I did get outbid on one but jbw correctly reported that); don’t know about buy – generally just do that with the browser. Multi-snipe unknown – haven’t tried one yet.

One weird thing I did notice is that on some auctions, the thumbnail picture is wrong. For example, auction 250463436285. The thumbnail picture shown in jbw is the image of the 2 green stamps and the seller’s picture, NOT the picture of the item. Again, this is probably related to the parsing of the returned page (it being a swedish vendor).

 
Jul 19, 2009
Avatar Kathi 1 post

Topic: Get My eBay Items stopped working

New to this program, been struggling with it off and on since last night because Auction Hunter is flaking out and this appeared to be the only decent alternative. I so badly want to like JBW (especially with those image pop-ups, because I’m a postcard collector), but it is not playing nice on my PPC Mac (PowerMac G5 running OS 10.5.6). Searches are only fetching about half the auctions they should. Title searches don’t work at all. URL load searches don’t work. It’s trying to fetch my eBay watched items but has never gotten them all. Does this program not really work well for late PPC Macs like mine? I guess I’ll try the pre-release, if that doesn’t behave better I may have to give up.

Update: The prerelease can find stuff with a title search, which was looking like progress… until I realized that it found about 60 items for the same search that fetches more than 500 if performed at ebay.com. Not looking good for me and JBW… Anybody have any tips about something I may be overlooking that is causing this poor search performance? I’ve tried looking for some setting that might cap the number of auctions returned in a search, but don’t see one.

On a positive note, the unknown seller problem has disappeared.

 
Jul 19, 2009
Avatar Frank P. fro... 71 post(s)

Topic: Get My eBay Items stopped working

JBidwatcher (2.1pre2-963) seems to kill the freeze on updating, all my auctions are up to date now again, while before the programm stopped work when updating completed auctions. Bid is ok, snipe I can’t tell at the moment …

 
Jul 19, 2009
Avatar zappram 290 post(s)

Topic: Get My eBay Items stopped working

I am not getting WATCH item automatically, but I drag item from Firefox 3.5.1 and 145 of them showed up now so I can snipe.

JBW however can automatically update any of my items that I bid on.

So, for now, I get all the items from SELLING and WATCH and BID items. I am okay for now. I believe if JBW can do scan and include all the watch/bid/sell items and we can snipe, then at least it’s consider stable already.

Thanks for the quick temp. fix We have a working working around at least. I will keep supporting your project as before. Keep up the great work. Thanks again.

zappram from California
Mac OS X 10.7.5 (very happy with Mac OS for so many years, yeah, never had a virus for almost 30 years).

 
Jul 19, 2009
Avatar Morgan Schweers 1,204 post(s)

Topic: Get My eBay Items stopped working

Greetings,
@Ward – I’d really appreciate an item number for an auction that you’re having trouble loading. The problem with the error log you’ve included is that I don’t know where it’s showing up.

Also, if you shut down JBidwatcher and restart it, do the items show up?

@tailgunner24 and @willer – Thanks muchly! It’s really good to know it’s getting better.

@zappram – So you’re not getting watch items, but you are getting bid-on items? Erf; that’s the opposite of what another user was having. :(

I’m trying to fix some of the lower hanging fruit (bid and buy (but not sniping) failing for some people, deleting items acting weird), while figuring out the My eBay problems.

— Morgan Schweers, CyberFOX!

 
Jul 19, 2009
Avatar zappram 290 post(s)

Topic: Get My eBay Items stopped working

I bid on 2 more items, and they showed up under (current) tab, BUT none of the WATCH items are showing up.

I usually only watch them so I just snipe when I want to buy them, now the work around is to bid on them and then snipe them. Unfortunately, some sellers do not allow you to bid more than a fix number of their listings.

 
Jul 18, 2009
Avatar willer 3 post(s)

Topic: Get My eBay Items stopped working

I live in Italy – I am happy of jbidwatcher (from 1 year) – the last 14, same problems with stable version 2.0.1; system Xp pro sp3 – I have installed the 2.1pre2-963 – I don’t use get my ebay items and I bid only on ebay.it; the pre works fine in all features – only high bidder is unknown – thanks for your works

 
Jul 17, 2009
Avatar dav 2 post(s)

Topic: Get My eBay Items stopped working

I’m having similar issues with inability to add eBay Watched items (win 2.0.1, US user, US auctions).

What it will do is that it will add auctions I’m bidding on when I choose Get My eBay Items, but it won’t add the watched ones.

(I think maybe it adds watched items ok, if I’m not bidding on anything, but when I do have active bids it won’t add watched items. I can’t test at the moment by ‘removing’ my current bids, though.)

 
Jul 17, 2009
Avatar tailgunner24 1 post

Topic: Get My eBay Items stopped working

Hi Morgan, I’m a US user – I installed 2.1pre2-963 on my XP machine and I’m happy to say everything now works perfectly— no unknown sellers, snipes fire properly and everything looks good. I regularly buy stamps from non-US sellers- this release got their listings and names correctly. I haven’t sniped any of their listings yet (tomorrow) but snipes on US listings (3) were perfect. If I can help more let me know.
Ernie Wolfe

p.s. I, for one, really appreciate your stupendous efforts in the whole jbidwatcher project. (check your paypal)

 
Jul 17, 2009
Avatar Ward 26 post(s)

Topic: Get My eBay Items stopped working

When I encountered this problem with Get My Items and unknown sellers, I installed the 2.1pre2 release on Mac OS X 10.5.7 (Java 1.5.0_19-b02-304).

I dragged the jBidwatcher icon from my Applications folder into my Dock. When I launch the app by clicking the Dock icon, that icon starts bouncing and a second jBidwatcher icon appears at the right end of the Dock with the blue footer mark showing it’s a running application. The original icon keeps bouncing while jBidwatcher initializes and does its initial synchronization with eBay (US). (For comparison, launching release 2.0.1 bounces the icon just once, and there’s no second icon.)

This new release shows seller names for items already in my current list.

Get My Items shows a bright yellow bar announcing “Found 14 watched items (about 14 new).” for 30 seconds or so. But nothing gets added to the current list. I’m including the beginning of the error log at the end of this note.

Auction menu > Add New does nothing. Clicking the big green “+” button shows the Adding dialog, but nothing happens when I add a valid action number (copied from an eBay page).

— Ward

Fri Jul 17 12:30:42 EDT 2009: PMQ Caught exception: com.jbidwatcher.util.xml.XMLParseException:
  XML Parse Exception during parsing of a FORM-tag at line 1:
    Syntax error while parsing an attribute key:

XML Parse Exception during parsing of a FORM-tag at line 1: Syntax error while parsing an attribute key

at com.jbidwatcher.util.xml.XMLElement.syntaxError(XMLElement.java:1354)

 
Jul 16, 2009
Avatar Zoran 1 post

Topic: Get My eBay Items stopped working

Hi. I’m an intermittent user of JBidwatcher (and of eBay) and am still running version 2.0.1-825 on a Macintosh running System 10.5.7 in Australia.

I just got up and noticed that my JBidwatcher seems to be working again. All the “unknowns” for Seller have disappeared, replaced with the names of the actual sellers. I haven’t tried to snipe on anything (there’s nothing I want currently), so I don’t if that’s working again, but I thought I should let you know that whatever eBay did, they seem to have undone.

I haven’t restarted JBidwatcher – I just have it running in the background more or less continuously. In the past, whenever JBidwatcher started showing “unknown” for sellers I found if I restarted it that fixed the problem. This time restarting didn’t work, so I just left it running with the “unknowns” just to monitor various auctions. So, I assume whatever has caused the “unknowns” to disappear must be something at eBay’s end rather than me clearing some glitch.

Maybe eBay was trying something new, decided it wasn’t working for whatever reason and have gone back to an earlier version.

 
Jul 16, 2009
Avatar BVH 4 post(s)

Topic: Get My eBay Items stopped working

Morgan,

I am still having problems getting my “watched” items. It seems to get all my selling items properly, but, not the watched items. I can also not manually enter them. I’ve downloaded and installed the new pre-2.01 update. Here is an example of an item I am trying to manually add: 270423818646

Both the item and I are in the U.S.

What am I doing wrong? Thanks for a great product!

 
Jul 16, 2009
Avatar Marc 13 post(s)

Topic: Get My eBay Items stopped working

Morgan,

With the 2.1pre2 release sniping works fine
from Europe to buy a US item offered worldwide
from Europe to buy a European item offered worldwide
and also on items offered only locally.
Bidding doesn’t work
from Europe to buy a US item offered worldwide and seems to freeze JBid.

Marc

 
Jul 15, 2009
Avatar gurumarkb 22 post(s)

Topic: Get My eBay Items stopped working

Good news on version 2.0.1 is that it still snipes properly for me on the US site. Of the 3 auctions I added this morning JBidwatcher placed a bid on all three at the right time and I won 2 of them. Unfortunately JBidwatch failed to know that I had won anything and put all 3 in my “Outbid” tab. That’s a very minor problem as it’s easy to send it over to the “won” tab but it shows up in red instead of the normal blue color. At least I can use 2.0.1, manually add the auctions I’m sniping, and manually move anything I win to the “won” tab until Morgan has the time to figure out just what in H eBay has changed now. Good luck, and “may the force be with you”.

 
Jul 15, 2009
Avatar gurumarkb 22 post(s)

Topic: Get My eBay Items stopped working

After switching back to 2.0.1 and just for the H of it I tried the “Get My eBay Items” function. The status line showed the normal “Synchronizing” but instead of nothing for a few seconds it actually showed the “Getting …” for each item I have on page 1 of my watch list including the 3 new ones I recently added. Since JBidwatcher 2.0.1 is reading the eBay watch list it appears to be a problem where it’s just not updating the “current” tab to display the auction item that it just imported. Very wierd behavior.
I fixed the display problem by renaming the .JBidwatcher directory and allowing version 2.0.1 to recreate it. Now when I manually add an auction it is displaying properly. Obviously the 2.1pre2 version added or changed something that screwed up the displaying of each auction (like using a white font on a white background).

 
Jul 15, 2009
Avatar gurumarkb 22 post(s)

Topic: Get My eBay Items stopped working

Oops, I spoke too soon about the 2.1pre version. It worked once and I thought all was ok but I added 3 new auctions to my watch list that end in a couple of hours so they are on page 1 of the eBay watching but the “Get My eBay Items” failed to update the display. Ok, I know this is a pre release so I’ll just manually add them. When trying to do that JBidwatcher says it can’t add the auction because it’s already in the list even though I can’t see it. Ok, so I highlighted all the current items and deleted them, went back and chose “Get My eBay Items”, watched the status line saying “Synchronizing” and then “Done synchronizing” and I have a completely blank “current” tab. Since I can’t manually add an auction that it imported from the eBay watch list I’m switching back to the 2.0.1 version for now as the “current” display will show any item I manually add to it. For now that will work and I know this display bug willl be worked out by the time 2.1 goes gold.

 
Jul 15, 2009
Avatar Marc 13 post(s)

Topic: Get My eBay Items stopped working

Morgan,

With the 2.1pre2 release sniping works fine from Europe to buy a US item.

Marc

 
Jul 15, 2009
Avatar gurumarkb 22 post(s)

Topic: Get My eBay Items stopped working

Thanks for the fast responce Morgan. The 2.1pre2-963 version has the “Get My eBay Items” function working again and the seller names are back as well for the US eBay site. I know it has to be very frustrating keeping up on all the page format changes that eBay makes all the time. You are correct that the 2.1pre2 version only gets the 1st page of the watch list.
I’m also sorry that your car is in the repair shop so I’ll PayPal again (it’s been a few years) to keep JBidwatcher alive. Many thanks again.

Everyone please donate to keep the JBidwatcher project alive. Thank you.

 
Jul 15, 2009
Avatar Morgan Schweers 1,204 post(s)

Topic: Get My eBay Items stopped working

Greetings,
Heh! You and I posted at the exact same time. Yeah, that looks like the problem I think it’s seeing. As I said, sniping should not have that problem, but…crap. Back to the drawing board, at least later today.

— Morgan Schweers, CyberFOX!

p.s. Goodness; this is my 700th post. Wow…