Posts that mikethebike is monitoring

Subscribe to Posts that mikethebike is monitoring 164 post(s) found

Jul 24, 2007
Avatar krs99 99 post(s)

Topic: Has ebay broke it? (19 July 07)

If you have items that were marked as ‘completed’ during the time when things weren’t going well for JBidwatcher, hilight them, pull up your context menu, choose the ‘Advanced’ menu, and ‘Mark as not ended’.
-————————-
Thank you Morgan – worked like a charm.

I also quit JBW completely and restarted it again. The 70 – 80% CPU resource issue has gone away. Now when it’s just sitting there, the CPU usage is down to 0.4% and when something happens, ie I open a JBW window, it jumps up to 15 to 20% momentarily. Real memory usage is also way down.

Thanks for the tremendous support Morgan – a financial contribution from me will be forthcoming as well.

 
Jul 24, 2007
Avatar krs99 99 post(s)

Topic: Has ebay broke it? (19 July 07)

I just found out that the latest build of JBW uses up a tremendous amount of my CPU resources – it regularly goes up to 75% and I have seen it go over 80%.
I can’t believe this is normal.
With JBW using 80% of the CPU resources, everything else becomes really sluggish.
I closed all other applications, checked the hard drive, it’s fine, repaired permissions, only two needed repairing. But that issue has not gone away.
I’m running an AGP G4 with a 1.25GHz processor with 1.5 GB of memory. Using OS 10.4.8 and JBW 1.0.2.pre4.

 
Jul 24, 2007
Avatar ian peters 4 post(s)

Topic: Has ebay broke it? (19 July 07)

All working again. Fantastic support from Morgan. I just realised how much I use this software so I sent you some dollars. If comercial software was this well supported it would be nice.

 
Jul 23, 2007
Avatar Morgan Schweers 1,204 post(s)

Topic: Has ebay broke it? (19 July 07)

Greetings,
For the intermittent red-eye issues, look here:
http://forum.jbidwatcher.com/forums/9/topics/1042?page=2

If you have items that were marked as ‘completed’ during the time when things weren’t going well for JBidwatcher, hilight them, pull up your context menu, choose the ‘Advanced’ menu, and ‘Mark as not ended’.

I don’t know what the quit-save-XML failure is, unfortunately. I can’t replicate it, probably without your auctions.xml file.

bidmaster: Are you running 1.0.2pre4? Check the version number in the About box.

— Morgan Schweers, Cyber*FOX*!

 
Jul 23, 2007
Avatar bidmaster 4 post(s)

Topic: Has ebay broke it? (19 July 07)

Won’t update auction prices on OS 10.4.10.

 
Jul 23, 2007
Avatar Martin Bürkel 18 post(s)

Topic: Has ebay broke it? (19 July 07)

Hi,
pleas consider this phenomen when you are working on new code:
I want to Quit JBW (From the Menue or via shortcut ) ant the Konsole says:
Mon Jul 23 14:33:58 CEST 2007: Exception during the check() operation of class AuctionsManager
java.lang.NullPointerException
at AuctionInfo.toXML(Unknown Source)
at AuctionEntry.toXML(Unknown Source)
at AuctionServer.toXML(Unknown Source)
at AuctionServerManager.toXML(Unknown Source)
at AuctionsManager.saveAuctions(Unknown Source)
at AuctionsManager.checkSnapshot(Unknown Source)
at AuctionsManager.check(Unknown Source)
at TimerHandler.run(Unknown Source)

and wont let me quit.
The activity of the jbw process goes up and stays high.
(Mac OSX 10.4.10 on Intel with JBW 1.0.2.pre4)
Martin

 
Jul 22, 2007
Avatar krs99 99 post(s)

Topic: Has ebay broke it? (19 July 07)

Pre4 updated all my pending auctions except this one: 160139367315

But none of my “red eye” completed auctions were updated – should that happen as well or can I just forget about those?

I’m on OS 10.4.8

Update: 160139367315 updated itself, but the completed auctions didn’t.

 
Jul 22, 2007
Avatar Miffy 1 post

Topic: Has ebay broke it? (19 July 07)

Hi,

Just to let you know that pre4 (.jar, jre 1.6.0, win2k) is sniping Ok, moved item to complete and even coloured it in properly as I’d won it! :o) Also, pulling new items from myEbay working OK. Nothing untoward appearing in the log. Looks good.

Mark

 
Jul 22, 2007
Avatar Morgan Schweers 1,204 post(s)

Topic: Has ebay broke it? (19 July 07)

Greetings,

1.0.2pre4 is available from the Announcements forum @ http://forum.jbidwatcher.com/forums/9/topics/1042.

I woke up about an hour ago, and went through all the messages while debugging the new change. Thankfully it appears minor, and brings back the end-time for stores!

— Morgan Schweers, Cyber*FOX*!

 
Jul 22, 2007
Avatar gl 25 post(s)

Topic: Has ebay broke it? (19 July 07)

Just a quick note to say that pre3, although broken listing-wise, did actually sucessfully fire a snipe (and I won it : ) earlier today.

Looks like I’ll need to set up a Java dev environment (I’m a C++ guy)…

 
Jul 22, 2007
Avatar russ132 6 post(s)

Topic: Has ebay broke it? (19 July 07)

Downloaded pre3 just a few minutes ago, would not pull anything from eBay. No error messages, so not sure what the problem is.

russ132
AKA Ray

 
Jul 22, 2007
Avatar hawkeye 25 post(s)

Topic: Has ebay broke it? (19 July 07)

Hi, me too snipe worked great, didn’t win it be hey so what!!! item put into complete window, so I would say so far so good, cheers, Malcolm

 
Jul 22, 2007
Avatar pmx 5 post(s)

Topic: Has ebay broke it? (19 July 07)

Hi,

snipe works !

 
Jul 22, 2007
Avatar psiberware 2 post(s)

Topic: Has ebay broke it? (19 July 07)

huntz…

Loaded up your .jar on a Win XP Pro (Java 6 Update 2). No red eyes on US site. Auctions load and add. Got a snipe set to go in an hour on US eBay, will let you know.

 
Jul 22, 2007
Avatar hawkeye 25 post(s)

Topic: Has ebay broke it? (19 July 07)

HI Huntz, well so far I have got the “watching items” up and are trying a snipe, finishing in 30 mins, can’t get finished items though, Thanks for your work on this, Mac OSX 10.4.10 Malcolm

 
Jul 22, 2007
Avatar Frank P. fro... 71 post(s)

Topic: Has ebay broke it? (19 July 07)

… thanx huntz :-)
seems to work her and now (german ebay, 18:09 sunday evening)
no red eyes any more, dragging urls ok

 
Jul 22, 2007
Avatar huntz 6 post(s)

Topic: Has ebay broke it? (19 July 07)

@robecity:Yesterday, after some changes to the main code, we were close to have a working solution, but today ebay has made other changes, so the program is not working anymore (for now…).

 
Jul 22, 2007
Avatar huntz 6 post(s)

Topic: Has ebay broke it? (19 July 07)

Thanks to Laurence for the good reg exp fix, I have tested with success the CVS build.

For the guys not used to build JBidwatcher from the CVS repository, I have posted here the .jar version (waiting the next Morgan fix…) :)

Feel free to test and report any problems…

Bye.

 
Jul 22, 2007
Avatar robecity 1 post

Topic: Has ebay broke it? (19 July 07)

Hi
You might object to a none tech person muscling on your erudite forum but I started using jbidwatcher only recently and found it very useful. However no sooner using it when ebay update caused all the problems you’ve identified.
I’m now confused. Some forum entries imply it now works others that it doesn’t. I downloaded the update to my Mac, it seemed to work but quickly displayed the red eye.
Any clarification / advice welcome
Regards
Mal

 
Jul 22, 2007
Avatar Hans 12 post(s)

Topic: Has ebay broke it? (19 July 07)

Hi all developers reading this thread,

to speed up development/error tracking and help in solving the current jbidwatcher-issues,
I was trying to use Eclipse to compile jbidwatcher.

But there were dozens of “The import com.stevesoft.pat.Regex cannot be resolved” thrown at me.
I changed the class-folder several times in the project-properties/Libraries tab, but still no luck.

Any help would be appreciated, but maybe it’s better to do it by mail to

yesitshans at gmail.com

as not to fill this thread with developer questions.

Thanks,

Hans
 
Jul 22, 2007
Avatar pmx 5 post(s)

Topic: Has ebay broke it? (19 July 07)

Ooops !

didn’t see you last post…

At least, it forced me to brush up my “Java regular expression” knowlege !

Again, thanks for the fix !

 
Jul 22, 2007
Avatar pmx 5 post(s)

Topic: Has ebay broke it? (19 July 07)

Hi Laurence,

I finaly got it : there is a white space between “[0-9]+” and “end time” that is missing. It probably disapeared in the sourceforge post due to line truncation.

So, it works with the added space .

Thanks !

 
Jul 22, 2007
Avatar Laurence Pas... 59 post(s)

Topic: Has ebay broke it? (19 July 07)

I’ve updated the regular expressions listed on sourceforge to remove all literal whitespace from them (see post dated: 2007-07-22 13:59). These should be safer from a copy-and-paste viewpoint. Note that they are one line strings and should not have any spaces in them, regardless of how they are displayed in your browser.

 
Jul 22, 2007
Avatar pmx 5 post(s)

Topic: Has ebay broke it? (19 July 07)

Hi Laurence,

sorry, changing jbidwatcher.properties doesn’t work for me (mod. applied against latest CVS version, connexion to ebay.fr).

Anyways, I understand the rationale behind this change. I will try to trace the code on my side (you know the open source paradigm: “thousands pairs of eyeballs browsing the same code …”) .

 
Jul 22, 2007
Avatar cregist 7 post(s)

Topic: Has ebay broke it? (19 July 07)

Not quite it yet. After making the changes Laurence suggests, I still get Failed to load auction / Failed to parse auction errors.

It was working just fine until …

Thanks