[PreRelease] JBidwatcher 2.1pre4 is out

Subscribe to [PreRelease] JBidwatcher 2.1pre4 is out 98 post(s), 44 voice(s)

Avatar RCalistan 37 post(s)


you can edit the search… Windows | Search manager | select the search | edit | change the tab.

as for the watched items, in the debug log (turn on debug & logging in configuration) I see a bit about jbw constructing the “200 item view page” and retrieving it.

Navigating to the ‘200 at a time’ watching page: http://my.ebay.com/ws/eBayISAPI.dll?MyEbayBeta&CurrentPage=MyeBayNextWatching&SubmitAction.ItemsPerPageSave=x&CustomizedContainer=240&ItemsPerPage=100&ViewMYEBAY_NEXT_CONTAINER_CUSTOMIZE&ssPageName=STRK:MEWAX:COUNT:100&View=WatchingNext

do you see that for the .de site? maybe something to do with that…

Avatar eu 2 post(s)

Hello Morgan,

Here is some additional info about my previous post. The bug seems to be reproducible.
1. Tell jbidwatcher to snipe on an auction
2. Before time is up (~2min before end of auction), tell jbidwatcher again to snipe on the auction same auction. This is done to change the amount jbidwatcher should use.
3. jbidwatcher immediately bids on the auction, using the old sniping amount.
4. jbidwatcher will not snipe (again) when the auction comes to an end. It seems to think it’s already done.
German ebay was used for this.
This bug happened 3 times in a row now, so it is at least somewhat reproducible.


Avatar dengel 10 post(s)


Thanks for the hint on editing the search.

Regarding the ‘200 item view page’, I see the following in the debug output:

Navigating to the ‘200 at a time’ watching page: http://my.ebay.com/ws/eBayISAPI.dll?MyEbayBeta&CurrentPage=MyeBayNextWatching&SubmitAction.ItemsPerPageSave=x&CustomizedContainer=240&ItemsPerPage=200&ViewMYEBAY_NEXT_CONTAINER_CUSTOMIZE&ssPageName=STRK:MEWAX:COUNT:200&View=WatchingNext

But JBidwatcher still only retrieves about 30 auctions (25 + it seems some FP auctions), but I’m currently watching over 60 items.

When I open the above URL in a browser, I can only see my usual page with 25 auctions on one page.

Avatar nightcrwler 1 post

I am still getting this with 2.1pre4 and I been getting this since the ebay format change.

java.lang.IllegalArgumentException: Timestamp format must be
yyyy-mm-dd hh:mm:ss[.fffffffff]

Here is the output from command line. looks the end date is a much bigger number.

java -cp main/main.jar com.jbidwatcher.app.JBTool 170371324056
Mon Aug 17 20:06:32 GMT-05:00 2009: MQ_Swing: Postponing Message: LINK UP
Mon Aug 17 20:06:33 GMT-05:00 2009: MQ_thumbnail: Postponing Message: com.jbidwatcher.auction.server.ebay.ebayAuction@1479feb
Mon Aug 17 20:06:35 GMT-05:00 2009:

Marvel Legends Galactus Series War Machine dan-ketch 513 100 9223372036854775000 4 houston, TX, United States h***a current


ruby -e ‘puts Time.at(9223372036854775000/1000)’
-e:1:in `at’: bignum too big to convert into `long’ (RangeError)
from -e:1

Avatar RCalistan 37 post(s)


could be 2 things that i can think of.

first – ebay isn’t working for you and the .com page isn’t showing all your .de auctions. weird but then, hey it’s ebay. the test is to hit the page in the logfile and see what it returns. if it’s only returning 25 auctions, then there’s a problem there….

second – there’s a parsing error that’s causing the import to fail/stop. when you do a get my ebay, check the log file for a java error. what could be happening is the same thing i’m running into (and will post on when i’m done here). The logfile (debug needs to be on) will probably be something like this:

Tue Aug 18 02:09:08 EDT 2009: Not loaded (xxxxx).
Tue Aug 18 02:09:11 EDT 2009: Loaded xxxxx.
Tue Aug 18 02:09:11 EDT 2009: Not loaded (xxxxx).
Tue Aug 18 02:09:11 EDT 2009:
Tue Aug 18 02:09:11 EDT 2009:
at java.whatever

at java.lang.Thread.run(Unknown Source)

Go to your watching page and search for the last auction number listed immediately before the error. The auction after that one is the “bad” one. delete it and re-run the get my ebay. you should complete (or at least, get further down the page). If you have more auctions from the same seller, they’ll probably all error (same template by the seller)…

Avatar tidris 49 post(s)

How about making drag & drop work on Linux? When I was using jbw on Mac OSX a long time ago I was able to drag an auction link from the web browser window into the jbw window, and that would get the link pasted into jbw. Ever since I switched to Linux that kind of drag and drop has not been working for me. Adding auctions is more tedious now that I have to copy on the browser and paste on jbw. Keep in mind I normally add several dozen auction links to jbw every day.

I use the Ubuntu/Gnome GUI and Firefox.

Avatar gunrunnerjohn 9 post(s)

I tried this latest version with Windows 7 RC and it still doesn’t allow me to snipe or bid. :-(

Avatar dengel 10 post(s)


When I load the ‘200 item on one page’ URL shown in the debugging output in Firefox, I get my usual “My Ebay” page showing 25 items on one page. It is showing all auctions, including the German ones, but on separate pages with 25 items each. I do not get any errors when the auctions are loaded by JBidwatcher.

Changing the Ebay site in the configuration to ‘ebay.com’ instead of ‘ebay.de’ also does not fix this.

Avatar Dolphin 5 post(s)

Item 330353177795 on ebay.co.uk is showing as sold for $1 in 2.1pre4, whereas it actually sold for £199. Deleting, clearing and then re-adding 330353177795 gives the same result.

Avatar RCalistan 37 post(s)

dengel: that’s weird because that page should return 200 items at a time.

if you go to the my ebay page manually and change the display options to show 200 items at a time instead of 25, does it stick across browser sessions?

grasping at straws here…

Avatar dengel 10 post(s)

Richard: How do I change it to show 200 items? When I go to “Page options”, there’s the item “Choose the number of items to display per section on your summary page”, and the maximum number I can choose there is 25.

Avatar RCalistan 37 post(s)

dengel: Hmmmm, you don’t want the Summary page. You want to click the Watch link – right under All Buying.

In the buying-watching view, the # of items isn’t in the customization dialog (like it is for, say, the won items), it’s a choice at the bottom of the table for the watched items, right after the delete/add note/etc… buttons: “Items per page:10|25|50|75|100|200”. If I login to ebay.de, I get the same thing: “Artikel pro Seite:10|25|50|75|100|200”.

Avatar dengel 10 post(s)

Richard: Ha, it’s working now! As you suggested, I went to the page with only the Watched Items and not the summary page, and changed the number of items to 200. Now JBidwatcher suddenly sees all items, although the URL is still the same.

I don’t get it, but hey, it works! Thanks!

Avatar RCalistan 37 post(s)

hey, glad it’s finally working…. :-)

Avatar Trumpington7 3 post(s)

Good morning Morgan, how’s the family?

I’m running up huge debts thanks to jBidwatcher 2.1 pre4-1010 which has been working very well, thanks for that I’ll send you the bill!
Seriously though it has been working well and then a couple of days ago about 45 mins before zero hour an item I was sniping disappeared from my “current” list. I had a look in “Completed” and it was there, still ticking away and it sniped from there and won (by less than $1 from my maximum so I was chuffed). I don’t know why it shifted early to the “completed” list.

This morning I tried to add an item to the current list but for the first time I highlighted the item number and pasted it into the new snipe box clicked and it simply disappeared, the item did not show up anywhere, not even in the completed box.

I am noticing that almost all items I’m personally interested in are won by sniping and I do wonder if eBay are working very hard to stop this?

Avatar krs99 99 post(s)

Ebay could just stop the sniping by changing the rules and the software – other sites have done that but I think consumers are not buying into that concept.
So sniping is officially allowed on ebay.

However – I have an odd problem
For this auction 130328994004, the amount of the current bid shows up as null – actually the word null.
I also have another auction listed by the same seller, 130328993898 where the amount shows up fine.

First time I have seen the word ‘null’ under the current price.

Avatar afleance 44 post(s)

I installed jbidwatcher the latest 2.1pre4 on a new windows xp machine, and after running for a couple days, I noticed my hard disk was getting constantly hit and my computer had gotten sluggish.
I investigated by running FileMon and it showed that jbidwatcher was constantly writing to .jbidwatcher/derby.log. My derby.log was 4 GB! Which is very surprising because I only have about 60 auctions I was watching. I never saw t his behavior on older release of jbidwatcher.

Avatar JS 3 post(s)

Hi, I was using 2.0.1 previously, and saw some auctions with FP (and your note that is one of the issues), so I upgraded to 2.1pre4.

2.1pre4 showed FP, so I erased the old .jbidwatcher configuration directory, launched it again and redid the configuration from fresh install state. Still showing FP on actual auctions, all on “Seller A”, I can’t see any difference in the listings themselves (both sellers have them as auctions).

220476060375 – FP seller A
380155740043 – ok seller B
220476173588 – FP seller A
380155752240 – ok seller B
220476196382 – FP seller A
220476197410 – FP seller A

Running Ubuntu Linux 8.04.3
Avatar stefanc1982 3 post(s)

Hi there,
Long time user, first time poster. I love this app. I started using 2.1pre4 after the issues with the seller ID in 2.01.

Anyway, the reason for my posting today is that I am having issues adding certain items to my auction list. Examples include auction #’s 250495718178 and 260474492441. Interestingly, I am able to add other items from this seller (i.e. auction #260474479420 and 260474479963).

Going to the error log, the error I am getting when adding these items is as follows (example for item 250495718178):
Sat Sep 12 18:23:55 EST 2009: Failing to insert “292278994-08-17 17:12:55” into column ending_at (17) of table auctions
Sat Sep 12 18:23:55 EST 2009: PMQ Caught exception: java.lang.IllegalArgumentException: Timestamp format must be yyyy-mm-dd hh:mm:ss[.fffffffff]
Timestamp format must be yyyy-mm-dd hh:mm:ss[.fffffffff]
at java.sql.Timestamp.valueOf(Unknown Source)
at com.jbidwatcher.util.db.Table.setColumn(Table.java:441)
at com.jbidwatcher.util.db.Table.storeMap(Table.java:331)
at com.jbidwatcher.util.db.Table.updateMap(Table.java:266)
at com.jbidwatcher.util.db.Table.insertOrUpdate(Table.java:253)
at com.jbidwatcher.util.db.ActiveRecord.saveDB(ActiveRecord.java:116)
at com.jbidwatcher.auction.AuctionInfo.saveDB(AuctionInfo.java:514)
at com.jbidwatcher.auction.server.ebay.ebayAuction.parseAuction(ebayAuction.java:480)
at com.jbidwatcher.auction.server.AuctionServer.doParse(AuctionServer.java:272)
at com.jbidwatcher.auction.server.AuctionServer.loadAuction(AuctionServer.java:216)
at com.jbidwatcher.auction.server.AuctionServer.create(AuctionServer.java:137)
at com.jbidwatcher.auction.AuctionEntry.prepareAuctionEntry(AuctionEntry.java:215)
at com.jbidwatcher.auction.AuctionEntry.(AuctionEntry.java:250)
at com.jbidwatcher.auction.AuctionEntry.construct(AuctionEntry.java:267)
at com.jbidwatcher.ui.UserActions.addAuction(UserActions.java:57)
at com.jbidwatcher.ui.UserActions.cmdAddAuction(UserActions.java:118)
at com.jbidwatcher.ui.UserActions.handleStringMessage(UserActions.java:85)
at com.jbidwatcher.ui.UserActions.messageAction(UserActions.java:71)
at com.jbidwatcher.util.queue.PlainMessageQueue.run(PlainMessageQueue.java:55)
at java.lang.Thread.run(Unknown Source)

I’m running Windows Vista. I tried doing what another user did (renaming the config folder effectively recreating the config folder) but this made no difference.

Hope there is either a simple fix or you can fix it.

Thanks for creating such a terrific piece of software.


Avatar stefanc1982 3 post(s)

Oops, I left out the critical error line:
Sat Sep 12 18:23:55 EST 2009: Failing to insert “292278994-08-17 17:12:55” into column ending_at (17) of table auctions

(I’ve now added this line to the post above).

FYI, a friend of mine (from the UK) was able to replicate this issue.

Avatar radar9628 1 post

Hi Morgan,
I used your app several months ago and just pulled it up yesterday. I downloaded the new release but 99% of my attempts show this error box: Can’t access auction database. JBidWatcher can’t access it’s database. Please check to see if you are running another instance. OK. I’ve done a soft boot and made sure it was shut down and then tried to boot it again. Same results. I’m NOT a programmer, so help for the non-geek is appreciated.

Avatar RCalistan 37 post(s)

@stefan – this was supposed to be fixed in pre4. I’m getting the same error and it’s due to that seller’s template and ebay’s formatting. or something like that which Morgan needs to fix.

@radar9628 – you’re probably bumping into your old install somewhere/somehow. i’d clean out the old files (see the FAQ for location) and give it a whirl then.

Alternatively, if you do DOS, you can force it to a certain directory by changing to that directory and running jbidwatcher with the “—usb” (no quotes on the command-line) command-line option. jbw will then create a .jbidwwatcher subdirectory in the current directory for its store.

Avatar stefanc1982 3 post(s)

Thanks Richard. For the record I won the auctions I was keen on anyway, even without the much loved bidwatcher doing the hard work ;)

Avatar Dave Partridge 2 post(s)

Hmmm I just installed this new release, and noticed something odd.

A lot of my items for sale are being shown with (FP) after the current bidding level even though they are NOT “Buy it now” auctions. The same is true of an item I am bidding on, that is also not a “Buy it Now” item (I hope this won’t stop JBidWatcher sniping on it). An item I have on sale as “Buy it Now” or “Best offer” has (1) after the price.


Avatar Dave Partridge 2 post(s)

I just uninstalled and reinstalled, and deleted the .jbidwatcher directory. Now things appear OK, except the price of my “Buy it Now” or “Best Offer” item is shown as null.