[PreRelease] JBidwatcher 2.1pre4 is out

Subscribe to [PreRelease] JBidwatcher 2.1pre4 is out 98 post(s), 44 voice(s)

← Previous 1 3 4
Avatar Morgan Schweers Administrator 1,204 post(s)

I’ve pushed a new pre-release, fixing a great many bugs in the 2.0.1 version with regards to eBay’s latest changes, as well as cleaning up most of the issues that folks found in the earlier pre-releases. This is 2.1pre4-1010.

  • If you’re running Mac OS X: http://www.jbidwatcher.com/alpha/JBidwatcher-2.1pre4.dmg
  • If you’re running Windows, a standalone version of the pre-release for the next version is here: http://www.jbidwatcher.com/alpha/JBidwatcher-2.1pre4.exe
  • Also for Windows, there’s an installer available that sets it up nicely: http://www.jbidwatcher.com/alpha/JBidwatcher-2.1pre4-Installer.exe
  • If you’re running Linux, get it at: http://www.jbidwatcher.com/alpha/JBidwatcher-2.1pre4.jar

I appreciate, and need any and all feedback! If things seem to be going well, I’ll be releasing this as the final 2.1 release, so this is the last chance to point out problems, big and small. I might not get around to fixing small problems, but they’ll go into my queue for 2.2!

Show-stoppers (multisnipe not canceling later items, sniping failing to fire, bids or buying not working, specific item numbers that don’t load), or anything consistently replicable are especially important.

— Morgan Schweers, CyberFOX!

p.s. Things are still a bit rough for me; I’ve been getting by though, thanks to donations from my amazing users (that’s YOU!), and I’ll soon be showing off some potentially neat features for people who’ve sent me contributions this year. I’ll be saying more when the final 2.1 is released. There’s a hint in the Configuration Manager… :)

Avatar Dolphin 5 post(s)

Hi Morgan,

Thanks for this great application.

I’ve been holding off registering to see if an issue I’d noticed would be fixed, but it doesn’t seem to have been. I’m running 2.1pre4, but item 200365249203 on ebay.co.uk is showing as a sold price of 29.99 whereas the web page shows 149.99. I’ve double clicked the auction, and JBidwatcher say it’s updating, but the sold price doesn’t get updated. I’m not sure what version I was running when this auction finished, but it may have been 2.0. I see that this auction has “The seller of this item is away until …” which others don’t – maybe this is what’s confusing JBidwatcher?

Hope this helps,


Avatar wiesel 7 post(s)


I’ve just installed 2.1pre4 on Linux and tried to add items. It’s not possible and I get the following error:

Sun Aug 09 11:50:40 CEST 2009:
  Failing to insert "292278994-08-17 08:12:55"
  into column ending_at (16) of table auctions
Sun Aug 09 11:50:40 CEST 2009: PMQ Caught exception:
java.lang.IllegalArgumentException: Timestamp format must be
  yyyy-mm-dd hh:mm:ss[.fffffffff]
    at java.sql.Timestamp.valueOf(Timestamp.java:194)
at com.jbidwatcher.util.db.Table.setColumn(Table.java:441)
at com.jbidwatcher.util.db.Table.storeMap(Table.java:331)
at com.jbidwatcher.util.db.Table.updateMap(Table.java:266)
at com.jbidwatcher.util.db.Table.insertOrUpdate(Table.java:253)
at com.jbidwatcher.util.db.ActiveRecord.saveDB(ActiveRecord.java:116)
at com.jbidwatcher.auction.AuctionInfo.saveDB(AuctionInfo.java:514)
at com.jbidwatcher.auction.server.ebay.ebayAuction.parseAuction(ebayAuction.java:480)
at com.jbidwatcher.auction.server.AuctionServer.doParse(AuctionServer.java:272)
at com.jbidwatcher.auction.server.AuctionServer.loadAuction(AuctionServer.java:216)
at com.jbidwatcher.auction.server.AuctionServer.create(AuctionServer.java:137)
at com.jbidwatcher.auction.AuctionEntry.prepareAuctionEntry(AuctionEntry.java:215)
at com.jbidwatcher.auction.AuctionEntry.(AuctionEntry.java:250)
at com.jbidwatcher.auction.AuctionEntry.construct(AuctionEntry.java:267)
at com.jbidwatcher.ui.UserActions.addAuction(UserActions.java:57)
at com.jbidwatcher.ui.UserActions.cmdAddAuction(UserActions.java:118)
at com.jbidwatcher.ui.UserActions.handleStringMessage(UserActions.java:85)
at com.jbidwatcher.ui.UserActions.messageAction(UserActions.java:71)
at com.jbidwatcher.util.queue.PlainMessageQueue.run(PlainMessageQueue.java:55)
at java.lang.Thread.run(Thread.java:619)

I’m logging in from Germany. I just started JBW using the jar file and looked for an item to test the new version. Item id was: 180392083264.

Anything I can do?

Thanks a lot!

Avatar zappram 290 post(s)

I installed Pre4 on Mac OSX 10.5.8 – works well, the Pre3 works well enough for me to use, to snipe, to multi snipe and I won a few things. Now I need to see how Pre4 works, so far, no issues I can see on the Mac side. Keep up the good work. Thanks.

Avatar Dolphin 5 post(s)


Just noticed something else. Item 150363215353 on ebay.co.uk started with a Buy it Now option, but that was cancelled once it was bid on. In 2.1.pre4, this item is showing the Buy it Now symbol in the Status column, and in the “Show Infromation” window, it says “Or you could buy it now, for £1.00.” As the auction says, the original Buy it Now was £125.

I seem to recall I noticed this “Or you could buy it now, for £1.00.” bug with 2.0, even before ebay changed it’s page format.



Avatar Morgan Schweers Administrator 1,204 post(s)

@Dolphin – Replicated; I’m not sure what’s broken right now. :( I’m looking into it. There’s no ‘registering’ necessary, btw. I appreciate the donations folks send me (and I’m living off them right now), but the program is free and fully functional…well, when it’s functional. :(

@wiesel – I’m unable to replicate that; it adds to my JBidwatcher correctly. You’re running it on Linux, right? You could do this:

bash$ unzip JBidwatcher-2.1pre4.jar main/main.jar
bash$ java -cp main/main.jar com.jbidwatcher.app.JBTool 180392083264

That should dump a block of XML which looks (roughly, formatting is fubared) like this:

Marc O’Polo PoloShirt orange Vintage Gr S 36/38 Neuwert hortensie 2157 100 1249840800000 1 Bremen, Germany 6***0 current

You should see an ‘end’ tag, with 1249840800000 in it. If you do this:

bash$ ruby -e ‘puts Time.at(1249840800000/1000)’

it should give you something like (depending on your time zone)
Sun Aug 09 20:00:00 CEST 2009

Let me know if you get the same results!

— Morgan Schweers, CyberFOX!

Avatar hillersa 1 post

Dear Morgan,

thanks for the Pre. Paypal, seller names and Price, are updated now (I’m on German Ebay). Just small a bug though: When I review the amount I want to snipe (having ‘subtract shipping’ turned on), shipping costs are not added again, so my actual snipe is lowered everytime I open ‘initiate snipe’ and hit OK.

best regards, André

Avatar wiesel 7 post(s)

Hi Morgan,

I solved my problem by renaming my old config folder so JBW was set up completely new and everything was working again. I do not know exactly what went wrong – perhaps some config from older versions lead to the error. But I think it’s not worth to put more effort into it since it is working. The info of older auctions is lost but – so what, it’s fine. Perhaps I can shift something from the old DB information.

Just in case it might be interesting here the results from what you suggested to do:
1. I did the unzip
2. java -cp main/main.jar com.jbidwatcher.app.JBTool 180392083264
Exception in thread “main” java.lang.NoClassDefFoundError: com/jbidwatcher/app/JBTool
Caused by: java.lang.ClassNotFoundException: com.jbidwatcher.app.JBTool
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
Could not find the main class: com.jbidwatcher.app.JBTool. Program will exit.

That’s where I ended up trying what I already mentioned since I only wanted it running.

Thank’s a lot for doing such a great job!

Avatar SurfaceCleanerZ 13 post(s)

Hi Folks,

Thank you Morgan for the great new version. I’ve updated my 1.02 to the new version and adding was impossible. The reinstalled Sun JRE and the same. The deleted my profile folder and the auctions.xml and it works. Seems to be the same as wiesel wrote above.

An bid and a snipe worked on ebay.de!

Auctions were added to the correct folders, Multisnipe worked and update also.

The only bug I have with this version (as before) is that doubleclicking an auction won’t open the auction in browser, as I configured. But that is not a huge problem, because rightclicking and open in browser works.

I didn’t have a look at the shipping costs…probably I had the problem, too.


Avatar Cloversmate 2 post(s)

Hi Morgan,

I’ve Just been having many problems with Bidwatcher 2.0 following recent Ebay changes.
Sniping not working, difficult to add new auctions etc.

I’m using Mac Os-X 10.5.8. New rel 2.1 beta today seems to have solved most of the current problems. Thank-you. Nice to be back bidding again.

I’ll be making another donation to help support this great project, and help keep it moving forward

Paul / Cloversmate

Avatar Morgan Schweers Administrator 1,204 post(s)

Thank you all!

I’m afraid I’ve been offline today; Sundays are my day to give my wife a break and let her do what she wants all day while I take care of everything, especially Corwin. :) It’s a tradition from when I was employed, and we’ve kept it up, even though I’m helping out during weekdays currently. It does, however, mean no computers since he’s too young (15 mo. last week!) to really let daddy type without wanting to bash on the keys himself. :)

I’m especially interested in auctions that aren’t loading, data that’s not populating, and problems that go away when you rename/delete the .jbidwatcher directory. For the latter, I’m concerned that there may be some overrides out there still. Overrides basically replace some of the parsing with special patterns. Sometimes folks put them up as an interim solution, sometimes I push them out using the update mechanism to solve a problem. However, if they aren’t removed, they can get out of date.

You can see if you have any overrides in place by pulling up the Configuration Manager of JBidwatcher, and going to the Advanced tab. If you enter override in the Configuration Key area, and it pulls anything up, you want to click the Delete button just under the Configuration Value field. Keep doing that until typing override doesn’t pull anything up. Then Save and restart JBidwatcher. If you don’t have any overrides in place, and renaming the .jbidwatcher directory still helps, PLEASE let me know.

So, to specific issues…

@wiesel – It feels like that date is a parsing error coming from the JBidwatcher configuration, especially with the success of renaming the old folder. I’d love it if you could grep your old .jbidwatcher/JBidWatch.cfg file for override. If not, there’s got to be something messed up about the database. :( As for the error running the JBTool, I’m presuming that it didn’t find main/main.jar unfortunately. Still, it sounds like you’ve got a good workaround.

@Dolphin – Interesting; it may be picking up some of the seller’s text and thinking that it indicates a Buy It Now auction. I’ll dig into that item #.

@hillersa – Interesting! I think I follow what you’re describing. I’ll look into it.

@SurfaceCleanerZ – Have you configured double-click to open-in-browser in the General configuration?

I’m glad 2.1pre4 is mostly working for folks! It’s a big relief after a few weeks of tension, while I tried to figure out all that had to get fixed…

I’ll work on these problems, and others that have been reported over the last day (especially what must be a stupid delete issue), and try and get another (maybe less widely spread) pre-release out with those fixes.

Crossing my fingers and hoping, it’s possible I might have two interviews this week, which would be promising.

— Morgan Schweers, CyberFOX!

Avatar David E 4 post(s)

p.s. Things are still a bit rough for me; I’ve been getting by though, thanks to donations from my amazing users (that’s YOU!)

Well I for one am very happy with this program, and appreciate the speed in which bugs are being rootled out and exterminated! I hope my small donation (just made) encourages you to continue. I would also not be adverse to paying a small annual fee to ensure continuous maintenance, if that were ever proposed.

Avatar jc_lbc 1 post

I’m having problems with the new version (as well as the older versions) on my MacPro. I can’t get jbidwatcher to update my list of watched items no matter what I seem to do. I’ve deleted all the prefs/config files I could find and opened it and reconfigured everything from scratch yet still all I get is one item I won last week under the “current” tab and one item I won last week in under the “completed” tab. Oddly enough, upgrading to the latest pre version worked great on the iMac I have at work but I’m getting diddly squat here at home. Both machines running the latest vs of OSX. Any suggestions?

Avatar zappram 290 post(s)


Similar to jb_lbc
After I tried JBW 2.1Pre4, it no longer automatically load any of my new WATCH items (intel iMac 10.5.8 with latest all sw updates). I tried to load 2.1Pre3, it won’t load up my WATCH items no more either. Only shows a yellow pop up banner bar of (103 watch items, 92 new items).

Dragging items from eBay listing to JBW works. Why did it work on Pre3 and all of a sudden, not working for me after I tried Pre4. Now that Pre3 won’t work either.

However, I did win a few nice snipes when 2.1Pre3 was working for me earlier. ;)

Avatar OzoneTom 4 post(s)

I just had a multisnipe that correctly cancelled remaining snipes after one succeeded, so can confirm that fix works. Thanks.

Avatar wernerflamme 2 post(s)

Hi Morgan,
with a new version, I am always excited what may happen when I use “Get My eBay Items”. It works like a charm, without having to change .jbidwatcher (what I had to do several times when switching to 2.0).

A new tab appears, two items inside: the one I am bidding on (and want to snipe ;-)), and the other (290331299840) is an auction that ended on July 19th and appears in the “You Have Bought” section of the page (don’t know the exact english name of the section since I use ebay.de in german language).

So for the moment JBW 2.1pre4 works on openSUSE 11.1 x86_64 with Sun’s “Java™ SE Runtime Environment (build 1.6.0_15-b03) Java HotSpot™ 64-Bit Server VM (build 14.1-b02, mixed mode)”.

Thanks for this fine piece of software!

Avatar acc 1 post

Several problems with multisnipe to report: Menus disappear when I do a multisnipe but can get them back if I do a snipe from the icons. I also had a problem where an item already had a snipe then I did a multisnipe of that item and another for $26… the first item showed at $26 and the second showed at $25 and both showed as multisnipe members. I deleted snipes and recreated multisnipe and price showed correctly on both auctions. I am at latest version of OS X.

Thanks for the great work!

Avatar gurumarkb 22 post(s)

Congrats on the hard work! I really like the new 2.1pre4 1010 version. From the yellow bar that comes up to tell me how many items it’s importing from my watch list, the items won being moved correctly to my won tab and in the correct blue color, the seller name being shown properly, to the multisnipe function ending all snipes after I win 1 of them, this version of Jbidwatcher is a winner. The only thing I found not working for me so far is that if I highlight multiple items and press DEL, only the 1st item is actually deleted so I must delete a group 1 by 1, but since this is a pre version you are probably already aware of this. I’m giving a resounding 2 thumbs up to Morgan for his hard word and dilligence.

As always PLEASE DONATE to keep the Jbidwatcher project alive.

Many thanks Morgan !

Avatar Dolphin 5 post(s)

Hi Morgan,

I’ve noticed that often when I first run JBidwatcher in the morning, it will start updating the current auctions, then it seems to get stuck. Double clicking an auction does not cause it to be updated – no new message appears at the bottom of the JBidwatcher window and the auction number does not change to the updating colour. In these circumstances, there is always a message at the bottom of the JBidwatcher window saying "Updating " where is one of my current items. { EDIT : not always, sometimes it has "Done updating "} In these circumstances, before this issue occurs, JBidwatcher has been able to get the sign in cookie, and has successfully updated some of the auctions. If I close and restart JBidwatcher, the problem is usually cured. My theory is that JBidwatcher is getting stuck updating an auction, and so cannot move on to other auctions, or respond to manual update requests. { EDIT : my previous edit tends to suggest this theory is wrong}Unfortunately, I’ve not checked the error or activity logs when this happens before closing the window. However, I did check the configuration, advanced, override (before closing the window), and the config value was blank.

I have another completed auction item that won’t update the current (=sold) price – 310161049265 on ebay.co.uk. JBidwatcher shows £24.00 (FP) on my machine, whereas the listing was an auction with a final price of £169.00. If it had been a fixed price of £24 it would have been a bargain ;-)

Summary of my PC:
Windows XP SP3 plus all critical updates
Sun Java version 6 update 15 (1.6.0_15-b03)

JBidwatcher is still a great and very handy application – thanks for all your hard work.

Avatar JeremyT 3 post(s)

Morgan, I have a couple of cosmetic issues, though the core functionality seems to be working great for me now. I’m running on Linux with the 1.6 Sun jre.

Here is what I’m seeing:

- When attempting to delete a group of auctions, they still remain in the GUI. Once I restart the application, they are properly removed. (This bug seems to have first appeared in the 2.1pre* releases)

- I am unable to delete tabs permanently. Although I can delete a tab and it will be removed from the current session, it always re-appears when I close and restart the application. (This bug predates 2.1pre*)

Thanks for all the hard work!

Avatar SurfaceCleanerZ 13 post(s)

Hello Morgan,

>@SurfaceCleanerZ – Have you configured double-click to open-in-browser in the General configuration?
Yes of course! I set it correctly under Configure!
But it works very seldom… It fails not always, but most times…

I had this problem on 2 machines running Win XP pro with latest Sun JRE and the .jar version.


Avatar eu 2 post(s)

Hello Morgan,

I used 2.1pre4 in germany and it worked.
Then I used it again and got a strange effect. I used sniping on an auction. Then, maybe 2min before the end of the auction, I increased my sniping amount. It turned blue, as if i had won the auction. yet bidwatcher had used the old, lower amount and i lost the auction.


Avatar greenbyte 1 post

@wiesel: had the same prob. I removed JBidWatch.cfg and display.cfg restarted, entered user and pass – now it works. All old auctions still there :).
And thanks to Morgan for his great work.

Avatar Dolphin 5 post(s)

IGNORE – both these issues have corrected themselves. Not sure why I was having this problem, but I have a low powered single core 1.6GHz PC.

Hi Morgan,
Doesn’t seem to pe parsing Buy It Now’s correctly. Item 230348680589 on ebay.co.uk, JBidwatcher reports “Current = null(7)” and “Shipping = —”, whereas in fact it’s a Buy It Now for £799 or Make Offer (there have been 7 offers), Postage = £4.99. Admittedly, sniping a Buy It Now/Make Offer seems a bit pointless, but I put auctions like this into JBidwatcher to keep track of if they sold, and what they actually sold for.

Also item 260462666448 was a Buy It Now at £150, but JBidwatcher reports it went for £100. Postage (Shipping) is reported correctly.

Just noticed a new tab called “recovered” with item 190326582470 (correctly reported by JBidwatcher) in it.


Avatar dengel 10 post(s)

Installed 2.1pre4 on Windows and so far it is working nicely (I am in Germany). However, two small questions:

1) When I do a sync with My Ebay in JBidwatcher, it seems it only imports the items from the first page. However, I am watching more items that can fit on one page (more than 25), and JBidwatcher doesn’t seem to be able to import those which are on page 2 or greater.

2) Items from My Ebay now get added to a new “My Ebay” tab. I liked the old behavior better, where everything was added to “current”. I know I can send the items manually to “current”, but it would be nice if this could somehow be automated.

Anyway, thanks for this new version!

← Previous 1 3 4