My current tasks, ordered by priority

Subscribe to My current tasks, ordered by priority 24 post(s), 10 voice(s)

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

  1. Interactive Bid/Buy fails under some JRE versions
  2. JBidwatcher 2.1pre2 isn’t getting the high bidders because eBay’s not showing them on the front page anymore
  3. Deleting items doesn’t appear to remove them until JBidwatcher is restarted and other delete problems
  4. There’s some kind of a FORM parsing error when getting My eBay items for some users
  5. Items I’m Bidding On don’t appear to be loading for some users
  6. Fix snipe failure (underbid) recognition errors (may be fixed already)
  7. JBidwatcher doesn’t move resurrected listings back to ‘current’
  8. Items showing up in the web interface that aren’t in the UI (some duplicates)
  9. Unable to identify when PayPal is offered or not (isn’t it mandatory now?)
  10. ‘Set Shipping’ dialog uses the InfoHTML, and can become too large for display with a lot of connection errors.
  11. Make sure every toolbar entry has an equivalent menu entry.
  12. Changing users while JBidwatcher is running doesn’t work quite right.
  13. Provide an ‘Action’ button column, for folks who don’t want to use the right-click menu, which just pops open the context menu whenever it’s clicked on.
  14. License pop-up on first startup.

This is always in flux, but these are the things I really want to work on and get working right now.

— Morgan Schweers, CyberFOX!

 
Avatar gstuart 15 post(s)

With jbw2.1pre2, the strangest bug I’ve noticed is the delete action. I try to delete one line and the whole
page vanishes. After I recover the data to keep it is doubled , try again and it’s tripled. Bid and snipe seem to
work OK. “Get eBay items” seems to get some items and not others. The check mark for winner has not come back yet. Most useful data now is the converted closing time. FYI not a gripe.
iMac intel, Tiger; G4 PCC, Tiger. & jbw2.1pre2

 
Avatar arva 3 post(s)

In addition to corruption of ‘Get My eBay Items’, the ‘Seller’ is now listed as ‘unknown’ for all citations. For unknown reasons, JBW started circa one month ago to download only about 25% of the items listed on my eBay personal page as ‘Watching’. Finally, if I run ‘Get My eBay Items’, Menu Meters on my MBP / OS 10.5.7 indicates ‘runaway’ CPU activity. Must close and restart JBW in order to free CPU. Have reloaded current version JBW, but no change. Suggestions?

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
@arva – All three of those issues are reported to be resolved with the 2.1pre2 alpha/pre-release which is why they’re not included above.

@gstuart – Yeah, I’ve fixed the delete issues now. The check mark for winner (that is, high bidder detection) is taking a lot of work, unfortunately.

Hope that helps!

— Morgan Schweers, CyberFOX!

 
Avatar gstuart 15 post(s)

I wanted to agree with you that “delete” had been fixed. I tried it on some recovered,
meaningless items today and jbw deleted as programmed; then tonight I wanted to
check again- – -about 8 lines on the recovered page, so I chose one, the safe delete
warning dropped down (very narrow one line which had to be dragged to expand to
legibility ); so click to delete- – shazam! 5 items gone at once ! ! That ain’t right and
I suspect the skimpy “safe delete warning” has to be tended to. FYI , Morgan, – -
not griping.

 
Avatar gstuart 15 post(s)

Now “send to. . .” don’t work. Nothing was sent , it just vanished. . ? ? !! ?. . ..
I can’t get any auctions to try JBW on . .!!!

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Uh; sorry. By ’it’s been fixed’, I mean I’ve found the problem and fixed it, not that I’ve released a new version that has the fix in it. The sizing of the delete window was resolved as part of that, but again, it’s the fix isn’t in an available pre-release yet.

I’m trying to fix high bidder recognition right now; it’s critical to get that fixed before I do the next pre-release.

— Morgan Schweers, CyberFOX!

 
Avatar gstuart 15 post(s)

Misundertood you. I was trying to help you catch up on time stressed
testing. But you’ve done that and I’ll shut up and be a cheer leader.
JBW is still good even when it’s broke.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Give me an item number that doesn’t get added by 2.1pre2 if you try to add it by hand?

— Morgan Schweers, CyberFOX!

 
Avatar zappram 290 post(s)

item# 310157247424

or any items by this seller (olympusauctions)

Thanks

 
Avatar zappram 290 post(s)

I can add manually other items, however, not with this seller who maybe is using their own way to link to eBay as they also have automatic way to add positive feedback if you leave them a positive feedback immediately.

I suspect they are their onw DB that links to eBay, and somehow JBW does not or cannot look up from those items that’s listed on the seller’s DB. I cannot explain well as I don’t know enough. Sorry. All I know is that I can manually drag other items to JBW from Firefox 3.5.1 but not any of the items from this seller. Hope I made it clear enough for you.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
@zappram – Thanks! I was able to find a fix for that problem.

@gstuart – Do you have any item numbers that are failing?

— Morgan Schweers, CyberFOX!

 
Avatar gstuart 15 post(s)

one particular # would not load; e.g.: 230360405202. I tried others
today and they did load under “current” tab. Still odd action on “get my
eBay items”.

 
Avatar Destro 8 post(s)

Sometimes, items I’m selling show up on the “Current” tab. Is that a known issue?

I have 17 auctions going right now, and 1 of the items is on the Current tab, zero on the “Selling”, even after “Get selling”. I’m running 2.0.1

What is the recommended version right now?

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
@Destro – That’s a known issue; it has to do with 2.0.1 not picking up seller names, and therefore not knowing it’s you.

The ‘recommended version’ is in limbo right now; the 2.1pre2 is pretty good for some things, but is missing some features as I work on fixing them.

I’m trying to get a new pre-release out with a lot of fixes, but it’s getting up to 100 degrees and 70% humidity here. Seattle’s having a heat wave, and it’s really hard for me to program in those kind of conditions. (Heck, it’s hard for me to have a coherent thought.) Add to that, my primary dev system (a 3-year old MacBook Pro) shuts off abruptly when it overheats, and it’s…challenging for me to be developing right now. I’m pushing through and fixing bugs, though. Hopefully I’ll have a new pre-release for this weekend, but it won’t fix all the open 2.1pre2 problems. (Specifically high bidder detection may have to wait another pre-release.)

— Morgan Schweers, CyberFOX!

 
Avatar dtech 6 post(s)

Hi, just to advise you that JBidwatcher-2.1pre2 is now seeing item bids or amount as (FP) fixe prices an does not let me snipe anymore only buy option thanks

 
Avatar erichard 2 post(s)

I just noticed the same problem as dtech (FP on all items, no sniping possible). Nice program though. Thanks.

 
Avatar Wolop 5 post(s)

Happened here(UK) too with 2.0.1 on XP

Loaded 2.1pre2, Still shows FP on all items.

Can not setup (multi)snipes by selecting and right mouse.

BUT as a work round can use Auction menu to setup (multi)snipes.

Have not had any item won yet but the I’ve not bid high enough since changing versions so have yet to see if the snipes are actually working.

 
Avatar Wolop 5 post(s)

Also works in JBidwatcher (2.0.1-825) : As a work round can use Auction menu to setup (multi)snipes.

 
Avatar Destro 8 post(s)

Wow, 100 degrees? Is that unusual in Seattle? I have some friends in Huntington Beach who don’t have air conditioning, because it’s 72 degrees there all the time. Do people in Seattle not have AC also?

Here in KY, we’re having the coolest summer in my lifetime (a little less than 40 years :-) )

 
Avatar RCalistan 37 post(s)

dtech, erichard, wolop, etc….

Check out the “Most auctions appear as FP” thread in the Help forum. I post work-arounds there….

 
Avatar pascal 1 post

It seems that auctions appearing as FP are auctions where Paypal is the preferred payment choice.

Morgan, JBidwatcher is an excellent work

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
I’ve got a pre-release (2.1pre3) to address the (FP) problems posted here and am continuing to work on other issues.

@pascal – Thanks!

@Destro – You hit it pretty much on the head; we have fans, and that’s about the extent of our cooling, because our area almost never gets this kind of thing (we hit record temps when I posted that message above). For me, the problem is the heat; I never function well in >85 degree (Fahrenheit, of course) weather. For my wife, who grew up in the California desert, it’s the humidity, which leaves her feeling like she’s walking through water to get anywhere. For my 15mo. old son…well, it’s the dehydration of high heat, mainly. For my wife and I, it was just uncomfortable and frustrating. For him, we punted and went to stay in a motel a few hours away for a day or so, as he was starting to have serious problems regulating his temperature and keeping hydrated. Not good. :( He’s loved the getaway, and the 24hr air conditioning. Things are getting back to ‘normal’ at home though, and it’s painfully expensive to stay out, so we’re heading home tomorrow.

I’ve been reading everything folks have been writing, and trying to keep a tally of the issues which are cropping up while I knock down other ones. There’s an unfortunately large amount to do, yet. I’m still plugging away at it, though.

— Morgan Schweers, CyberFOX!