New test version 1.0.2pre3

Subscribe to New test version 1.0.2pre3 35 post(s), 26 voice(s)

← Previous 1
Avatar Morgan Schweers Administrator 1,204 post(s)


This build should improve performance a little, and recognition a lot. It also should eliminate the problem with stores items showing up as 30-days-left first, and on first update turning into N/A-end-date listings.

It also changes the context menu, so Bid isn’t right below Snipe, and adds an ‘Advanced’ menu off the context menu for setting items to ‘Not Ended’ that JBidwatcher incorrectly identified as ended.

I also added a new menu item in the File menu for clearing out the deleted items list, as that’s evidently a common cause of memory overload.

This version is built with Java 1.4.2. PLEASE try these out, and let me know any issues which come up.

OS X :

Linux :

Source code :

Windows :

Let me know how it works!

— Morgan Schweers, Cyber*FOX*!

Avatar Morgan Schweers Administrator 1,204 post(s)


Sorry; minor network issue prevented them from getting up there until now.

They should all be available now, though.

— Morgan Schweers, Cyber*FOX*!

Avatar serenity 1 post

Hi there

On Linux with JRE 1.6 the 1.0.2 pre-1 would not add an auction (perhaps because if was hours from finishing) although others (days from finishing) added happily, but the Pre-3 has solved that problem. I am a very light user, but it seems to be working fine. Thanks for your efforts.

Regards, Phil Stephens.

Avatar tlc 1 post

I am using 1.0.2pre3 with OS-X 10.2.8
sniping away just fine, thank you.

ooops… as of this morning it is back to not letting me add auctions. (and all red-eyes on existing ones.

Avatar mark 1 post

I am using 1.0.2pre2 with XP seems to be fine.

Avatar Hoddy 108 post(s)

Hi, It looks like eBay (UK) have made more changes at 9:00 BST as I’m now back with a bad case of “Red Eye” in the status column. I’ve tried both 1.0.2pre2 & 1.0.2pre3 with the same result. Is it just me or Worldwide?

Regards Hoddy

Avatar sts 4 post(s)

Everything was ok this morning with 1.0.2pre2 (win xp) on ebay FR
Since a few minutes ; no more updating.
I upgraded to 1.0.2pre3 and no auction update anymore …

Avatar sts 4 post(s)

“Red eye” for me too !

Avatar Hoddy 108 post(s)

Sorry, I should have also mentioned that JBidwatcher is no longer updating the auctions, won’t add new auctions and all (FP) auctions over 7 days have a N/A in the time left.

Regards Hoddy

Avatar Frank P. fro... 71 post(s)

… yes-terday (beatleshumming)…
1.0.1pre2 worked,
when I got up this morning, red eyes again… installed 1.0.1pre3: doesn’t work as well
auction time left shows up correctly
red eyes
no bids updated, sticks on the highest bidder and its bid from yesterday

Avatar Frank P. fro... 71 post(s)

sry: 1.0.[b]2[/b]pre 2 and 1.0.[b]2[/b]pre3, not 1.0.1pre…

Avatar shedman 1 post

Updated to 1.0.1pre3 about 8 hrs ago – worked great. restarted my iMac about half an hour ago – back to square one with no auction updates, failure to recognise my bids for “private listing” bids

Avatar r2d2hp 8 post(s)

Same for me as well, seemed to stop working sometime between midnight and 09:00 this morning.

But have noticed that US auctions do not have a Red Eye

Avatar ausdeutsch 2 post(s)


Using JbidWatcher on SuSE linux. So far so good.

Great work Morgan! Thank you

Avatar Frank P. fro... 71 post(s)

… just tested: adding auction result :

“An Error occured”
“Cannot add auction ########, either invalid or communication error talking to server”

just as the 1.0.1 produced yesterday (no message when drag&drop auction url from browser, but no success as well ….)

BTW: when adding bid via “adding” or adding comments, the cursor focus is never on the input line, quite a confusing behavior …)

Avatar elektr4 2 post(s)

Here it works with 1.0.2pre2 (OSX 10.4.10) until this morning.
Now “red-eye” grr again and cannot add auction.
pre3 doesn`t help… sorry!

Nevertheless: Good vibes from overseas Morgan,
and … Thanks for all! :-*

Avatar steve_harris16 4 post(s)

Hi, I have tried every Windows version of JBW that I have on my PC (on the off chance that eBay had removed their recent changes) & none of them work unfortunately. 1.0.2pre2 worked fine a few hours ago. Now, no updates & no additions again.

Thanks for all your efforts though Morgan, much appreciated.

Avatar largeous 5 post(s)

red eye for me to

Avatar ausdeutsch 2 post(s)

Red eyes and error messages for me too now – Linux – SuSE

Failed to parse auction! Bad return result from auction server.
Failed to load auction title from header:

Alas! Thanks for efforts so far . . .

Avatar tricke 2 post(s)

thanks for trying to solve the problems quickly, Morgan. I’m having the same issues as steve_harris16 on windows, if i can help in some way let me know.

Avatar huntz 6 post(s)

Damn ebay! Again another change! :-/

I confirm too the “Failed to parse auction! Bad return result from auction server.” error.

Tested under Mac and Linux (on,,

Thank you.

Avatar hawkeye 25 post(s)

Hi, just tried pre3 failed to load any ebay items, switched back to pre2 just the same, not getting any auctions at all. Mac OS10.4.10

Avatar tonitonitoni 1 post

Same thing with
Sun Jul 22 12:55:37 CEST 2007: Failed to load auction title from header: “HP Scanjet 3400C – (item 320138004352 end time Jul-22-07 07:48:16 PDT)”
Sun Jul 22 12:55:37 CEST 2007: Failed to parse auction! Bad return result from auction server.
Sun Jul 22 12:55:37 CEST 2007: Not loaded (url

(JBidWatcher-1.0.2pre3 & java 1.4.2_13 on Kubuntu)

Avatar zc-cruiser 4 post(s)

Same for eBay Australia with pre3 – red eyes.
Can still make bids but no updated information displayed

Avatar Heiner 2 post(s)

Here in Germany eBay was not able to forbid sniper programs, because their profits must not be guaranteed. (I am even 100% sure, that their profits decrease without sniper programs) I am nearly sure, that eBay can be motivated by a temporary restraint order or a court decission to give full documentation about the interface changes in advance and, to stop implement code changes.

Should their be interest in fair market behavior ordererd by a court please let me know.


← Previous 1