Has development ceased on JBidWatcher?

Subscribe to Has development ceased on JBidWatcher? 8 post(s), 3 voice(s)

 
Avatar (SF) Philip ... 3 post(s)

Looks as if http://www.jbidwatcher.com/ hasn’t been updated since Nov 14th 2005 and there’s no sign of any action against any of the recently reported bugs.

Anybody know what’s happening?

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Well, given that I’ve been addressing the recent OS X breakage with 10.3.9 and Quicktime 7.0.4 (I had to replace the launcher with the Universal launcher), and there’s been this issue with eBay Italy where they’re putting an interstitial page between bid confirmation and bid completion (basically a warning about fruadulent use of the standard Italian payment methods, or something), and I’ve checked in a load of code for per-tab Properties…

I’d say development hasn’t ceased. (And if you look a line down in the home page, you’ll notice that the last entry is actually the 23rd of November. Admittedly, not very recent, but there really hasn’t been much news.)

That said, I will be vanishing for a few weeks near the end of this month. More details will be available on the front page, but it’s basically coming up on my wedding and subsequent honeymoon, and my future wife has made it clear that I shall not be checking for any issues with JBidwatcher during said honeymoon. ;)

I’d like to get a version out this weekend, but I NEED it to have fixed the eBay Italia bug first, because it’s failing bids and snipes for users who are able to do everything else. The turnaround time for debugging that is a killer, though.

Are there any bugs in particular that you find to be show-stoppers that should be addressed in a new version?

— Morgan Schweers, CyberFOX!

 
Avatar (SF) Philip ... 3 post(s)

Morgan

Many thanks for the update and sorry for missing the update of 23rd (but can I mention that the link to your blog at foxcode.ws no longer works).

There is one bug which does cause me problems (and which has stopped me from using JBidWatcher) and that is that I cannot stop it from running! Neither File|Exit nor clicking on the “X” in the top right of the window have any effect. (This is listed as Bug 1330703 on SourceForge).

Congrats on the marriage and I hope that the wedding and honeymoon are fabulous!

regards,
Philip

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Unfortunately foxcode.ws didn’t get redirected to Livejournal’s new IP address after the Six Apart purchase. I’ve changed the IP to point to it now, but it’ll take a day or so to catch up. (The foxcode blog is actually a mirror of the coding section of my main blog, but that includes random non-technical discussions which most users will find irrelevant.)

As for the ‘Cannot Close Program’ issue… Errrf. The problem you’re referring to is unfortunately a memory issue; the program runs out of memory (within what the JVM allows it). Program-closing requires a small amount of memory to do a final save, so it fails, which fails the exit. I’d say it’s a memory leak (possible, but rare, in Java), but I’ve run JBidwatcher through two commercial profilers and found nothing, so I’ve never been able to pinpoint what is going on.

If I find anything new, I’ll definitely put up a notice about it, though. It’s a very frustrating bug, especially because it doesn’t even occur for hours, sometimes days.

Thanks very much for the well-wishes!

— Morgan Schweers, CyberFOX!

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
The file locking is a fascinating one; why did you choose to use that?

What frustrates me, a bit, is that under Mac OS X it should be using:
-Xms=64m -XMx=512m
which is what’s set in my Info.plist for the JBidWatcher package.

Under Windows, the only parameter is:
-Xmx512M
because there was a problem passing the ms as well. (It was a weird issue between the newest JRE and the launcher I bundle JBidwatcher in for Windows.)

Hopefully a Windows user will let me know if
-Xms16m -Xmx256m -XX:UseFileLocking
works (i.e. fixes the OOM problem) under Windows as well. The way to use it under Windows would be to download the .jar file, and then run it from the command prompt using:
java -jar -Xms16m -Xmx256m -XX:
UseFileLocking JBidWatcher-0.9.9.jar

I have a Windows box myself (as well as 2 macs and a Linux box), but I don’t have a data set which causes the problem, at least inside of multiple days.

One of the MANY things I really, really want to do is disk-base completed auctions, so that they aren’t loaded into memory unless you are referencing them.

One thing, by the way, that I have heard exacerbates the problem is having recurring searches running. If you can tell me if that’s true, that might help also.

— Morgan Schweers, CyberFOX!

 
Avatar (SF) Michael... 10 post(s)

I don’t know if the vm options are case sensitive because you use -XMx=512m and not -Xmx=512m.

Anyway I think I had some concurrency problems on shutdown with JBW so I turned on the file locking option. May be it won’t help because the file is locked task-based and not thread-based but then it won’t hurt either. I wonder if adding some synchronized code sections could improve concurrent access to the files on disk.

IMHO testing for concurrency or memory problems for these files can be done by just saving the auction manually. If no “Auctions saved” dialogs pops up then you know where to look at. Otherwise you can just kill the process because all data has been saved.

Also some information about the time JBW was already running (hours or days or weeks) and having put the computer into sleep may give some pointers to the right direction. Or issues like a dropped network connection. Sometimes I have to restart JBW to regain updating of auctions.

 
Avatar (SF) Philip ... 3 post(s)

Since I started the thread, the least I could do was to try the line which Morgan suggested:

java -jar -Xms16m -Xmx256m -XX:+UseFileLocking JBidWatcher-0.9.9.jar

which gives me an error message:

Unrecognized VM option ‘+UseFileLocking’
Could not create the Java virtual machine.

I also tried:

java -jar -Xms16m -Xmx256m JBidWatcher-0.9.9.jar

which started JBidWatcher OK, but when I try to shut it down it still doesn’t work. I get the following logged in the Command Prompt window (apologies, but this is not a technology that I know anything about):

Tue Jan 17 21:26:51 GMT 2006: SMQ Caught exception: java.lang.StringIndexOutOfBo
undsException: String index out of range: -1
java.lang.StringIndexOutOfBoundsException: String index out of range: -1
at java.lang.String.substring(Unknown Source)
at AuctionsManager.makeBackupFilename(AuctionsManager.java:489)
at AuctionsManager.preserveFiles(AuctionsManager.java:436)
at AuctionsManager.saveAuctions(AuctionsManager.java:396)
at JBidWatch.internal_shutdown(JBidWatch.java:708)
at JBidWatch.shutdown(JBidWatch.java:692)
at JBidWatch.messageAction(JBidWatch.java:155)
at SwingMessageQueue.run(SwingMessageQueue.java:34)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source) at java.awt.EventDispatchThread.pumpEvents(Unknown Source) at java.awt.EventDispatchThread.pumpEvents(Unknown Source) at java.awt.EventDispatchThread.run(Unknown Source)

Hope this helps – let me know if there’s anything else I can try.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Yes, you can email me at cyberfox on gmail.com, and I’ll give you a pointer to a new version to download and try. It looks like you’re having a very different problem than the memory issue described above. For some reason your save-directory either doesn’t have a ‘\’, or the save file doesn’t have a ‘.’. Either way, I’ve made a change to JBidwatcher which will log that, and try to work around it.

I’ll give you a pointer to a new .jar file for you to download, and run the same command as you did above.

— Morgan Schweers, CyberFOX!