Snipe won't let me enter text...

Subscribe to Snipe won't let me enter text... 7 post(s), 4 voice(s)

 
Avatar chuck585a 4 post(s)

Hi Morgan,

I have been using JBidwatcher for quite a while now, and
it has really improve my ebay experience. Thanks!

I am currently running 1.0.1, and I am using jdk1.5 as the
java in my system.

When I click on “auction -> snipe” and click the mouse
on the price field, typing on my keyboard does nothing.
However, if I first click the check box for “auto subtract
shipping…”, and unclick it, then when I click the mouse
on the price field it accepts numbers as it should.

This behavior has been around for quite awhile now, 3 or 4
versions anyway.

Any ideas?

-Chuck

 
Avatar Sabaki 5 post(s)

I have been having the same problem with Bidwatcher for several years. It seems to be intermittant. Sometimes I can enter a snipe amount and sometimes I can’t. Usually I can when or if I just started or restart BidWatcher but only the first time. Sometimes I can minimize the snipe box and remaximize it again and then be able to enter an amount. Sometimes on re-maximizing the snipe input box the amount I entered appears, although it didn’t appear when I was typing it. It is weird.

I’m running Bidwatcher 1.0.1 and java version “1.5.0_09” in Firefox on Slackware Linux and also on Ubuntu Linux. Different versions of Java, Firefox, etc. do not seem to affect the problem.

Any help appreciated!

Thanks,

Chuck Bell

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

Can you give me the full output of:

java -version

if possible?

— Morgan Schweers, Cyber*FOX*!

 
Avatar Sabaki 5 post(s)

Yes -

On my Slackware Linux 11.0 box it is:

java version “1.5.0_09”
Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_09-b01)
Java HotSpot™ Client VM (build 1.5.0_09-b01, mixed mode, sharing)

And on my Ubuntu ’Dapper" Linux box it is:

java version “1.5.0_06”
Java™ 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
Java HotSpot™ Client VM (build 1.5.0_06-b05, mixed mode, sharing)

Hope this helps -

Chuck Bell

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

Hmmm… I was concerned that the libgcj version (default for many Linux distros) might be the issue, but it looks like Sun’s regular version. Have you tried it with 1.6?

I ask these things because the snipe dialog code is not particularly…clever, it’s just a text-input-box, and I don’t know under what circumstances that would fail to accept input, outside of a JRE issue.

I wonder if it’s a bad interaction with the window manager… Unfortunately, the others who’ve posted haven’t offered their operating systems, so I also don’t know how cross-platform the problem is.

Any ideas on how to replicate it?

— Morgan

 
Avatar krs99 99 post(s)

As I just posted………..

I never ever had this problem.
Currently on JBW 1.0 with Mac OS 10.4.8 and Camino.

 
Avatar Sabaki 5 post(s)

Hey Morgan -

I’ve been doing some testing… and actually upgraded one of my computers to test this from Slackware 11.0 to Slackware 12.0 that was recently relesed and that has the Java JRE 1.6 instead of JRE 1.5 and BidWatcher seems to be working fine on that computer without exhibiting the ‘snipe text-box’ problems.

So I found a third-party JRE 1.6 package for Slackware 11.0 on linuxpackages.net and upgraded it on my main computer and now the problems with the snipe text-input-box seem to have cleared up on it as well.

So, it looks like you nailed it. The latest JRE seems to have fixed this problem… finally! Woo Hoo!

I don’t know when Ubuntu will have a JRE 1.6 package available but I’ll bet when they do it will clear up the problem on my Ubuntu boxes as well.

So, looks like this problem is solved as far as I can tell.

Thanks for all your hard work and a great program!!!

Chuck Bell