Linux

Subscribe to Linux 7 post(s), 5 voice(s)

 
Avatar (SF) David 2 post(s)

Looking for any hints or suggestions. I’ve gotten your program to run flawlessly under Windows, but on my Linux box it won’t add auctions.

As root I try /usr/java/jdk1.3.1_07/bin/java -jar /djm/app/Jbid/JBidWatch-0.9pre5.jar

The app runs the config page and runs however I’m not able to add any auctions

I previously tried also tried 1.4 under /usr/java/j2sdk1.4.1_02/bin/java -jar /djm/app/Jbid/JBidWatch-0.9pre5.jar and I get the communications error referenced in another posting when I try to add an auction, so I backleveled to 1.3

I’d love to get it working under linux because my linux box runs all the time.

details of the output from starting the program for the first time and adding an auction are at : http://members.cox.net/davidmitchell/details.txt

It seems to be a sun.io.MalformedInputException error

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Ick… I’m not sure what the MalformedInputException error is, but the problem adding auctions has been fixed… Contact me via email to get access to a version that doesn’t have this problem.

eBay is down right now, so I can’t check out the auctions you reference in the details.txt file, but I will when I wake up. In general, though, some of the errors in there, I recognize, and have already made fixes for.

— Morgan Schweers, CyberFOX!

 
Avatar Steven 1 post

This may not be the smartest question in this forum but I don’t know how to execute JbidWatcher under linux.
I’ve recently installed Ubuntu 7.04 (7.10 was buggy on my laptop so I’m still under 7.04) and I have Java version 1.5.0_11 installed.
What command lines should I enter to begin the program ? I tried java -Xmx512m -jar ./JBidWatcher-1.0.1.jar and java -Xmx512m -jar ./JBidWatcher-1.0.2.jar but both time the console couldn’t find the file, I don’t see any file called JBidWatcher-1.0.2.jar or JBidWatcher-1.0.1.jar or any *.jar in the binary I downloaded either.

 
Avatar cyber 1 post

First, thanks for excellent product (I’m not an ebay pro and don’t depend on it, but it does make my life easier). I’ve switched away from WinXP to Linux and JBidWatcher was one of my first add-ons ;). A quick question — is there a way (other than standard Linux way of sending all the output to /dev/null) to make the program LESS verbose? I’m getting tons of things like

(:32349): Gtk-WARNING **: Attempting to add a widget with type GtkButton to a GtkComboBoxEntry (need an instance of GtkEntry or of a subclass)

(:32349): Gtk-CRITICAL **: gtk_widget_realize: assertion `GTK_WIDGET_ANCHORED (widget) || GTK_IS_INVISIBLE (widget)’ failed

(:32349): Gtk-CRITICAL **: gtk_paint_box: assertion `style->depth == gdk_drawable_get_depth (window)’ failed

(:32349): Gtk-CRITICAL **: gtk_paint_box: assertion `style->depth == gdk_drawable_get_depth (window)’ failed

which I’d like not to see … but, I’m guessing here, there might be some error messages/warnings sent to terminal that I DO want to see?

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

Unfortunately, those messages aren’t generated by JBidwatcher. Those are probably generated by the GTK look and feel for Java.

You could probably avoid it by setting your default look and feel to a different one, but then it wouldn’t integrate visually as well with your UI.

JBidwatcher does output some messages, but mostly they’re logged to the log files in ~/.jbidwatcher.

— Morgan Schweers, Cyber*FOX*!

 
Avatar rg 2 post(s)

I was wondering if there were any instructions of how to run jbid watcher under ubuntu? If someone can provide a basic overview of getting the app running it would be great.

Thanks
RG

 
Avatar rg 2 post(s)

Oh well forget that – figured it out … duh

java -jar :)

thanks – great app!!!!!