Can't run on FC3...I'm ignorant

Subscribe to Can't run on FC3...I'm ignorant 8 post(s), 2 voice(s)

 
Avatar (SF) renyst1 5 post(s)

I run the java -jar … and this is what I get

This change was necessary because the rmiregistry, rmic and jar tools
installed by previous versions of libgcj conflicted with symlinks
installed by jpackage.org JVM packages.
Exception in thread “main” java.lang.NullPointerException
at JConfigGeneralTab.buildSpendingLimits() (Unknown Source)
at JConfigGeneralTab.JConfigGeneralTab() (Unknown Source)
at JConfigFrame.createConfigFrame() (Unknown Source)
at JConfigFrame.JConfigFrame() (Unknown Source)
at JBidWatch.getUserSetup() (Unknown Source)
at JBidWatch.main(java.lang.String[]) (Unknown Source)

Nothing ever pops up or loads…what am I doing wrong? Please be specific.

Thanks

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

Go to:
http://java.sun.com/getjava
download the appropriate version for your platform (Linux)
Install it.
Determine where it was installed; probably something like:
/usr/java/j2re-1.5.0_04
Now run JBidwatcher like this:
/usr/java/j2re-1.5.0_04/bin/java -jar JBidWatcher-0.9.8.jar

Replace ‘j2re-1.5.0_04’ with whatever the actual name for the directory created was.

What you are doing wrong, to be specific, is trying to run JBidwatcher on a feature-poor, incompatible version of Java. It won’t work like that. You need to use a modern version, and the general directions above should get you there.

The only hard part for you will be figuring out what directory Java installed into. Once you figure that you, you could put it first in your path, for instance, and not have to type the whole pathname. Or you could just create a shortcut to running the whole long command.

Does this help?

— Morgan Schweers, CyberFOX!

 
Avatar (SF) renyst1 5 post(s)

I will try it when I get home today. It will likely work.

Thank you for both helping me get it up and more for helping me understand why it doesn’t work to begin with.

 
Avatar (SF) renyst1 5 post(s)

Should I attempt to uninstall the current version of java?

rpm -e java%%% ?

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
No, it’s not worth going through the dependency hassles.

Sun’s Java should install alongside what you currently have.

I’m not running FC3 myself, but a previous user had a similar problem.

— Morgan Schweers, CyberFOX!

 
Avatar (SF) renyst1 5 post(s)

Well, I got the update from Sun and installed it (jre1.5.0_04) but I still get the exact same thing when I try to run it. I even ran it from the directory java is installed to….same thing.

Any other suggestions? Is there a way to verify it is using the proper version of the JRE?

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
You put in the whole path to the Java installation?

If all you’re doing is typing:
java -jar JBidWatcher-0.9.8.jar
then whatever’s first in your path will be the version of Java that runs. For most users, this will be FC3’s bad GCJ-based version of Java.

Even if the right version of Java is in your current directory, the shell only looks through your $PATH for any program that matches the command you’re typing. (I can explain why if you’d like.) In fact, if you don’t have ‘.’ in your $PATH variable it won’t even look in the current directory for executables.

So if Java is installed at:
/usr/java/jre1.5.0_04
you need to type
/usr/java/jre1.5.0_04/bin/java -jar JBidWatcher-0.9.8.jar
to launch it.

What’s really annoying about this is that RedHat chose to ship a non-working version of Java standard with their distribution, causing users such as yourself and others who have also had the same problem, tons of confusion and breakage.

I very much hope the program works well enough for you and helps you out in your eBaying enough to make up for the work it’s taken to get installed.

If the above suggestion doesn’t work, then we’ll probably need to dig into talking about your setup, where programs are installed, your PATH variable, maybe seeing a script of you trying to run it, and the like.

— Morgan Schweers, CyberFOX!

 
Avatar (SF) renyst1 5 post(s)

Sorry it took me a few days to get back to you. Yes it does work now. I foolishly thought if I was in the directory where java was installed that it would launch that one.

Thank you for your help…