jbidwatcher stopped working

Subscribe to jbidwatcher stopped working 16 post(s), 9 voice(s)

Avatar (SF) Martin ... 1 post

yesterday all went well but today
it simply stopped working …

neither can i retrieve ‘my ebay’ items,
nor manually enter any items nor update
information to items already saved ..

no error messages !

Avatar (SF) eric 1 post

I’ve got the same. But on the command line there is
a null-pointer-exception.
I use the java version on debian linux.

Avatar (SF) James H... 2 post(s)

Ebay did their own thing again… A new page format. Annoying as the change is, I actually agree with them that the new format makes it easier to find stuff.

Anyway, changing two things in jbidwatcher.properties fixed things for me:
ebayServer.sellerInfoPrequel=Seller information
fixed the null-pointer exception, and I also did this:
changed to
but I’m not so sure that was needed (I was trying to fix thumbnail display)

If cyberfox doesn’t get a new version out today, I’ll go post my .jar somewhere.

Avatar (SF) Qrobur 4 post(s)

Cyberfox has pushed a change (not a full fix yet), but whatever it is jbidwatcher is still broken on my Win2K OS.

Guess it’s matter of waiting for the full fix.


Avatar (SF) Jim Rus... 2 post(s)

Thanks, James, that fixed it for me. Well, at least it fixed getting an auction. We’ll see if bidding and sniping works….

Avatar Morgan Schweers Administrator 1,204 post(s)

Normally, if I could have, I’d have addressed this on a weekend, but that hasn’t been an option this time, as the breakage was severe enough to require an emergency release.

I’ve pushed up a new version of JBidwatcher for download, which SHOULD fix this. I’m asking those who’ve reported the issue to check it out first, so that I can feel comfortable pushing it to a larger community. Responses will be best noticed if they include ‘BETA’ in all caps in the subject line someplace.

The versions are as follows…

For the Macintosh, download from:

For Windows, download:

For Linux, or any other platform that can run Java .jar files, download:

I hope these versions work cleanly and perfectly out of the box for you. If not, as I said above, please report to me anything at ALL that you find not working quite right.

— Morgan Schweers, CyberFOX!

Avatar (SF) Jim Rus... 2 post(s)


Seems to be working well under linux. Thanks for the quick update.


Avatar (SF) Bruno V... 1 post

Updating auctions, finding items in “My Ebay”, and bidding does work again for me (Slackware 10.2, JDK 1.5.0_04).
Thanks a lot for the quick fix!


Avatar (SF) Qrobur 4 post(s)

Win2K Pro, JRE 1.5.0_06

  • adding auctions manually (either by auction number or with drag and drop works).
  • finding auctions via URL search works.
  • bidding works.

Fix looks good, thank you.


Avatar (SF) Qrobur 4 post(s)

Subsequent to my prior post, it has become clear that winning a multisnipe fails to cancel later bids for the same item.

Avatar Morgan Schweers Administrator 1,204 post(s)

Yes, I just found the cause for multisnipe failing. I’ve got a fix in the works for that, too. (As well as seller-search, and several other minor issues.)

— Morgan Schweers, CyberFOX!

Avatar (SF) Robert ... 4 post(s)

I tried the new beta 1.0pre2.exe on Windows XP with Java 1.5.0_06. I can now manually add an auction, but Get My eBay Items and sniping do not work. Unfortunately I missed out on winning an auction when it failed to snipe.

Avatar Morgan Schweers Administrator 1,204 post(s)

Now that’s unusual. Most people report that sniping works fine. (Get My eBay Items is fixed in 1.0pre5, check the blog for it.)

Any idea what went wrong? (Do the logs, or the ‘Show Information’ status show anything in particular?)

I take sniping failures pretty seriously, so I’d like to hear what went wrong, in case it’s something that’s changed.

— Morgan Schweers, CyberFOX!

Avatar (SF) Robert ... 4 post(s)

OK, for some reason it failed to login. My saved password hasn’t changed, so I don’t know why it failed. I just reinitialized the saved settings for ebay id and password, restarted, and it can now retreive My Ebay items. I had done this yesterday also, but it still didn’t login. It makes sense that failure to login made sniping and getting My ebay items fail also.

So my guess is that sniping will work now, I’m just sorry I missed that auction yesterday as it’s something that I needed. Oh well, I’ll just have to wait for the next one, there’s always another opportunity just around the corner. :-)

So I’ll just write this one off as a glitch in my system. BTW, thanks for such a great program.

Avatar (SF) Chris Cox 1 post

Hi, I had the same problem yesterday where jbidwatcher (1.0 pre 5) was unable to log into my account. Looking at the debug log I got the following error repeatedly:-

Wed Mar 29 23:30:12 BST 2006: Couldn’t sign in!
java.io.IOException: Failed eBay security check (captcha).
at ebayServer.getSignInCookie(ebayServer.java:1441)
at ebayServer.getSignInCookie(ebayServer.java:1490)
at ebayServer.getNecessaryCookie(ebayServer.java:1304)
at ebayServer.messageAction(ebayServer.java:741)
at PlainMessageQueue.run(PlainMessageQueue.java:70)
at java.lang.Thread.run(Unknown Source)
Wed Mar 29 23:30:12 BST 2006: MQ_: Postponing Message: NOTIFY eBay’s security monitoring has been triggered, and temporarily requires human intervention to log in. JBidwatcher will not be able to log in (including bids, snipes, and retrieving My eBay items) until this is fixed.

Interesting I notice that when trying to log in using a browser during this time, once the username/password was entered, I then got an additional page with a random sequence of characters over textured background and was prompted to enter the characters before the login was successful. This evening this page is no longer there. Could this be due to ebay making some changes?


Avatar (SF) Robert ... 4 post(s)


Yesterday when I had the problem with jbidwatcher logging in, I could login to ebay via a browser with no problem. I did not receive any additional page.