Sign in fail with html error 405

Subscribe to Sign in fail with html error 405 37 post(s), 11 voice(s)

← Previous 1
Avatar dickyfit 15 post(s)

This evening I’ve started to get sign in failures with html error 405 reported. and .com give the same results.


Avatar carnivalist 1 post

Me too. I’ve tried every fix recommended on the forums in past years but nothing happens. I fear something has changed on ebay’s site.

As far as I’m aware nobody is updating JBidwatcher anymore so sadly it may be the end.

Can anyone recommend an alternative?

Avatar zappram 290 post(s)

Is it an issue with

As I am not experiencing any problem from USA using Can you try to login from and see if it makes any differences?

So far, so good and JBW still snipes for me (from USA, 9 seconds before end of auction). But I do find that there are more and more BIN listings, than bidding….. I end up buying more than 95% of the items I purchase from eBay now, and only enjoy bidding on about 5% of the items I buy from eBay.

Avatar dickyfit 15 post(s)

I’ve just tried .com and again. Both give either “Server returned HTTP response code: 405 for URL:…” or “Server returned HTTP response code: 405 for URL:…” based on settings.


Avatar zappram 290 post(s)

I’m on Mac OS X, no issues with this error code even when I tried:

From the web:

maybe the problem is not with JBW?

Sorry, no direct help. Good luck guys.

Avatar dickyfit 15 post(s)

I’m running on Debian 10 with jbidwatcher 2.5.6-11-gac197d6

If jbidwatcher is now abandonware; as carnivalist asked, any suggestions for an alternative?


Avatar ivan 11 post(s)

Same here in France. Whatever the server is, I tried fr, es, it,, com,
I tried the version 2.99 pre5 as well.
I’ve had a lot of issues with eBay for 3 months, they regularly blocked my account several times a week, putting a captcha, which jbidwatcher failed against; even twice on the same day! I struggled with the customer service. I believe that these issues, including jbidwatcher ’s ones are tightly linked to a modification of their security policy.
Today, I noticed the following message on the status bar : Done getting the signin cookie for [my_eBay_login_address: date, time].
Where is this cookie supposed to be recorded ?

Avatar dickyfit 15 post(s)

eSniper seems to have had a similar problem. The thread I found with information is here:

I think the relevant part is:

How to reproduce the behavior within a webbrowser (e.g. Chromium):

Switch off (block) java script for Delete all cookies from Enter Within the developer tools go to ‘elements’ Search for Edit attribute and change from ‘disabled’ to ‘enabled’ Enter user and password and submit the form

You will get a response 405 and will be redirected to a captcha security page.

I would say, it’s a cookie problem. With java script disabled some cookies are not available and they are probably needed for the login process.

The following cookies are missed:


I currently havent found, where they are transfered (js, ajax, …). Maybe someone can help.


Avatar dickyfit 15 post(s)

If i use ebay signin/s from a browser I can login fine. If i try to get the page with wget i see this

-2019-11-26 00:39:13-
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 405 Method Not Allowed
2019-11-26 00:39:14 ERROR 405: Method Not Allowed.


Avatar zappram 290 post(s)

ivan: regarding “captcha”, try in settings, instead of your ebay user ID, use your email address associated with the eBay ID. I actually had problem logging in from my browser before, and i am sure about my password, so I called eBay on that, and the customer service rep. told me to use email address to login from my browser, and it works. But sometimes, the eBay ID will not work. The reason eBay gave me is that every one can know your ID, but not everyone knows the email address used for that eBay ID (for security reasons when they suspect that you are logging in from so many different IP#, etc. if you are using a VPN or access your ebay account from many different “not so normal” locations.

Good luck.

Avatar dickyfit 15 post(s)

Changing the login details has made no difference.
Because wget is returning the same 405 error when simply trying to retrieve the page makes me think the problem is similar to the esniper info.


Avatar rwburbage 11 post(s)

it’s not working man! What do we dooooooo. I feel like a chicken with my head cut off…. need the little blue birdy to work…

Avatar Sunray 2 post(s)

Had a look at the eBay API, it’s published so it shouldn’t change and it hasn’t.

What HAS changed is that eBay have discontinued all the non SSL end points which JBidwatcher relied upon.

Maybe running it through a proxy might make it work, but looking at the code, it would be easier for someone to create a new app.

Avatar ivan 11 post(s)

To zappram: I never log with my eBay user ID. That’s a while I had issues and abandonned it. Concerning the connection origin, yes, I’m connecting via my provider, or with my phone or with it as an access point for my computer. I suspected that eBay was blocking the account regarding these various IP addresses, For 7 days I connected through my provider only and I got 4 password change requests !

That said, since the moment the issues apperared with jBidwatcher, I noticed that the way to log into eBay is different than before. Now, there’s a first findow requesting the id with a button for accessing the second one for typing the password.
I noticed as well but for a longer while that the “stay connected” box is grayed.

Why not two cookies : A first one related to the ID and a second one (the “missed cookie”) for the password ?

Avatar dickyfit 15 post(s)

The browser login screen I see at still has both username and password inputs on the same screen.

Avatar ivan 11 post(s)

You’re right. Today, the login process came back to normal.
eBay is quite inconsistent.

By the way, and it’s off topic, did someone remark that the icons are missing in the registed search page and in “my ebay: summary” ?
These pages have been randomly working for 2 or 3 months but, on, my ebay summary (mon eBay: récapitulatif") is still OK !

Avatar MEC2 61 post(s)

Been getting this for a week. JBW is effectively useless at this point. I’ve had two times where it suddenly got green dot, but it went away briefly thereafter. Using bidnapper for now but I prefer JBid for drag/drop ease and better handling of the auction photo, but it’s not been able to snipe for a week…

Avatar MEC2 61 post(s)

Getting this now when trying to add auctions…

Thu Nov 28 09:32:20 CST 2019: Cannot add auction 383289377053, either invalid or
communication error talking to server.

Avatar zappram 290 post(s)

I am more confused now. As all are working for me, and JBW still does snipe and drag and drop or add for me.

I click on the + sign, copy/paste item # 383289377053 and it added the item. Click on show in browser, and it showed the item with URL below:
Greece, 25 Drachmai 1913, Signature Valaoritis, Condition:VF – 25, Pick#52
currently big at $15.50 with 7 bids.

Alll I have from past experience is: I need to keep my end “consistent”. I’d bee blocked by eBay thinking I’m someone else from my own home computer, but that’s probably having inconsistent IP# from using a VPN client before. Now all cleared and settled.

So, I will snipe on that note for you if you want. Happy Thanksgiving from California USA.

Avatar MEC2 61 post(s)

Hey zappram – I will say, I’ve been using NordVPN lately, and sometimes my IP address will move – I wonder if that is related to the login. But, even without the VPN on, I cannot connect. Strange. Could be some kind of active blocking eBay is doing. Not sure why – and I can still use eBay from the browser over the VPN on the same account.

So odd…

Avatar zappram 290 post(s)

Could be that eBay detected “changes” on your end (like different IP#’s).

Maybe you can go to preferences in JBW and “test login” again?
And also if you use VPN, how do you set the preferences in JBW for the ’Firewall"?
Those all play some factors I think.

Granted it was working much smoother and easier before. But maybe that’s why eBay tighten up their codes as they are the one being responsible for any financial transactions that went through their servers.

I think every well “used” machines whether Windows or Mac, will have lots of footprints and signatures left in the machine from prior use. We need to know how eBay is either granting or blocking access. And if IP# and machine ID is the keys they look for then that’s how we need to follow.

It’s similar to if you use your own phone and the app will just login in to your bank account or Paypal or eBay. But try it when you get a new smart phone, even with complete restore to where all apps and files are all the same as the old phone, you still need to authenticate with your bank accounts and Paypal and eBay, etc.

If I turn on my VPN, even selecting “California” which is where I am, all my email accounts will be blocked and I will receive notifications of “suspicious login” telling me that someone else has my password and is trying to access my email account and it was “blocked”, and I should thank them for bloking me haha.

Avatar dickyfit 15 post(s)

The machine I run jbidwatcher from has a static IP, so an IP change won’t be figuring in my scenario.


Avatar zappram 290 post(s)

alright, sorry I can’t help you much. I tried and I don’t have any issue.

Again, you have issues with browsers even getting into ebay site, logically thinking, you may have issue using JBW accessing ebay sites also.

So, this is not a JBW error code? Just from your general web browsing?

Avatar dickyfit 15 post(s)

My browser access is fine.
Accessing the login page with jbidwatcher or with wget generates a html 405 error.
I tested with wget because it’s wysiwyg and doesn’t process the page or any embedded scripts.

Avatar zappram 290 post(s)

Oh well, you have no problem login with browsers and you have static IP, and did you test your login within JBW preferences settings ? If that does not login, then your JBW will not work, right?

Besides that, I don’t know how else but to suggest you read from the web:
From the web:

and figure out why you have the infamous error 405.

← Previous 1