Linux: "Time left" 1hr too much

Subscribe to Linux: "Time left" 1hr too much 40 post(s), 15 voice(s)

← Previous 1
Avatar Robin Whittle 11 post(s)

I installed 2.1.6-0-geb75036 in my 64 bit Debian 6.0 machine and ran it with:

java -Xmx512m -jar JBidwatcher-2.1.6.jar &

based on this forum discussion on installing JBidwatcher on Linux:

‘&’ leaves it running in the background. I haven’t yet made it run at boot time.

I set it up for (I am in Melbourne Australia) as I have with my Windows installation. I set up an auction to snipe (190594906375) and all looked well until I noticed it displaying, for instance,
“2h, 26m” for “Time left” while my Windows installation of the same
version, with the exact same settings, was showing the correct time left of “1h 26m”.

Both programs display the correct “EST” (Australian Eastern Standard Time, which is currently daylight savings) at the top right of the window, except that the Windows version shows a time 4 seconds later.

When I use the Servers > Synchronize Time command, both programs display the time I did this at the bottom of the window. This text remains unchanged as time goes by, for instance:

Mon Nov 07 01:59:43 EST 2011

I can’t do this to both programs at the same instant, but I think there’s no time offset between them. The Servers > Time Information command results in:

Linux: Page load 1321 eBay time delta -1580
WinXP: Page load 5640 ebay time delta -4562

The date command on the Linux machine gives the correct time, such as:
Mon Nov 7 02:08:58 EST 2011 and the Windows machine is also giving the correct time – all Australian EST daylight savings.

- Robin
Avatar Robin Whittle 11 post(s)

Now the time to go is less than one hour, the Linux version is reporting the correct time to run, but 1 second greater than the eBay auction page time, with the Windows version being about 6 seconds greater. Hmmm now the Windows one is only 1 second greater – perhaps because I clicked “Servers > Update Auctions”. So all looks well now.

BTW, this pop-up window for replying to the forum is bad. The cursor has disappeared and there is a very small text window. (Firefox 7.01 WinXP.) OK, now the cursor has returned . . .. – Robin

Avatar Hoddy 108 post(s)

Have the same problem here in the UK. The time is changing on the auctions with less than an hour to go – an hour is being added to the time! So an auction with 15 minutes left is now shown in JBidWatcher as having 1hour 15 minutes to go. Anybody have an explanation why?


Avatar ytterligare 7 post(s)

Same here in Italy ( ….I’ve got an Auction ending in 20 minutes, and Jbid says it’s 1h20…what will happen in 20 minutes ? Will it fire a snipe ?

Well, I’m not preoccupied for this auction, which I can manage manually, but for tonite’s…
Any hints ?


Avatar wes.w 5 post(s)

In the UK last weekend we changed from BST to GMT. JBidWatcher got confused by this. If you’ve added something in the past week, it will probably be OK, but anything added before the clock changed needs updating to get things right. JBidwatcher missed 5 of my bids this morning until I managed to get the auctions updated properly. They were 10 day auctions. So if you are bidding in the UK, or for something in the UK, be careful.

Avatar bob4 2 post(s)

Same problem here in Finland!

I just lost an auction because of the same phenomenon. It’s the second time within a week! It’s not the end of the world, but still makes me angry!!

exactly one hour before the end of the auction one hour is mysteriously added to the remaining time!

I’ve set german ebay as my country site (I have a german ebay account). Here is an excerpt from my activity log:

Sun Nov 06 19:33:07 EET 2011: Successfully synchronized time with
Sun Nov 06 19:33:09 EET 2011: Successfully synchronized time with
Sun Nov 06 19:33:09 EET 2011: Server time is now: Sun Nov 06 19:33:01 EET 2011
Sun Nov 06 19:33:12 EET 2011: Done getting the sign in cookie for

Is it normal that JBW synchronizes with and

Of course I can add one hour to the sniping time, but this is just stupid. It worked before, why doesn’t it now? I’ve been using JBW for roughly 3 months. Most of my snipes were made in August while I still was in Germany, but two were done successfully from Finland.

And who guarantees that JBW will not quirk and add an even bigger offset?

THIS SUCKS!! It also seems to be a new and uprising phenomenon….. please fix it!



Avatar ytterligare 7 post(s)

Hmmm….I tend to stick to WES theory.
My auction just finished, but I managed it manually 5 secs before Jbid was supposed to snipe for a higher amount.
Of course, being 1 hour behind, Jbid just did nothing. A subsequent update on Jbid got the auction ended finally…but of course I run the risk of loosing it…
What is strange is that now ALL my watched items on Jbid are again correct….but this could be right if Wes got it right…
And Bob…yeah….the risk of a random time offset is disturbing… ;-)


Yes, my Jbid also connect to and for time synch.

Avatar wes.w 5 post(s)

>It worked before, why doesn’t it now?

Read the message above. IT DOESNT SUCK!! – its just an unforseen problem. You get this software for free. Don’t whinge if it isn’t 100%!! Is Windows or Linux 100% bug free?

Avatar bob4 2 post(s)


I wrote “THIS SUCKS” which refers to the problem, not to the software itself.

Avatar ogpete 2 post(s)

Lost 2 x auctions here in the UK today – both seem related to the BST / GMT Chageover last weekend

Here’s a log from the latest “missfire”:

Listing ended at
Sun Nov 06 18:10:46 GMT 2011
Last updated at
Sun Nov 06 18:11:12 GMT 2011
Listing has ended. Events
Sun Nov 06 12:05:52 GMT 2011: Establishing a snipe (5) Sun Nov 06 18:11:08 GMT 2011:
Preparing snipe. Sun Nov 06 18:11:09 GMT 2011:
Cancelling snipe. Sun Nov 06 18:11:09 GMT 2011:
Cancelling snipe, auction is reported as ended. Sun Nov 06 18:11:12 GMT 2011:
Cancelling snipe. Sun Nov 06 18:11:12 GMT 2011: Snipe apparently failed, as the auction cannot be bid on anymore:

Seems like Jbids’ clock is 1 minute out of synch – however the displayed countdown was correct!

Avatar Hoddy 108 post(s)

Don’t think it’s a problem with the UK time change to GMT. If you check the other posts you will see that it’s affecting people all over the world! I assume it must be a problem with as JBidWatcher uses this site to fire it’s snipes. Seems to be completely random in which auctions it affects. I have ‘Syconized Time’ and now are carefully watching the six auctions I have snipes on that end within the next two hours. At the moment the times are correct and all counting down nicely……..


Spoke to soon – one of the auctions got to 20 minutes then changed to 1hour 20 minutes! Very frustrating………….

Avatar Dodgy Geezer 107 post(s)

Yup – I also just lost three auctions with hour-late bids.

I’m in the UK, my system clock was properly set, and the UK ebay time was displaying correctly on the ebay page. I put a snipe on three items this morning and Jbidwatcher bid for them 1 hour late.

As a test I picked a cheap item which was going to close in about 10 mins time, and put a snipe on. It correctly indicated a few minutes to go, but when I checked TimeSync, I found I was -16937. When I went back to the main page, I found Jbidwatcher was now indicating 1 hour 5 minutes to go. It ran past the proper bid time without making a bid. I then tried re-syncing, and after a few goes it went back to the correct time, and then set the snipe to red, as it was in the past…

It looks like there is a bug of some kind in the timing code, and JBidwatcher 2.1.6-0-geb75036 cannot currently be relied upon to bid in a timely fashion….

Avatar ytterligare 7 post(s)

I was luck I took a look at the auction to monitor Jbid behaviour.. : I had snipes ready for two items, one ending after 8 minutes, the other 40 minutes later.
At a certain point, the first item countdown became 1h 8min the other was unchanged !!!!
I was lucky I was sniping items in the E.U. …. had the item been offered in the USA, I could be easily in bed sleeping and loose the auction…
There’s not really a pattern….suddenly I find my Jbid not reliable, so I’m shutting it down, until a fix comes out… :-(
Any word from the author ?


Avatar Dodgy Geezer 107 post(s)

I’ve just noted that I was on Java 6-24, and the current is 6-29. I wonder if that might be an issue…?

Avatar wes.w 5 post(s)

>Don’t think it’s a problem with the UK time change to GMT.
>If you check the other posts you will see that it’s affecting people all over the world!
But maybe if it was using ebay uk as GMT, and then using that to calculate your local time (which worked while we were on BST, because it was programmed that way, but now we are truly on GMT), that would screw up things worldwide.

I’ve been watching it for a few hours now, and nursing my snipes along. It only seems to go wrong in the last hour, and that happens when it automatically updates an auction. You can’t predict when its going to update, so:

Avatar Dodgy Geezer 107 post(s)

Just tested it again. It’s an easy test – pick an auction with about 10 minutes to go, and put a bid on for less than the current price. That means the bid will fail to establish at 2 minutes to go, but that’s not important for the test.

Watch the JBidwatch countdown. In my case, fairly reliably, the Jbidwatcher countdown goes OK to about 5 mins to go – then it switches to 1 hour 5 minutes. If you look at the Information pop-up for the item in this state, you can see that it is indicating that the item auction end is one hour five minutes away, instead of 5 minutes. Unsurprisingly, the snipe will not fire at the correct time, and will either wait one hour, or jump back to the correct time on it’s own, at some point after the auction has ended…

Avatar Martin Bürkel 18 post(s)

It´s the same here in Germany on a Mac. Has as it seems nothing to do with location or platform. So could it be ebay who changed something? I have won auctions till 31th of october, had “unknown errors” from 1.11 till 5th of november and finally since today “Cancelling snipe, auction is reported as ended” with completely disappearing snipe amount. Could this all be a change on ebay ? Why does the snipe amount disappear? Hope this could be resolved soon.

Avatar Dodgy Geezer 107 post(s)

I have just updated Java to 6-29, rebooted my machine, and run two more tests. Both auctions went down to 30 secs before end, and ‘prepared a snipe’ before I canceled them, so I think they would have gone the whole way. I suggest that people try a test auction as above, check their Java version, update it to the latest, and then retry the test auction again to see if there’s a difference. The results should help Morgan when he comes to look at the problem…

Avatar Robin Whittle 11 post(s)

I imagine the biggest challenge for Morgan is testing this software for multiple eBay systems and multiple versions of Java and operating system while at any moment, including on a transient and intermittent basis, the behaviour of eBay’s servers could change and a bunch of happy JBidwatcher users find their program no longer working.

This is not the sort of programming I would be keen to tackle!

Has anyone had JBidwatcher operate correctly since the start of November? I think it would be helpful to Morgan to report such successes, or any mixture of success and failure on the forum. JBidwatcher 2.1.6-0-geb75036 failed a few hours ago under:

WinXP Java 1.6.0_29

64 bit Debian 6.0 Linux
java version “1.6.0_18”
OpenJDK Runtime Environment (IcedTea6 1.8.7) (6b18-1.8.7-2~squeeze1)

I posted some logs to another thread, and suggest other people do the same on that thread, to avoid cluttering this one.

I still won the auction with a bid via I signed up and it worked – I guess they will ask for billing information once their service wins a few auctions.

According to my understanding of the “desktop” section of this extensive listing of auction sniping software:

JBidwatcher is the only one to work on Linux, apart from JoyBidder, which can apparently run as a Firefox extension.

- Robin
Avatar Robin Whittle 11 post(s)

As mentioned in thread 2923, is having troubles with eBay too. On their main page, right now, is the message:

  • NOTICE: eBay is randomly showing us incorrect endtimes
  • for auctions as a result of the time change. This is effecting
  • a small percentage of bids. You can compare the time left
  • on this site with the time left on eBay to make sure we have
  • the correct endtime. If not, try deleting and re-adding the
  • auction. We appologize for the problem, but there is little
  • we can do until eBay resolves the issue.
- Robin
Avatar Dodgy Geezer 107 post(s)

Can’t see anything on their home page at 06:00 am GMT….

Avatar ytterligare 7 post(s)

Look for the “news” section…


Avatar mmoole 2 post(s)


now i have set my preferences to and will see what will happen throughout the day.

Before: when updating an auction, the end time jumped “often” by 1 hour, be it from 1h later to the correct time, or vice versa.

##edit: oh, now i have also one auction that is shown to end 1h earlier than expected, nr. 220884701193 end at 16h23 CET, but in jbidwatcher it displays 15h25 after updating. Lets see what will happen to this …

Avatar John Lockwood 5 post(s)

I can confirm this problem also affects the Mac version in the UK.

Rather than merely saying – me too, I do have a tip for a temporary workaround. As the error margin for me and most people is exactly 60 minutes, you could as a temporary solution increase the amount of time before the end of an auction that JBidwatcher bids so instead of 30 seconds make it 60 minutes and 30 seconds, this would mean adding 3600 extra seconds.

Avatar stanleymack 5 post(s)

That sounds like a potentially good suggestion for a temporary work-around, John Lockwood. I’m also in UK, running Jbw on XL. Same problem. Is organ Scweers aware of the issue? Is there a way to report it to him?

← Previous 1