Most auctions appear as FP

Subscribe to Most auctions appear as FP 51 post(s), 26 voice(s)

Avatar erichard 2 post(s)

I’m running the latest Mac software, and command-E (highlight the individual auction, then key command-E) does bring up a dialog box successfully, which enables sniping despite the (FP) label on the item. So I’m waiting to see if the snipe works. No reason to think it won’t. Thanks for the tip guys.

I did win something yesterday, and it was labeled (FP) in the “complete” window, and the color was red on my snipe, indicating I had lost. I checked the auction, and I had actually won, so keep an eye out for that (in other words, it should have shown that I had won the item and been blue).

I’m running version 2.0.1-825 in case anyone’s interested.

Avatar Morgan Schweers Administrator 1,204 post(s)

@erichard – At the end of the previous page of comments ( ) is a set of links to the latest pre-release, for which you shouldn’t have to use the workaround.

— Morgan Schweers, CyberFOX!

Avatar Marc 13 post(s)


Thank you for pre3 and the various fixes !
One new issue : item bought with ‘buy it now’ is not shown properly e.g. item 160350510070.
Other point : items I bought recently are show with the correct high bidder information but still remain written in brown, not with the blue highlight.


Avatar Charlie 16 post(s)

Morgan, your pre3 version is looking much better. I now have sellers and high bidders listed, and can see current bid and # of bids. Like Marc, I do have the issue that an item I have the high bid on is displaying in red, which isn’t a problem for me right now. Overall, a big step forward. Thanks!

Avatar The Gaffer 5 post(s)

Hi All,
Not sure if this is release wide or just my install.

Just a quick reminder, Good house keeping = make regular backups of important folders……..

Reoccurrance of multiple entries of auctions. (Both JBidwatcher-2.1pre2 and 2.1pre3) One auction No# is listed four time in a row.

I don’t think JBidwatcher-2.1pre3 sync’s with ‘My Ebay’
JBidwatcher-2.1pre2 release was OK.

Still have a delete problem. I tried to do a little spring cleaning and delete 180 odd auctions in one go.
The initial delete dialogue box is now correctly sized. The confirmation box is OK. But still doesn’t delete highlighted auctions. It just leaves them highligted in the tab.
I (think) it does remove them on restart as in the previous release.

But reluctant to use the new pre-release for a second reason.

I have perhaps 15 – 20 searches set up in JBW. Some text, some url.
Some autorun and others manually started.
On startup of the new release, it wipes the contents of the searches.xml file……..
(explorer now reports it to be 1k in size, while the working file was 26K)

(Unusually) for me I have a backup of the JBW folder from last month :-0

On the positive side.
Not sniped yet, but FP auctions updating to correct status.

Seller id column parsed correctly.

In the HighBidder Column, I still have ‘unknown bidders’ or Bidder 2 or 3 but it does recognises my ebay id on the only auction I have made a ‘token’ bid on, (BUT no Blue highlighted text & tick in the Status Column?)

Anybody know the significance of the shipping amount shown in bold?
(Auction No# in bold means you have made a comment against the auction.)

The configuration window in the new releases have some intriguing options for the future :-)
Any threads on the uses for the ‘My JBidwatcher’ tab?

Regards Alan.
( JBW 2.1pre3-998, Win XP-Pro sp3)

Avatar xarxx 8 post(s)

pre3 fixed the FP problem! Thanks Morgen! Even if there’s a memory leak, at least we are on the right track!

Avatar clanger 12 post(s)

Hurrah! Thanks for the new fix Mr Cyberrrrrrrfox!

Avatar jumpfroggy 3 post(s)

I just downloaded 2.1pre3-998, and during the first run it shows the “Version 2.0.1 available!” popup that tells me a new version is available. I didn’t “upgrade”, but it seems like the version checking is bad unless I missed something.

It just ran through all my false-FP auctions and reverted back to normal (yay). I’ll see if it comes back.

Avatar Morgan Schweers Administrator 1,204 post(s)

Yeah, I don’t mess with making the version checking work right until the release; it purely operates off of ‘is it different than what I already know?’. Sorry ’bout that.

I’ve been hearing reports that it’s deleting or losing folks saved searches; I need to look into that.

Not recognizing you as high bidder is probably because high bidder identification is separate from item loading now (it gets pulled from another page). It just needs to trigger the comparison again, when it updates it.

— Morgan Schweers, CyberFOX!

Avatar Morgan Schweers Administrator 1,204 post(s)

Let’s see…

@The Gaffer – Are you seeing multiple entries in the UI, or in the web interface?

Delete’s should be working; what you’re describing is odd and unsettling as it’s not replicating for me. :( Are there any errors in the log when the delete fails?

The shipping amount being in bold means that you set it by hand, instead of it being read from the listing.

As for ‘My JBidwatcher’, if you go to and sign up, I’ll enable your account for full access. It’s nothing much right now, but I’m working on it…well, when eBay’s not making JBidwatcher break fully. I’ve had to pause my work on it, until I get JBidwatcher fully functional.

— Morgan Schweers, CyberFOX!

Avatar buserror 6 post(s)

as posted on twitter, I still have the UK 1994 problem here. It’s been like that for over a year.

Avatar The Gaffer 5 post(s)

Hi Morgan,

A reply from THE MAN ! Thank’s.
I’m a developers nightmare…….
I chop and change between releases as (I belive) some are beter at specific tasks than others.
ie: In current use !

JBidwatcher-2.0beta11 consistantly recovered ‘my watching’ listings. (often the full 200 items limit)
But on my already overstressed system would after 1 or 2 days of running, result in extended periods of HDD access resulting in ‘program not responding’ from Windows, missed snipes because the system is busy.
BUT JBW is not crashed. If you do an action but it doesn’t respond, don’t repeatedly ‘click away’. Leave, walk away, get a coffee, maybe a second or third. IT WILL dig it’s self out of the hole.

JBidwatcher-2.0.1 is good for leaving for 2 or 3 days unattended, Sniping & running automated searches. Also seen periods of extended disk access, only perhaps in blocks of 20 – 30Sec but overall program is more responsive.
No sync with ‘My Ebay’
Doesn’t read me as won auctions.
But to me, I belive it’s important to get a valid snipe in on time.
I don’t mind checking the Ebay site to see if I have to make any payments :-)

JBidwatcher-2.1pre2, good to leave running.
Did sync with ‘My Ebay’ put them in the new tab etc. (until I ran pre3 and lost my customised searches.)
Only (semi-)real issue was FP, but that has the cntrl e workaround.

JBidwatcher-2.1pre3 is so nearly there.
Just for me I use automated searches a lot. (too many hobbies and interests…….)
The issue with overwriting the searches.xml file makes it not a good release to use.
No Sync with My Ebay. There is only one entry in the auction search manager, and it’s ‘my ebay’ but doesn’t load anything?
(If I use an old searches.xml file back in JBidwatcher-2.1pre2 custom searches are back & OK but there’s no sync with ‘my ebay.’

Has ebay known to have broken it again, or does JBW handle the process differently between the latest release and a xml created by (I guess) JBidwatcher-2.0beta11
and not work in JBidwatcher-2.1pre2 ?)

FINALLY, the answers you care about !

Multiple entries are within UI
It’s there in both the pre2 & pre3 releases.
OK in JBidwatcher-2.0.1

RE:Shipping amount in Bold.
The entry was parsed by JBW, no manual intervention.
One tab of 132 items has 43 highlighted shipping entries. None were manualy added.

I shouldn’t spend too much time if it’s just my report of delete problems.

I’m watching a lot of items from the results of my automated searches. I then ‘weed out’ almost all search results to leave the few I will actually watch in JBW……….
I normally have to delete in blocks of 50 – 75 items so JBW is not ‘busy’ for too long.
When I ran pre3 I tried to delete a group of approx 180 items.

Another instance tried to delete 3 listings, One deleted cleanly, the other two remained highlighted in the tab
They did delete across a restart, so not a great problem.

JBW is a snipper program. It still Snipes, and if you bid enough you win……

Thank’s to Morgan It does the one important thing.
Everything else, are added value extra’s.
Thank’s for your time & find a gratitude payment.
( JBW 2.1pre3-998, Win XP-Pro sp3)

Avatar The Gaffer 5 post(s)


from your screen capture I guess you are using the gui?

I entered the auction No# in JBW 2.1pre3-998 ui and it listed fine with the correct end date.

I’ll get myself registered to use ‘My JBidwatcher’ and see how it works……

Regards Alan.
( JBW 2.1pre3-998, Win XP-Pro sp3)

Avatar The Gaffer 5 post(s)


Had sometime to play inbetween snipes…

As a workaround for the extended periods of disc activity I have, where there is a risk of missing a snipe because the system is busy. For auctions I REALY want to win I use a cutdown set of files only containing only a few items I’m sniping on in the near future.

I copied & pasted a old set of files last used with JBidwatcher-2.0.1 into the JBW Folder.
I ran up JBW 2.1pre3-998 and it wiped the searches xml as expected,
it DID create the new ‘My ebay’ tab.
I ran get my ebay items, nothing in the newly created tab.
BUT it did load them into the ‘current’ tab.

No duplicated auctions,
No bold text in the shipping column
So it’s not all broken !

In the ‘added value’ category.
A thought to help users with overworked under performing systems, could JBW pause updating auctions and any other none critical actions say 5 or 10min before a snipe,to give the machine a chance to get back ‘upto speed’ before the 2min bidding form request and I guess the final ebay / JBW time delta check. (Could this be the cause of the wildly differing timing errors other users have reported? I have missed snipes with pre JBidwatcher-2.0.1 releases but not recently. And if I have been around, the system is obviously struggling with intesive HDD activity, which nobody else has commented on?)

Tried to set up ‘My JBidwatcher’ I’m unable to check the ‘enable my Jbidwatcher’ box.
A mouse hover highlights the box, but mouse click or spacebar doesn’t modify the box.
Also I to have noted the save action in the configuration manager does not also close the window.

Regards Alan.
( JBW 2.1pre3-998, Win XP-Pro sp3)

Avatar RCalistan 37 post(s)

Switched over to 998 2 minutes before a snipe, had to see if it worked… :-O It did, just fine… :-)

Things I’ve noticed, right off the bat:

1. I ran into the deleting problem The Gaffer mentions when I was cleaning some old auctions out. What I did: first I ran some massive updates on completed auctions that had
unknown" high bidders and were showing as false FPs. v998 fixed these all up nicely. I then had a bunch of auctions that had 0 bids on them and since I don’t care to save those, I Shift-click selected them and did a right-click | delete (just hitting the delete key didn’t work). Some of the selected items deleted, but not all. Some of the remaining auctions stayed selected, some didn’t and the sorting of the remaining items all changed. Hmm, that’s weird I said to myself, and did another block-select and delete. jbw deleted more but not all. The third time worked. One thing that I noticed the 2 different times I tried this was that the list of items in the tab changed from more than a screen-ful to less than a screenful and there was artifacting of old auctions in what should now be whitespace (I hope that makes sense). Clicking a column to res-sort cleared up the artifacts. The error log has the normal “Deleting 26 entries” entry. Don’t know if the count matches what was actually deleted. I’ll try it again and do some checking….

2. I did see one instance of an auction repeated in pre2. I forgot all about it until reading it in the thread here. I deleted the dupe and the remaining now non-dupe was there after a restart.

3. I only have one search enabled – the get my ebay. I do all my searching with firefox and then watch the items i’m interested in and let jbw grab them for sniping. With v998, I do see an error in the logs:

Sat Aug 01 19:25:04 EDT 2009: JBidwatcher 2.1pre3-998
Sat Aug 01 19:25:04 EDT 2009: Sun Microsystems Inc. Java, version 1.6.0_13 on Windows XP
Sat Aug 01 19:25:05 EDT 2009: Loaded the appropriate driver.
Sat Aug 01 19:25:05 EDT 2009: Connected to database jbdb (JBidwatcher DataBase)
Sat Aug 01 19:25:05 EDT 2009: Auction information database already exists.
Sat Aug 01 19:25:05 EDT 2009: Closed connection
Sat Aug 01 19:25:06 EDT 2009: Database shut down normally
Sat Aug 01 19:25:06 EDT 2009: Loaded the appropriate driver.
Sat Aug 01 19:25:06 EDT 2009: Connected to database jbdb (JBidwatcher DataBase)
Sat Aug 01 19:25:06 EDT 2009: Closed connection
Sat Aug 01 19:25:06 EDT 2009: Database shut down normally
Sat Aug 01 19:25:06 EDT 2009: JBW: Failed to load saved searches, file exists but can't be loaded!
  XML Parse Exception during parsing of the XML definition at line 1:
  Syntax error while parsing a tag name
  XML Parse Exception during parsing of the XML definition at line 1:
  Syntax error while parsing a tag name
	at com.jbidwatcher.util.xml.XMLElement.syntaxError(
	at com.jbidwatcher.util.xml.XMLElement.scanTagName(
	at com.jbidwatcher.util.xml.XMLElement.parseCharArray(
	at com.jbidwatcher.util.xml.XMLElement.parseCharArray(
	at com.jbidwatcher.util.xml.XMLElement.parseFromReader(
	at com.jbidwatcher.util.xml.XMLElement.parseFromReader(
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at com.simontuffs.onejar.Boot.main(
Sat Aug 01 19:25:07 EDT 2009: Scripting is not enabled.
Sat Aug 01 19:25:07 EDT 2009: Loaded the appropriate driver.
Sat Aug 01 19:25:07 EDT 2009: Connected to database jbdb (JBidwatcher DataBase)
Sat Aug 01 19:25:07 EDT 2009: Loading listings from the database (116/493/494 entries, 494/497 auctions)
Sat Aug 01 19:25:07 EDT 2009: Done with the initial load (got 116 active entries)
Sat Aug 01 19:25:08 EDT 2009: Auction Entries loaded
Sat Aug 01 19:25:08 EDT 2009: Completed loader spun off

My searches.xml was originally (with pre2 and before I ran pre3 for the first time) either:

My eBay 1 ebay 0 1248498974267 current My Selling Items beelsr 1 ebay 0 selling


My eBay 1 ebay 0 1248498974267 current

Sorry, I can’t remember if I had deleted the seller search or not, I’m pretty sure I already did.

It was changed by pre3 to (after its first run) to:

My eBay -1 ebay 0 My eBay

i went to the search window, it showed as disabled (it wasn’t with pre2) and I couldn’t enable it with the enable button I hit the edit button and could enable it for every hour and change the destination tab back to current. Will report later on how it works. A manually fired get my ebay seemed to work fine, with no errors in the log (other than the usual “Bad input tag (ignoring): button id=”EditButton_xxxx…." ones I seem to always get with debug loggin turned on)…

The searches.xml is now:

My eBay 1 ebay 0 1249176494058 current

3. High bidder is being kind of correctly reported. The feedback # is trailing my name – e.g., “beelsr (581)” – and for auctions I’ve won, this is this is causing the highlight to be red and not blue. It also sorts differently from old auctions where the high bidder was identified as just the name.

4. Most BIN auctions I’ve won don’t report the high bidder. Looking at the actual page, there’s no second page with bidder history. There is the text: “Congrats beelsr! You bought this item.” in the top frame that you could search on. It does look like parsing gets hammered because current shows as “null (FP)” and price as “null”. Some others don’t recognize me winning but do report the prices correctly. I can supply screen prints and or the html files returned or whatever you want to debug if you need it. Items: 300323576861(unknown high, correct price), 300302543467 (unknown high, null (5) price), 200366094980 & 200366094980 (“—” high, null (FP) price).

5. I clicked on the “Enabled My JBidWatcher” checkbox and it turned the input fields from grey to white but the box didn’t check. I didn’t put in a name/pw or anything (don’t have one) and it’s perpetually. Didn’t find anything in the config. Just FYI….

6. In the config, what is the difference between the and ebay.mature attrs? .adult is true and .mature is false. I do NOT have the “I plan to view adult….” checked in the configure dialog (but most likely did at some time in the past). I assume you changed the attribute name from adult to mature but the adult didn’t get cleaned up during the conversion.

7. Related to #4, some BINs that are still active have parsing error for the bidder: “Return policy details:” (360169355070, 360174312318; same seller), “prepays item bid….” (300300092550).

8. Snipes & buys are working just fine. Haven’t multi-sniped yet. Had one yesterday but I lost both… :-(

Avatar madra 17 post(s)

JBidwatcher (2.0.1-825) – mac OSX 10,5,7.

i’m getting the same symptoms, although snipes do seem to be working properly as i won a ‘FP’ auction with a snipe only yesterday.

i’m also getting a symptom that someone else mentioned above, whereby some [but not all auctions] are showing their price as $1. i’m in UK so my listings are in £s anyway.

also, all my sellers are listed as ‘(unknown)’ and although snipes are working, the interface is not indicating that i have wone the auction ie. they are not turning blue.

all of these issues [apart from the incorrect bid amounts of $1] are not really stopping jbidwatcher from winning me snipes. they’re more just annoyances, but i thought i might as well flag them up anyway.

Avatar BVH 4 post(s)

Hello Morgan,

I just downloaded JBW 2.1pre3-998, and I am still unable to snipe because auctions still all show as (FP). I am using Windows. in the U.S. bidding on U.s. Auctions, Thanks!

Avatar Christoph 21 post(s)

BVH, try updating false FP auctions, they should revert to normal with version 2.1pre3-998; if not, press Ctrl-e to open the snipe window despite of the menu item being inactive. There you can enter the value as on any other auction, the snipe will be stored and work as expected. The FP does not really matter, it only prevents you from using the context menu to snipe.

Avatar Morgan Schweers Administrator 1,204 post(s)

@buserror – I believe you have out-of-date overrides, so your date/time parsing is broken. Overrides carry over from version to version, so it’s very possible to carry them as you upgrade. I twittered the steps to clear them out in an @ message to you.

Fundamentally, if you open the Advanced tab, type ‘override’ into the key area, it should pull up any overrides you might have defined. Select each in turn, and click ‘Delete’ to remove that key. Then, once you’re done, save the changes, exit JBidwatcher and restart it.

The overrides should be gone, and auction updates afterwards should show up correctly.

— Morgan Schweers, CyberFOX!

Avatar Morgan Schweers Administrator 1,204 post(s)

@Richard Beels – You’ve got the right idea on #6; was the old setting, which most people clicked because it seemed the right thing to do. :) I try to discourage it in the 2.x series, because it’s a much more complex flow, so I made folks who wanted it enabled re-enable it, by changing the configuration name.

I think I know what’s breaking with search between sessions, but it’s going to take a little bit for me to fix it.

Fixed price ‘winners’ is another thing that I’m working on; it’s similar to auction winners, but since there can be multiple buyers, it makes it a little harder.

My JBidwatcher is really, really raw right now. If you sign up for it on the web site, it’ll send you an access key (although I have to bump up your access by hand afterwards), but you can also use your web site password. (I strongly recommend against making it the same as your eBay password.) I’m too busy trying to get JBidwatcher working to spend time on the web app, but I really want to get back to it as soon as possible.

Thanks for the pointer to listings that are failing the feedback parse; I’ll try and figure out what I can do…

Glad snipes are working for you! :)

— Morgan Schweers, CyberFOX!

Avatar RCalistan 37 post(s)

Hi Morgan. Thanks for the updates….

Don’t worry about My jbw, not using it right now.

I do notice more memory being consumed. pre2 and before would sit at around 100MB of private memory (xp sp3) for the javaw process. pre3 ends up at about 100MB after the initial startup/update cycle. after about 24 hours, it’s up to 140MB-ish but I haven’t had a longer program run since I started using pre3…

Avatar doomkrad 54 post(s)

Hi Morgan, thanks for 2.1pre4, I downloaded it roughly an hour ago.
One issue that will probably interest you:
the US item (added after moving to 2.1pre4) 220463091784 shows the seller as (unknown).
If there are any other details that I can provide about it, please let me know.
Thanks again,

Avatar JBWUser 7 post(s)

Hi Morgan,

Sorry for bad news but JBidwatcher 2.0.1-825 still has false-FPs.
Sample auction numbers are 180394658849 and 320407333795.

Avatar zappram 290 post(s)

Why are you not using the current version (JBW 2.1Pre4)?

Just curious…

Avatar santa 11 post(s)

Starting yesterday and using 2.1pre4 on windows XP, I started once again to have false FPs and (unknown) sellers.
Example auctions : 360179394422 (false FP), 390079175171 (unknown)

Thanks for your work Morgan. It looks like ebay is making your life quite complicated.