Get My eBay Items stopped working

Subscribe to Get My eBay Items stopped working 52 post(s), 19 voice(s)

← Previous 1 3
 
Avatar gurumarkb 22 post(s)

This is the 2nd time this year that JBidwatcher 2.0.1-825 has stopped retrieving my eBay watch list. I get logged into eBay ok but the “Get My eBay Items” doesn’t display anything even though the status line at the bottom says “synchronizing with My eBay”, there is a pause (presumably communicating with eBay), and then it shows “Done synchronizing with My eBay” with nothing in my current list. I have many items I’m watching so it’s not an empty watch list. The last time this happened I had to rename the .jbidwatcher directory inside my user name folder on XP Pro SP2 and restart JBidwatcher so it would create a new folder and set of files. I hate this as then I lose all the auctions I have in my “Completed”, “Won”, and a tab called “Outbid” that I created to keep all auctions I’ve bid on but not won. Are the contents of the different tabs kept in separate files so I can copy back the “Completed”, “Won”, and “Outbid” listings after I rename the .jbidwatcher folder?

I also keep getting this “error.##.log” file error:

Tue Jul 14 20:36:25 EDT 2009: JBidwatcher 2.0.1-825
Tue Jul 14 20:36:25 EDT 2009: Sun Microsystems Inc. Java, version 1.6.0_14 on Windows XP
Tue Jul 14 20:36:26 EDT 2009: Error setting up scripting: java.lang.NoClassDefFoundError: org/jruby/runtime/builtin/IRubyObject
Tue Jul 14 20:36:26 EDT 2009: Loading listings from the database (0/57/57 entries, 57/57 auctions)
Tue Jul 14 20:36:26 EDT 2009: Done with the initial load (got 0 active entries)

I’m up to error.54.log currently but all the error log files say the same thing about an IRubyObject. I do run RegCure 1.5 once a month to clean out the garbage that builds up in my XP registry. Could it be removing something important to JBidwatcher or Java?

 
Avatar gurumarkb 22 post(s)

Ok I decided to rename the .jbidwatcher folder. After running JBidwatcher it created the .jbidwatcher folder but this did not fix the problem. Now the “errors.log” file says:

Tue Jul 14 21:30:41 EDT 2009: Getting the sign in cookie.
Tue Jul 14 21:30:41 EDT 2009: MQ_Swing: Postponing Message: Getting the sign in cookie.
Tue Jul 14 21:30:43 EDT 2009: Done getting the sign in cookie.
Tue Jul 14 21:30:43 EDT 2009: MQ_Swing: Postponing Message: Done getting the sign in cookie.
Tue Jul 14 21:31:54 EDT 2009: MQ_tray: Postponing Message: TRAY on
Tue Jul 14 21:31:54 EDT 2009: Dequeue'd unexpected command or fell through: 4:Update login cookie
Tue Jul 14 21:31:55 EDT 2009: JBidwatcher 2.0.1-825
Tue Jul 14 21:31:55 EDT 2009: Sun Microsystems Inc. Java, version 1.6.0_14 on Windows XP
Tue Jul 14 21:32:00 EDT 2009: Error setting up scripting: java.lang.NoClassDefFoundError:
org/jruby/runtime/builtin/IRubyObject
Tue Jul 14 21:32:00 EDT 2009: Failed to set the tray icon using the java6 method!

Still shows the IRubyObject error and another error about the tray icon even though the icon displays correctly in my system tray. Any help deciphering this would be greatly appreciated.

 
Avatar gurumarkb 22 post(s)

Uh Oh, I’ve got a bad feeling eBay just changed their database access yet again. I went on my friends computer and deleted his watch list, tried the “Get My eBay Items”, and nothing came up in his current list. This is very bad if JBidwatcher can’t retrieve the watch list anymore!

I went back and copied the contents of my old jbidwatcher folder back to the newly created .jbidwatcher folder and all my previous auctions are back again. It looks like copying the XML files and the auctionsave folder contents gets my old auction info back at least.

Manually adding an auction still works so at least I can get items into JBidwatcher so I can snipe them but now the dreaded “(unknown)” comes up in the Seller column. I hope some one can figure this out real soon.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
eBay just broke JBidwatcher for non-US items by not including a element in the page that’s returned on ebay.com for items that aren’t visible on the US site. The symptom is JBidwatcher freezing up, at least with respect to updating or reading auctions.

I’m working on a fix.

— Morgan Schweers, CyberFOX!

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

This post is now out of date. Try the 2.1pre3 version now.

You mention running Windows, the pre-release for the next version is here: http://www.jbidwatcher.com/alpha/JBidwatcher-2.1pre2.exe

If you’re running Linux, you should be able to grab the latest version at: http://www.jbidwatcher.com/alpha/JBidwatcher-2.1pre2.jar

If not, and you’re running Mac OS X: http://www.jbidwatcher.com/alpha/JBidwatcher-2.1pre2.dmg

It’s steaming hot and fresh from my compiler, with just enough testing to know that it can parse the basics from the failing non-US listings. I found sniping bugs and fixed them since the last pre-release (about 10 super-early testers), and I’ve tested sniping a few days ago and it worked, but I haven’t tested it since. I know that’s not as reassuring as folks would like, but it’s what I’ve got right now.

It should be up there as of now. Give it a try, and let me know how it goes! If it doesn’t work, or if it does, please tell me.

— Morgan Schweers, CyberFOX!

 
Avatar bidfish 14 post(s)

Latest alpha seems to be sniping fine.
For testing purposes I just sniped a book for EUR 1,50 plus 1 EUR shipping costs ;)

 
Avatar Marc 13 post(s)

Morgan,

Thank you for the quick fix.
I tested it under Linux : no more freezes, seller ID reappears, and I can add new auctions again.
Haven’t tested bidding or sniping yet.
One problem remains : the high bidder remains ‘(unknown)’ on a past won auction that has no bidder hiding.

Marc

 
Avatar Marc 13 post(s)

I have tried to bid right now, and it didn’t work,
nothing is sent to eBay, and nothing is shown on JBid
either in the information window or in the Max column.

Marc

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
I just tried to replicate that a lot of times, and couldn’t. It seems to bid fine. The real frustration for me is that I ran into a situation where it successfully submitted the bid, but got ‘stuck’ trying to update afterwards, but I couldn’t replicate it in the debugger.

It doesn’t help that my wireless antenna is broken and my machine shuts off if it overheats (which it does when JBidwatcher gets stuck in an infinite loop consuming CPU). I’m still working on it… I believe that bidding and sniping are, for the most part, working though.

US/Non-US?

— Morgan Schweers, CyberFOX!

p.s. The ‘(unknown)’ bidder problem is because the new eBay format pages don’t actually have the high bidder shown on them. :( I’m going to have to do another network request to retrieve that information, and a much more complex parsing process…

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Ah; false alarm. I’d downloaded an older version of pre2. :(

No hang with the current version. whew

— Morgan Schweers, CyberFOX!

 
Avatar Hoddy 108 post(s)

Hi Morgan, I’m afraid there seem to be lots of problems with the 2.1pre2 release. I’m using the Windows executable version on a Win XP machine and I am in the UK. Problems I’ve found so far are:

1) Fails to bid or snipe – as reported earlier – nothing is shown on screen
2) High Bidder is (Unknown) – as reported earlier
3) Screen display/program crashes when you delete an item (does not delete an item untill you restart the program)
4) Does not load Won items
5) Does not load all my items. I am watching 117 but only 107 are loaded. Items with more than 8 days to go are not loaded – these are all ‘Buy it Now’ auctions
6) I can’t even add the items not loaded by either drag and drop or by inputting the auction number

I expect others can add to this list……… Sorry to have such a large list.

Regards Hoddy

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

  1. I can’t replicate this with anything I’ve tried on.
  2. I described the problem above. I’m working on it, but it’s not an easy solution, and it’s going to double the eBay web page hits. :(
  3. I’ll look into that.
  4. Not sure what you mean… You mean ‘My eBay’ won items? No, it probably doesn’t…haven’t touched that code in ages. I think it tries to read the page of items you’re bidding on, but I’m not even sure that page still exists with the new My eBay.
  5. 107 out of 117? I didn’t think JBidwatcher could get more than 100 right now; it only looks at the first page of results. The other 7 are probably coming from the ‘bid on’ page?
  6. Perhaps those items are suffering from some other problem? Look in your log file for errors, or paste in the item numbers and I’ll have a look.

Well, that is I’ll have a look when I wake up, and after I get my car towed to the repair shop. It’s 5:30am for me, and I’ve been trying to write parsing code to analyse the ‘Bid History’ page, so I can pick up the high bidder information, even though it’s obfuscated on most items. I think I’ve got an approach that’ll work, and it might help longer term with parsing some of the other pages.

Issue #1 bugs me the most, because it’s working for me and some others. :(

— Morgan Schweers, CyberFOX!

p.s. I hate to say this, but further My eBay bugs might not get fixed for this release. The current problem of hanging when loading certain non-US auctions is far too serious for international users to hold it up because the My eBay import isn’t working. I really need to understand if there are any sniping or bidding problems with this release, though.

 
Avatar Hoddy 108 post(s)

Morgan,
This is the error when I bid:

Wed Jul 15 13:52:10 BST 2009: Bidding null on 1 item[s] of (390068974055)-Remote & Nunchuck
Controller Set Fit Nintendo Wii uk
Wed Jul 15 13:52:10 BST 2009: PMQ Caught exception: java.lang.NullPointerException
java.lang.NullPointerException
	at com.jbidwatcher.auction.server.ebay.ebayBidder.getBidInfoURL(ebayBidder.java:182)
	at com.jbidwatcher.auction.server.ebay.ebayBidder.getBidForm(ebayBidder.java:109)
	at com.jbidwatcher.auction.server.ebay.ebayBidder.bid(ebayBidder.java:314)
	at com.jbidwatcher.auction.server.ebay.ebayServer.bid(ebayServer.java:497)
	at com.jbidwatcher.auction.AuctionEntry.bid(AuctionEntry.java:1262)
	at com.jbidwatcher.auction.AuctionBid.execute(AuctionBid.java:23)
	at com.jbidwatcher.auction.AuctionActionImpl.activate(AuctionActionImpl.java:44)
	at com.jbidwatcher.auction.server.ebay.ebayServer.bidMsg(ebayServer.java:278)
	at com.jbidwatcher.auction.server.ebay.ebayServer.messageAction(ebayServer.java:202)
	at com.jbidwatcher.util.queue.PlainMessageQueue.run(PlainMessageQueue.java:55)
	at java.lang.Thread.run(Unknown Source)

Regards
Hoddy

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
aghast look What JRE are you running?

I think…bidding may work under 1.6, and fail under 1.5. Or something like that. Sniping should be unaffected, though.

If you underbid on an item, and you get, ‘Your bid for null was too low’ as a message, then it might be a Java version problem. Apparently the older JRE is broken in how it handles a perfectly valid construct. :(

— Morgan Schweers, CyberFOX!

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Heh! You and I posted at the exact same time. Yeah, that looks like the problem I think it’s seeing. As I said, sniping should not have that problem, but…crap. Back to the drawing board, at least later today.

— Morgan Schweers, CyberFOX!

p.s. Goodness; this is my 700th post. Wow…

 
Avatar Hoddy 108 post(s)

Hi Morgan,
I’m running Java version 1.60_14-b08…..

Hoddy

 
Avatar gurumarkb 22 post(s)

Thanks for the fast responce Morgan. The 2.1pre2-963 version has the “Get My eBay Items” function working again and the seller names are back as well for the US eBay site. I know it has to be very frustrating keeping up on all the page format changes that eBay makes all the time. You are correct that the 2.1pre2 version only gets the 1st page of the watch list.
I’m also sorry that your car is in the repair shop so I’ll PayPal again (it’s been a few years) to keep JBidwatcher alive. Many thanks again.

Everyone please donate to keep the JBidwatcher project alive. Thank you.

 
Avatar Marc 13 post(s)

Morgan,

With the 2.1pre2 release sniping works fine from Europe to buy a US item.

Marc

 
Avatar gurumarkb 22 post(s)

Oops, I spoke too soon about the 2.1pre version. It worked once and I thought all was ok but I added 3 new auctions to my watch list that end in a couple of hours so they are on page 1 of the eBay watching but the “Get My eBay Items” failed to update the display. Ok, I know this is a pre release so I’ll just manually add them. When trying to do that JBidwatcher says it can’t add the auction because it’s already in the list even though I can’t see it. Ok, so I highlighted all the current items and deleted them, went back and chose “Get My eBay Items”, watched the status line saying “Synchronizing” and then “Done synchronizing” and I have a completely blank “current” tab. Since I can’t manually add an auction that it imported from the eBay watch list I’m switching back to the 2.0.1 version for now as the “current” display will show any item I manually add to it. For now that will work and I know this display bug willl be worked out by the time 2.1 goes gold.

 
Avatar gurumarkb 22 post(s)

After switching back to 2.0.1 and just for the H of it I tried the “Get My eBay Items” function. The status line showed the normal “Synchronizing” but instead of nothing for a few seconds it actually showed the “Getting …” for each item I have on page 1 of my watch list including the 3 new ones I recently added. Since JBidwatcher 2.0.1 is reading the eBay watch list it appears to be a problem where it’s just not updating the “current” tab to display the auction item that it just imported. Very wierd behavior.
I fixed the display problem by renaming the .JBidwatcher directory and allowing version 2.0.1 to recreate it. Now when I manually add an auction it is displaying properly. Obviously the 2.1pre2 version added or changed something that screwed up the displaying of each auction (like using a white font on a white background).

 
Avatar gurumarkb 22 post(s)

Good news on version 2.0.1 is that it still snipes properly for me on the US site. Of the 3 auctions I added this morning JBidwatcher placed a bid on all three at the right time and I won 2 of them. Unfortunately JBidwatch failed to know that I had won anything and put all 3 in my “Outbid” tab. That’s a very minor problem as it’s easy to send it over to the “won” tab but it shows up in red instead of the normal blue color. At least I can use 2.0.1, manually add the auctions I’m sniping, and manually move anything I win to the “won” tab until Morgan has the time to figure out just what in H eBay has changed now. Good luck, and “may the force be with you”.

 
Avatar Hoddy 108 post(s)

Update Hi Morgan, JBidWatcher 2.1pre2 release is now showing both Seller and High bidders (I’ve gone blue again)! I had to restart JBidWatcher after deleting an item (still crashes on deleting an item from a column) this morning (Thursday 16th July) and hey presto they appeared and are still showing. JBidWatcher has now also found and now shows all my “Watched, Won & Items I’m Bidding On” items (total 150+ items). I still can’t bid from within JBidWatcher but Sniping works but Items that have ended are no moved to the Completed column. On deleting an item(s) the popup box is to small (height wise) and has to be stretched every time so get to the confirmation button. I assume Ebay have made some more changes……….

Regards
Hoddy

Update II I had to restart JBidWatcher as I deleted an item and the Highest Bidder column went back to (Unknown) sigh. I have found if I keep restarting JBidWatcher it eventually starts working again so I can now see the Highest Bidder again…. but I expect it will break again if/when I restart JBidWatcher – deep sigh.

 
Avatar Marc 13 post(s)

Morgan,

With the 2.1pre2 release sniping works fine
from Europe to buy a US item offered worldwide
from Europe to buy a European item offered worldwide
and also on items offered only locally.
Bidding doesn’t work
from Europe to buy a US item offered worldwide and seems to freeze JBid.

Marc

 
Avatar BVH 4 post(s)

Morgan,

I am still having problems getting my “watched” items. It seems to get all my selling items properly, but, not the watched items. I can also not manually enter them. I’ve downloaded and installed the new pre-2.01 update. Here is an example of an item I am trying to manually add: 270423818646

Both the item and I are in the U.S.

What am I doing wrong? Thanks for a great product!

 
Avatar Zoran 1 post

Hi. I’m an intermittent user of JBidwatcher (and of eBay) and am still running version 2.0.1-825 on a Macintosh running System 10.5.7 in Australia.

I just got up and noticed that my JBidwatcher seems to be working again. All the “unknowns” for Seller have disappeared, replaced with the names of the actual sellers. I haven’t tried to snipe on anything (there’s nothing I want currently), so I don’t if that’s working again, but I thought I should let you know that whatever eBay did, they seem to have undone.

I haven’t restarted JBidwatcher – I just have it running in the background more or less continuously. In the past, whenever JBidwatcher started showing “unknown” for sellers I found if I restarted it that fixed the problem. This time restarting didn’t work, so I just left it running with the “unknowns” just to monitor various auctions. So, I assume whatever has caused the “unknowns” to disappear must be something at eBay’s end rather than me clearing some glitch.

Maybe eBay was trying something new, decided it wasn’t working for whatever reason and have gone back to an earlier version.

← Previous 1 3