Lost most of my current auctions

Subscribe to Lost most of my current auctions 5 post(s), 3 voice(s)

Avatar krs99 99 post(s)

The strangest thing just happened to me.

My Mac running OS 10.4.8 was running a bit sluggishly, so I decided ti restart it.
I have done that on occasion before to clear out memory and reset things.
Most of the time, I let the mac quit all open applications while it’s shutting down, but recently I have been using force quit to speed things up a bit.
The other reason I use force quit is because JBW invariably cancels the shut down when I have open snipes and I have to in a second time to tell JBW to quit.
Nothing unusual about any of this – I have done that a number of times before.

So the mac starts up, after the desktop is launched, I restart JBW, it starts up normally, but when I look at the current auction page, a whole set of auctions is in red. They disappear one by one because these were auctions that had finished quite a while back, also not really an issue although I have never seen this before, but the problem is that a whole set of additional auctions that I had saved to JBW today have just disappeared. They are no longer in the ‘current’ auction list or in any of the other tabs.
For some of these I had snipes set, others I was just watching.
First time that ever happened.
I wonder if anyone has a clue what went wrong. It almost seems as if JBW loaded an older version of the ‘current’ data that still included auctions that have now been completed and didn’t have the new updates yet.
The only thing I can think of that I did different is that I saved auctions to JBW by dragging the ebay URL to JBW whereas before I always copied and pasted the ebay number.
None of the auctions I want to snipe on close for a couple of days yet, so I’ll see if anyone has a suggestion how to retrieve the “lost” auctions before I add them manually again.
Maybe I shouldn’t have force quit JBW, but I have done that before without any ill effect.

One more point I just noticed.
I added three new tabs, today I think, after laurence told me how to do this.
I also changed the properties of most of the tabs – existing and new.
The three additional tabs are still there but all the properties are back to their default value, ie everything gets moved to “completed”

One more comment.
After restarting the mac, things are whipping along again.
However, I also noticed that the clean up I was doing in my completed auctions didn’t get saved either. Hundresd of auctions that I had deleted were back again suggesting that in fact JBW picked up an older verion of the data.

Avatar Morgan Schweers Administrator 1,204 post(s)


Using ‘Force Quit’ on JBidwatcher is a really bad thing. It kills the app without giving it time to save its data. In JBidwatcher’s case, that’s all the stuff you lost. :(

JBidwatcher cancels shutdowns because it needs to take time to clean up, save, and check to see if there are any snipes, in case it needs to warn you that you might miss them while it’s down. I’ve tried in the past to improve its behavior in regards to shutdown, but evidently not enough.

Still, if you force-quit it, it doesn’t get the chance to save (or do any of the rest of what it’s trying to do, but not saving is the Very Bad part). In my hypothetical future version, it would be less of an issue, but it would still definitely be an issue.

If you have done a force-quit on JBidwatcher in the past, you may have lost items you’d added in the last half hour before closing it, or however long since JBidwatcher saved its data out. (Usually every half hour, which is why I say that.) You may not have even noticed, because it’s a lack of something, not the presence of something wrong.

Don’t ‘Force Quit’ JBidwatcher unless it’s entirely failing to quit on its own.

‘Force Quit’ even warns you that you may lose unsaved changes if you do that. Unfortunately, that’s exactly what happened here.

— Morgan Schweers, Cyber*FOX*!

Avatar r2d2hp 8 post(s)

I seem to have suffered from a similar problem, when I restarted jbidwatcher after a forced shutdown as it seemed to have hung its trying to bid on a number of completed auctions and all my current auctions have disappeared.

Many of the current were added by a scheduled search that adds the items from My Ebay but running it again will not bring them back.

Have I broke it somehow?

Avatar r2d2hp 8 post(s)

Have updated to (1.0.2pre6) and now its picked up my current auctions again. Forgot to say I am running windows xp.

When I tried to shut down 1.0.2pre4 it would not exit so I had to task manager to abort it. Now I have updated to 1.0.2pre6 all exits as expected.

Avatar krs99 99 post(s)

Still, if you force-quit it, it doesn’t get the chance to save (or do any of the rest of what it’s trying to do, but not saving is the Very Bad part). In my hypothetical future version, it would be less of an issue, but it would still definitely be an issue.

Makes sense – I thought it was something like that.
No problem – I shouldn’t have used force quit for that in the first place just because I was too lazy to wait.
Won’t do it again.

BTW: I have never ever had to use force quit with JBW because it was hung up somehow.