Has ebay broke it? (19 July 07)

Subscribe to Has ebay broke it? (19 July 07) 134 post(s), 50 voice(s)

 
Avatar hawkeye 25 post(s)

HI Huntz, well so far I have got the “watching items” up and are trying a snipe, finishing in 30 mins, can’t get finished items though, Thanks for your work on this, Mac OSX 10.4.10 Malcolm

 
Avatar psiberware 2 post(s)

huntz…

Loaded up your .jar on a Win XP Pro (Java 6 Update 2). No red eyes on US site. Auctions load and add. Got a snipe set to go in an hour on US eBay, will let you know.

 
Avatar pmx 5 post(s)

Hi,

snipe works !

 
Avatar hawkeye 25 post(s)

Hi, me too snipe worked great, didn’t win it be hey so what!!! item put into complete window, so I would say so far so good, cheers, Malcolm

 
Avatar russ132 6 post(s)

Downloaded pre3 just a few minutes ago, would not pull anything from eBay. No error messages, so not sure what the problem is.

russ132
AKA Ray

 
Avatar gl 25 post(s)

Just a quick note to say that pre3, although broken listing-wise, did actually sucessfully fire a snipe (and I won it : ) earlier today.

Looks like I’ll need to set up a Java dev environment (I’m a C++ guy)…

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

1.0.2pre4 is available from the Announcements forum @ http://forum.jbidwatcher.com/forums/9/topics/1042.

I woke up about an hour ago, and went through all the messages while debugging the new change. Thankfully it appears minor, and brings back the end-time for stores!

— Morgan Schweers, Cyber*FOX*!

 
Avatar Miffy 1 post

Hi,

Just to let you know that pre4 (.jar, jre 1.6.0, win2k) is sniping Ok, moved item to complete and even coloured it in properly as I’d won it! :o) Also, pulling new items from myEbay working OK. Nothing untoward appearing in the log. Looks good.

Mark

 
Avatar krs99 99 post(s)

Pre4 updated all my pending auctions except this one: 160139367315

But none of my “red eye” completed auctions were updated – should that happen as well or can I just forget about those?

I’m on OS 10.4.8

Update: 160139367315 updated itself, but the completed auctions didn’t.

 
Avatar Martin Bürkel 18 post(s)

Hi,
pleas consider this phenomen when you are working on new code:
I want to Quit JBW (From the Menue or via shortcut ) ant the Konsole says:
Mon Jul 23 14:33:58 CEST 2007: Exception during the check() operation of class AuctionsManager
java.lang.NullPointerException
at AuctionInfo.toXML(Unknown Source)
at AuctionEntry.toXML(Unknown Source)
at AuctionServer.toXML(Unknown Source)
at AuctionServerManager.toXML(Unknown Source)
at AuctionsManager.saveAuctions(Unknown Source)
at AuctionsManager.checkSnapshot(Unknown Source)
at AuctionsManager.check(Unknown Source)
at TimerHandler.run(Unknown Source)

and wont let me quit.
The activity of the jbw process goes up and stays high.
(Mac OSX 10.4.10 on Intel with JBW 1.0.2.pre4)
Martin

 
Avatar bidmaster 4 post(s)

Won’t update auction prices on OS 10.4.10.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
For the intermittent red-eye issues, look here:
http://forum.jbidwatcher.com/forums/9/topics/1042?page=2

If you have items that were marked as ‘completed’ during the time when things weren’t going well for JBidwatcher, hilight them, pull up your context menu, choose the ‘Advanced’ menu, and ‘Mark as not ended’.

I don’t know what the quit-save-XML failure is, unfortunately. I can’t replicate it, probably without your auctions.xml file.

bidmaster: Are you running 1.0.2pre4? Check the version number in the About box.

— Morgan Schweers, Cyber*FOX*!

 
Avatar ian peters 4 post(s)

All working again. Fantastic support from Morgan. I just realised how much I use this software so I sent you some dollars. If comercial software was this well supported it would be nice.

 
Avatar krs99 99 post(s)

I just found out that the latest build of JBW uses up a tremendous amount of my CPU resources – it regularly goes up to 75% and I have seen it go over 80%.
I can’t believe this is normal.
With JBW using 80% of the CPU resources, everything else becomes really sluggish.
I closed all other applications, checked the hard drive, it’s fine, repaired permissions, only two needed repairing. But that issue has not gone away.
I’m running an AGP G4 with a 1.25GHz processor with 1.5 GB of memory. Using OS 10.4.8 and JBW 1.0.2.pre4.

 
Avatar krs99 99 post(s)

If you have items that were marked as ‘completed’ during the time when things weren’t going well for JBidwatcher, hilight them, pull up your context menu, choose the ‘Advanced’ menu, and ‘Mark as not ended’.
-————————-
Thank you Morgan – worked like a charm.

I also quit JBW completely and restarted it again. The 70 – 80% CPU resource issue has gone away. Now when it’s just sitting there, the CPU usage is down to 0.4% and when something happens, ie I open a JBW window, it jumps up to 15 to 20% momentarily. Real memory usage is also way down.

Thanks for the tremendous support Morgan – a financial contribution from me will be forthcoming as well.

 
Avatar krs99 99 post(s)

Ooops – spoke too soon.
The CPU usage is way up again in the 70 to 80% range and memory usage is back up to 95 MB from around 40 MB.

 
Avatar Charlie 16 post(s)

First the good news – pre4 version seems to be working fine for me, including sniping. I’m running WinXP Pro on a 2.66 GHz Pentium 4 in the US, and my Java version is 1.6.0_01-b06. No problem here with excessive CPU usage either, running around 2 to 5 percent with an occasional brief jump to 20. Big thanks to you Morgan for JBW!

Now the not-so-good news – I cannot quit JBW normally, either with the window Close button or Quit on the Menu. Have to use Task Manager. Hey, what do I know, maybe this is a new feature, right? Why would anyone WANT to close JBW? A minor issue, so I’ll quit whining now … :-)

 
Avatar dl6dx 6 post(s)

Just as a pointer:

The same problem Martin Bürkel describes (http://forum.jbidwatcher.com/forums/1/topics/1034?page=5#posts-3159) occurs on my system.

More details in http://forum.jbidwatcher.com/forums/9/topics/1042?page=2#posts-3176.

Regards

Stefan

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

I’m guessing something in the data got ‘broken’ in the process, so when it’s trying to serialize out the data, it’s running into a ‘null’ value someplace where it shouldn’t. :(

For krs99, it’s probably doing it’s half-hour auto-save, and failing, and dumping data to the log file obsessively. :(

Here’s my real problem, though, I don’t know what data is wrong, so I don’t know what to fix!

I need someone who’s having the problem to email me, directly (cyberfox at gmail), their auctions.xml file. The save file location is in JBidwatcher’s Configuration Manager, under the ‘Paths’ tab.

It’s a pain to get to on the Mac, unfortunately, because Finder doesn’t usually view ‘.’ prefixed directories…

Basically, I’ll need to load that auctions.xml file into a running JBidwatcher, and try to save it, to see where it’s failing.

For what it’s worth, that file contains nearly everything that is in JBidwatcher, all the auctions, tabs, your username, and your encoded password, so I understand if few people are going to want to share it, but I hope someone will, so I can replicate the problem. I will only use it to figure out what the heck broke, and it’ll be wiped as soon as I’ve got a fix out.

— Morgan Schweers, Cyber*FOX*!

 
Avatar bondaluh 1 post

pre4 working fine under Win XP (ebay Germany), although I spotted one error which hasn’t been mentioned here (as far as I could see), namely that shipping costs of newly added auctions no longer show up.

Thank you so much for your great work, Morgan, I really appreciate it!

Regards,
bondaluh

 
Avatar dl6dx 6 post(s)

Cyberfox wrote:
I need someone who’s having the problem to email me, directly (cyberfox at gmail), their auctions.xml file. The save file location is in JBidwatcher’s Configuration Manager, under the ‘Paths’ tab.

Morgan,

just sent you auctions.xml and excerpt of error log by e-mail.

Regards,

Stefan

 
Avatar Charlie 16 post(s)

Good morning Morgan,

I just sent my auctions and error files to you a few minutes ago. Hope it helps you out.

Charlie

 
Avatar sammy 2 post(s)

from non-techy
I could not compile
so ran the jar version with patch and newest java EE 6
did reboot of 2 diff systems
both are working fine
the jar version is much slower than Exe
20% cpu when adding or updating memory use low 31mb
have sniped and or did buy it now with no errors
XP pro SPK2 with only 4 critical updates
cable isp at 6mb

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

I believe I’ve found the basic issue behind the save-failing… Give the latest build another try at:
http://forum.jbidwatcher.com/forums/9/topics/1047

Let me know if that works for you!

— Morgan Schweers, CyberFOX!

 
Avatar Martin Bürkel 18 post(s)

Hallo me again,
some of the trubles are gone with the pre5.
But i still cant Quit JBW the normal way. he good thing is that the processor workload is dramatically reduced.
( around 1.5% on a Intel DualCore) so i can let JBW run all the time. ( Every time i force to quit i will loose half of my auctions as they are apparently not saved )
Konsole says:
Wed Jul 25 16:51:17 CEST 2007: Serious error, consider dying.
java.lang.OutOfMemoryError
apple.awt.EventQueueExceptionHandler Caught Throwable : java.lang.OutOfMemoryError
java.lang.OutOfMemoryError

Hope this helps.