Has ebay broke it? (19 July 07)

Subscribe to Has ebay broke it? (19 July 07) 134 post(s), 50 voice(s)

 
Avatar tinkerer007 3 post(s)

Morgan..

Is the windows version supposed to be present at … http://www.jbidwatcher.com/beta/JBidWatcher-1.0.2pre1.exe ?? I have not been able to find it present..

Do appreciate your efforts to ge it working again quickly.. Its a great program.. Thanks..

 
Avatar RBEmerson 22 post(s)

No joy – killed off by the version issue.

wxsat /root# java -version
java version “1.4.2_15”
Java™ 2 Runtime Environment, Standard Edition (build 1.4.2_15-b02)
Java HotSpot™ Client VM (build 1.4.2_15-b02, mixed mode)

 
Avatar David M 19 post(s)

In the current CVS version, there appear to still be some time issues with BIN sales from Shops, etc.

For example, if I quit JBidWatcher and then restart it, any saved Shop items (with no time information) first come up with a very large single number in the “Time Left” field. They are then changed to “N/A” during the first update of the auctions.

Also, it is possible to get apparently contradictory information from eBay and JBidWatcher. For instance, if I do a search, then the search results page for any Shops items DO show a specific “Time Left” value for each item. However, this “End time” information is not displayed on the individual item pages themselves, and so JBidWatcher will not find it. Instead, JBidWatcher first displays “29 d, 23 h” in its “Time Left” field when any such item is transferred, which it later changes to “N/A” during the first update.

Vehicles seem to have a time issue. For example, item 260130815829 is a Classified Ad listed on its eBay page as a “30-day listing” from “21-Jun-07”, and yet JBidWatcher lists the “Time Left” as “29 d, 23 h” from when it is first transferred (in my case, with the listing apparently ending on “Mon Aug 20 00:43:45”). On the other hand, Vehicles with a specified BIN “End time” on the item page (eg. 320138801845) are transferred to JBidWatcher correctly.

David

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

New pre-release, this one built with 1.4.2 and with a Windows version this time as well, has been released:
http://forum.jbidwatcher.com/forums/9/topics/1035?page=1#posts-3030

David: Item 260130815829 is a 60 day listing, actually, so I think JBidwatcher has the right end time for it.

The ‘large number’ switching to ‘N/A’ has been fixed in a quick-patch of the 1.0.2pre2 that I just put up.

I think there may still be a problem where shops items show up with 30 days left until the first time they’re updated, at which point they go to ‘N/A’.

— Morgan Schweers, Cyber*FOX*!

 
Avatar David M 19 post(s)

I can confirm that the compiled JBidWatcher-1.0.2pre2 works fine on my Mac with Java 1.4.2 (unlike the previous Java 1.5 version, which wouldn’t work at all). However, Shop items do still start with “29 d, 23 h” and then swap to “N/A”.

I am also still getting discrepancies between JBidWatcher and eBay with regard to Vehicles, but oddly enough it seems to be eBay that sometimes produces the wrong numbers. I have just checked a number of cars, and JBidWatcher has the correct end time based on the “List Date” and “Duration” information in each of the item pages. However, the “Time Left” information shown on the eBay Search page can be anything up to 5-6 minutes different, irrespective of how often I refresh that page (and the discrepancy varies between refreshes). This may also explain item 260130815829, which I chose originally because eBay listed it as finishing in a few minutes time. Perhaps it was updated to a “Duration” of 60 days in the minute between when the item page was displayed for me and when JBidWatcher read the information.

I don’t know if anyone else can reproduce my results, but JBidWatcher may now be a more reliable source of time information than some of the eBay pages! Perhaps their formatting changes have not been an improvement for their customers.

David

 
Avatar RBEmerson 22 post(s)

JBidWatcher-1.0.2pre2 works here w/ SuSE Linux 10.0

 
Avatar krs99 99 post(s)

JBidWatcher-1.0.2pre2 still doesn’t update the completed auctions with OS X

 
Avatar hawkeye 25 post(s)

JBW 1.0.2pre2 I am running a Mac on 10.4.10 build 8R218 Java 1.4.2 and so far everything works. great stuff

 
Avatar paul_b 4 post(s)

JBidWatcher-1.0.2pre2 seems to be working fine on Mepis 6.5-32.
Thanks for the quick response/fix.

Paul

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

There’s a new pre-release (1.0.2pre3) available.

http://forum.jbidwatcher.com/forums/9/topics/1041

— Morgan Schweers, Cyber*FOX*!

 
Avatar kliere 11 post(s)

Hi folks,

seems eBay broke it again? Last pre2 and pre3 versions exhibit the red crossed eye again and do not update (ebay.de that is).

Mac OS X 10.4.10, latest Java)

Cheers,

k.

 
Avatar fedcas 9 post(s)

same problem for me :s

 
Avatar gl 25 post(s)

same for me, windows/ebay.co.uk. it worked OK yesterday. pre2, and the released 1.0.1 also don’t work.

BTW, would it be possible to get the shipping display working again (it’s been broken for a long time now)? Shipping is always ‘—’ regardless of listing type.

 
Avatar pmx 5 post(s)

Hi all :

the eBay headers now look different .

Example of debug messages (linux) :
Sun Jul 22 13:46:11 CEST 2007: Failed to load auction title from header: “Emco Attenuator 17dB, 10 Watts, 50 Ohm, 1.5 Ghz. – (item 110148689234 end time Jul-22-07 11:34:41 PDT)”

Hope this helps in some ways,
Pierre.

 
Avatar Laurence Pas... 59 post(s)

See my post here: http://forum.jbidwatcher.com/forums/9/topics/1041?page=2

Specifically, if you have a CVS checkout you can fix JBW by changing the jbidwatcher.properties entries listed here:

http://sourceforge.net/tracker/index.php?func=detail&aid=1758418&group_id=3914&atid=103914

and rebuilding.

 
Avatar cregist 7 post(s)

Not quite it yet. After making the changes Laurence suggests, I still get Failed to load auction / Failed to parse auction errors.

It was working just fine until …

Thanks

 
Avatar pmx 5 post(s)

Hi Laurence,

sorry, changing jbidwatcher.properties doesn’t work for me (mod. applied against latest CVS version, connexion to ebay.fr).

Anyways, I understand the rationale behind this change. I will try to trace the code on my side (you know the open source paradigm: “thousands pairs of eyeballs browsing the same code …”) .

 
Avatar Laurence Pas... 59 post(s)

I’ve updated the regular expressions listed on sourceforge to remove all literal whitespace from them (see post dated: 2007-07-22 13:59). These should be safer from a copy-and-paste viewpoint. Note that they are one line strings and should not have any spaces in them, regardless of how they are displayed in your browser.

 
Avatar pmx 5 post(s)

Hi Laurence,

I finaly got it : there is a white space between “[0-9]+” and “end time” that is missing. It probably disapeared in the sourceforge post due to line truncation.

So, it works with the added space .

Thanks !

 
Avatar pmx 5 post(s)

Ooops !

didn’t see you last post…

At least, it forced me to brush up my “Java regular expression” knowlege !

Again, thanks for the fix !

 
Avatar Hans 12 post(s)

Hi all developers reading this thread,

to speed up development/error tracking and help in solving the current jbidwatcher-issues,
I was trying to use Eclipse to compile jbidwatcher.

But there were dozens of “The import com.stevesoft.pat.Regex cannot be resolved” thrown at me.
I changed the class-folder several times in the project-properties/Libraries tab, but still no luck.

Any help would be appreciated, but maybe it’s better to do it by mail to

yesitshans at gmail.com

as not to fill this thread with developer questions.

Thanks,

Hans
 
Avatar robecity 1 post

Hi
You might object to a none tech person muscling on your erudite forum but I started using jbidwatcher only recently and found it very useful. However no sooner using it when ebay update caused all the problems you’ve identified.
I’m now confused. Some forum entries imply it now works others that it doesn’t. I downloaded the update to my Mac, it seemed to work but quickly displayed the red eye.
Any clarification / advice welcome
Regards
Mal

 
Avatar huntz 6 post(s)

Thanks to Laurence for the good reg exp fix, I have tested with success the CVS build.

For the guys not used to build JBidwatcher from the CVS repository, I have posted here the .jar version (waiting the next Morgan fix…) :)

Feel free to test and report any problems…

Bye.

 
Avatar huntz 6 post(s)

@robecity:Yesterday, after some changes to the main code, we were close to have a working solution, but today ebay has made other changes, so the program is not working anymore (for now…).

 
Avatar Frank P. fro... 71 post(s)

… thanx huntz :-)
seems to work her and now (german ebay, 18:09 sunday evening)
no red eyes any more, dragging urls ok