jbid not go

Subscribe to jbid not go 4 post(s), 3 voice(s)

 
Avatar albasalo 1 post

when i launch jbid it start and close after some moment, what is my problem?

 
Avatar Laurence Pas... 59 post(s)

This happened to me once and it was due to a corrupted auctions.xml file. (To be fair, I was mucking about with the source code and I corrupted it!) You could try renaming it to auctions.xml.bak and see if that helps.

 
Avatar Laurence Pas... 59 post(s)

I couldn’t start JBidWatcher just now but for different reasons – it’s your lucky day!

I was setting up another account on Mac OS X and JBidWatcher is installed in /Applications which can be seen by everybody. However, after being extracted from the distributed tar.gz, JBidWatcher only has executable permissions for the person who installed it. Consequently other users cannot run it. There are two solutions:

1) reset the executable permissions so anyone can run it:

chmod o+x /Applications/JBidWatcher.app/Contents/MacOS/JavaApplicationStub

2) make a copy of it (/Users//Applications/JBidWatcher) and use that instead

(2) is the easiest if you’re not familiar with Unix file permissions.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,

There’s a lot of possible reasons JBidwatcher won’t start up. Main among them are corruption of the auctions.xml file, and platform-specific issues.

There are log files named errors.###.log where ### is the run number of JBidwatcher that logged that data. If you find the right one for when you had that problem (or look for the highest number, run it again, and there should be a new one), you can send me that log file. My email address should be in the About box, or you can use cyberfox at the gmail service.

The log files are found in /Users/{username}/.jbidwatcher on Mac OS X (Finder usually won’t show it, you have to get to it via Terminal), or in C:\Documents and Settings\{username}\.jbidwatcher on Windows. On Linux and other Unix-alikes, it’s at ~/.jbidwatcher.

That’s also where your auctions.xml file is, if you wanted to try renaming it as per Laurence Passmore’s suggestion.

Speaking of which, the permissions issue is a very good one to know! I’d never run into that, so I wouldn’t have thought of it.

I’ll dig into the ant task which creates the .tar.gz, and see if I can’t set the permissions to be a little more…permissive. :)

Thanks muchly!

— Morgan Schweers, Cyber*FOX*!