SOLVED: Sign in information incorrect

Subscribe to SOLVED: Sign in information incorrect 3 post(s), 2 voice(s)

Avatar georg 2 post(s)


wanted to try jbidwatcher and it doesn’t connect me to I tested this with Version 1.0.1 (WinXP) and the previous version on MacOSX 10.4, with no luck, same error. The logfile says
Tue Jun 12 14:32:54 CEST 2007: Your sign in information is not valid.
I know that I typed the correct login information, so I checked the file JBidWatch.cfg. The variable “ebay.password_b64=” shows the correct value for my password (according to php’s base64_decode) [btw.: is it possible to at least shift the encoded base64-pwd by n characters? this way, thanks to base64_decode, the pwd is stored almost plaintext on the harddisk]. Just the “ebay.user=” variable troubles me a little bit. My username contains a “-”. So when I enter “my-username”, it gets stored as “ebay.user=my/username”. So I tried to change that with an editor, but if I start jbidwatcher again, everything is reverted to the old value my/username.
Long story short: is there any way how I can tell jbidwatcher to accept my username or to get more debug-information to solve the problem by myself? I would so definitely want to use jbidwatcher…


Avatar Morgan Schweers Administrator 1,204 post(s)


I have no idea why it’d be doing that.

It really shouldn’t be changing the ‘-’ to a ‘/’. I use ‘test-jbidwatcher-bids’ as one of my accounts, and it doesn’t do that to it in the config file…

I hate to ask, but is there possibly some kind of character mismatch between ‘-’ and the dash character on a German keyboard (if it’s even custom at all)? Is it a special character, or an ‘ndash’ or ‘mdash’ perhaps…?

As I said, I use accounts with dashes in them for testing, so I know they fundamentally work… What you’re describing definitely would fail, but it shouldn’t be happening. :( I wish I had some idea how better to help…

— Morgan Schweers, Cyber*FOX*!

Avatar georg 2 post(s)


I finally found out why jBidwatcher rejected my username/password-combination. I hope posting this here helps others with the same problems.

So, after playing around with the config file for a while, I noticed, that my username was stored in the correct way (“my-username” instead of “my/username”). Don’t know why this happened when I first posted this, but at least this issue has gone magically. Still, jBidwatcher showed the “Not logged in…” sign. So if it isn’t the username, maybe it’s the password. In my case, my ebay-password contains the character “§” (the paragraph symbol). I’m not so familiar with base_64, but I thought I heard that it has problems with some special characters. So I changed this paragraph-character in my password with a “standard-ascii”-character (a-z, A-Z, 0-9) and – voila – now I can connect.

SOLUTION: If you have special characters in your passwords, try changing them with some “more-standard” ones. Although you might loose a little bit of security, it may work for you.