[PreRelease] JBidwatcher 2.5.3pre4

Subscribe to [PreRelease] JBidwatcher 2.5.3pre4 70 post(s), 40 voice(s)

1 3 Next →
 
Avatar LMarkoya 3 post(s)

OK…the damaged file was caused by a setting in preferences for files, but JBidwatcher is still not working at all…no bid is placed

 
Avatar zappram 269 post(s)

I personally have not upgraded to 10.9 so I can’t help you on solving the problem… but if you ever have back up of your older setup, perhaps your database file are still “healthy” in your backup volume that you might want to dig it out to use…. or start from fresh and it will read your ebay items from “My eBay”….

 
Avatar solaris_07 5 post(s)

The JBidwatcher 2.5.3pre4 will not work using the system OSX 10.9.
The TAB “Current” is not showing any auctions. (The database shows some “xml” files… but there is no visual display…)
But JBidwatcher 2.5.3pre3 seams to act fine.

 
Avatar zappram 269 post(s)

I stayed with JBidwatcher (2.5.3pre3-2-g03a9bc3) because I read about something not working in the pre4, and so far, it’s sniping and I win some if I set bid high (reasonably enough), and the glitches is that thumbs may not show, and dragging the entire search page from browser to dump in JBW does not work now, but overall, it works and I am using it everyday….

Since it’s quite stable for me, I did not spend time setup my other machine to run pre4 under 10.8 and now I have less incentive to setup 10.9 ……

 
Avatar Hans-Peter J... 1 post

Dear Morgan,

hope, you’re doing good.

While being a happy JBW camper some time ago, I tested both new versions: 2.5.3pre3 and pre4.

Unfortunately, both didn’t work for sniping (not tested other functions). While pre3 pastes auctions and displays them at least, and even found my 2 watched items, it is showing the auction in question as (FP), hence sniping is impossible. Pre4 neither paste auctions for me, nor will it add them by id.

In order to start from fresh ground, I moved my old .jbidwatcher directory away.

Here are the details:
System: openSUSE 12.2 with java-1_7_0-openjdk-1.7.0.6 (x86_64)

The eBay URL:
http://www.ebay.de/itm/AMD-Phenom-2-X4-965-BE-/111210789660?pt=DE_Elektronik_Computer_CPUs&hash=item19e4adfb1
(this is not a fixed price action, of course)

Tested with ebay.com and ebay.de. No change.

Update:
Just installed jre-7u45 and JBidwatcher 2.5.3pre3 in a windows w2k3 test environment: behavior persists (I had to reenter my account data a few times, since even if I pressed check and save, JBW complained about missing account information. Also JBW seems to have issues to save the state of “Prefer Non-US auction server”: I checked and saved it, but after a JBW restart, it’s unchecked again.

Hmm, would be great to get sniping going again.. Postal handling and icon stuff isn’t all that important, but JBW without sniping?!?

Cheers,
Pete

 
Avatar islisis 7 post(s)

For the last week I have been experiencing the same problem as the above poster, for all auctions including US.

Seems to be a more severe bug of past FP problems.

Seeing that I can’t seem to post a new topic in the development forum, I would like to know if anyone could maintain a compiled version of 2.5.5 from github. Thanks

 
Avatar ljmuk 2 post(s)

Apologies for using this forum but the ‘help’ forum has an error if you try to start a new topic.

I am having a strange problem with the latest version of jbidwatcher. I use alt/tab to move through the windows that are open on my laptop and have always used this shortcut. If I do it with jbidwatcher open, it immediately crashes and I have to re-boot to get it loaded again. Would appreciate any advice as have been using jbidwatcher for a couple of years and this has never happened before. I am using Windows 7. I have just upgraded from Windows XP, could this have something to do with it?

 
Avatar gizmatron 3 post(s)

well I’m running os 10.7.5 and since 2.5.5 pre3 stopped working I thought I’d try the pre4 but still no good.. on any auction that’s not actually on ebay.com the snipe,cancel snipe and bid buttons are greyed out so I can’t even enter a snipe. EDIT ok can’t right click and snipe but the snipe button itself works .. Duh.. never thought of that.. but still no thumbnails and EVERY auction not on ebay.com is marked (FP)

 
Avatar Morgan Schweers Administrator 1,200 post(s)

Greetings,
I’m working on a release which should help, and I’ll try to figure out what broke in the forum software. :(

— Morgan

 
Avatar Morgan Schweers Administrator 1,200 post(s)

Greetings,
So I fixed the forum, but I found an annoying bug in non-US auctions in JBidwatcher which is delaying the release. (It’s showing bid counts for auctions as ‘0’, no matter what they actually are.)

I know what’s wrong, but fixing it is taking a little bit.

— Morgan

 
Avatar Frank P. fro... 71 post(s)

EMAGIC AMT8 Unitor 8 MIDI-Interface 19 Zoll (181255653404)
Currently
â?¬61.88 (14 Bids)
High bidder
1***i
Your max bid
â?¬62.00
Shipping
â?¬5.00
Seller
charley2020
Listing ended at
Sun Nov 17 20:10:35 CET 2013
Last updated at
Sun Nov 17 20:15:38 CET 2013
You could have used Buy It Now for â?¬62.14 Listing has ended. Events
Sun Nov 17 19:16:18 CET 2013: Establishing a snipe for â?¬53.00
Sun Nov 17 19:17:46 CET 2013: Cancelling snipe.
Sun Nov 17 19:17:57 CET 2013: Establishing a snipe for â?¬62.00
Sun Nov 17 20:08:29 CET 2013: Preparing snipe.
Sun Nov 17 20:08:32 CET 2013: Loading bid request…
Sun Nov 17 20:08:33 CET 2013: Done loading bid request, got form…
Sun Nov 17 20:10:30 CET 2013: Submitting bid form.
Sun Nov 17 20:10:30 CET 2013: Firing actual snipe.
Sun Nov 17 20:10:31 CET 2013: Unknown error sniping on EMAGIC AMT8 Unitor 8 MIDI-Interface 19 Zoll (181255653404)
Sun Nov 17 20:10:31 CET 2013: Failed to load post-bid data. ‘Show Last Error’ from context menu to see the failure page from the post-bid page.
Sun Nov 17 20:10:31 CET 2013: Loading post-bid data.
Sun Nov 17 20:10:31 CET 2013: Done submitting bid form.

Error Log
Sun Nov 17 20:10:31 CET 2013: 181255653404 (EMAGIC AMT8 Unitor 8 MIDI-Interface 19 Zoll) – Done submitting bid form.
Sun Nov 17 20:10:31 CET 2013: 181255653404 (EMAGIC AMT8 Unitor 8 MIDI-Interface 19 Zoll) – Loading post-bid data.
Sun Nov 17 20:10:31 CET 2013: 181255653404 (EMAGIC AMT8 Unitor 8 MIDI-Interface 19 Zoll) – Failed to load post-bid data. ‘Show Last Error’ from context menu to see the failure page from the post-bid page.

Sun Nov 17 20:10:31 CET 2013: File contents logged with message: http://offer.ebay.co.uk/ws/eBayISAPI.dll?MfcISAPICommand=MakeBid&maxbid=62.00&quant=1&mode=1&stok=-304776350&uiid=1862134972&co_partnerid=2&user=HIDDEN&fb=2&item=181255653404&confirmbid=Confirm+bid

Sun Nov 17 20:10:31 CET 2013: 181255653404 (EMAGIC AMT8 Unitor 8 MIDI-Interface 19 Zoll) – Unknown error sniping on EMAGIC AMT8 Unitor 8 MIDI-Interface 19 Zoll (181255653404)

 
Avatar Stopper 1 post

well, the software stopped working on my auctions too. (FP) problem
and now i understand how bad i am feeling when i miss it.
were great for me and worked for like a charm.
Hope Morgan, the great developer will fix it for all of us.

 
Avatar ToKa 6 post(s)

Mine shows too all as (FP) since 8 days, 10.6.8 pre3.

But the older work around is still working:

Configuration manager -> General / Doubleclick settings -> action: initiate a snipe on a given action

In JBWatcher you can snipe by double clicking on the item.

 
Avatar niclaw 2 post(s)

Hello Morgan,

I hope you do check posts (even if you can’t respond to each individual posts).
One widespread problem that you will notice is no matter which version of JBidwatcher we are running on OS X 10.9 is that bids don’t fire!
After going through many settings, going through the forum and faq’s and losing 5 auctions (as a test, in all instances, snipes did not fire).

The problem seems to be Energy Saver settings!
In 10.8, snipes fired spot on with Energy Saver settings set to-> Computer Sleep:Never ; Display Sleep: 15 minutes ; Put hard disk to sleep when possible : unchecked (disable)

In 10.9, with these same settings, snipes do NOT work. The log entry consistent with every failure: The computer may have slept through the snipe time

Also, in 10.8, moving a mouse would “wake” the screen. In 10.9 moving a mouse does not wake the screen. Only pressing a key wakes the screen. Could this have anything to do with snipes not firing?

Now, I am talking about an iMac…not a laptop so the lid is not shut or anything. It is running with above settings. Just can’t figure out how to prevent computer from going to sleep (or why is it going to sleep in the first place!)

Is it not possible for JBidwatcher to “wake” the computer 40-50 seconds BEFORE executing the snipe? Once a computer is awake 40-50 seconds before snipe execution atleast snipe can’t fail because of sleep!

Any ideas? Suggestion? scripts?

 
Avatar zappram 269 post(s)

10.9 wake issues are talked about on many places including Apple Support forum.

I am trying to setup 10.9 and try, but as I posted many times before, my setup with an iMac @ 10.6.8 and pre3 works good for me and …

I keep iTunes playing all my music continuously (volume down to minimum or mute), and keep display to dim and eventually my screen will go blank, but music is going and somewhat trustworthy cable internet connection with a snipe time of 8 sec. works well so far for me.

No software package is perfect not mentioning eBay has hundreds of droids working on modifying the scripts and thousand of servers (hardware may act up?)…. but if it works, or you can make it work for you, then it’s a good solution.

I am still winning my share of bids assuming I want to bid high enough, but mostly I set a moderate price and if I win, I am always happy.

That’s my strategy…. I kept the 10.6.8 because of JBW and 2 other programs I must use and 1 of my favorite game, and I do have the luxury of other Mac OS machines, so it’s working for me this way for now……

But do read up about the wake issues on 10.9 which I think I will encounter when I setup 10.9, but who knows, 10.9.1 will be out soon as usual, the first version is somewhat buggy such as the wake was never encounter in Apple lab I suppose they just keep those test machine running all days….

Good luck.

 
Avatar BKi 8 post(s)

I see (FP) in every auction, although the price is not fixed (e.g. item 121220517850). It occurs for a long time now, so I couldn’t snipe using JBidwatcher since some months. JBidWatcher 2.5.3pre4 is running unter Linux (openSUSE 13.1, up-to-date, java 1.7.0_45). Configured country site is ebay.de
Is there a way to repair the auction data base manually, configure any setting, or do I have to wait for JBidwatcher to be fixed?

 
Avatar ToKa 6 post(s)

>>Is it not possible for JBidwatcher to “wake” the computer 40-50 seconds BEFORE executing the snipe? Once a computer is awake 40-50 seconds before snipe execution atleast snipe can’t fail because of sleep!

Any ideas? Suggestion? scripts?<<

I’am doing this by using EyeTV and programming some TV show for that time

 
Avatar zappram 269 post(s)

You might need more than 40-50 seconds if your Mac falls to a deep sleep…… takes time to wake and start spinning disc, attempt to connect to internet dealing with WiFi protocol etc….. so I would say 1.5-2 min. to be safe if you want to do any programming.

 
Avatar splodger 8 post(s)

Hi Morgan,

Hope you and yours are all fine!

JBW: I’m running 2.5.3pre3-2-g03a9bc3 on Win 8.0, (Ebay.co.uk Java 7.45) and it’s mostly fine.
OK, there are the problems with missing shipping details, and the thumbnails, but they can be worked around.

My main problem is that JBW seems to shut itself down at random times (anywhere from an hour up to a day or so) for no apparent reason.

There’s nothing unusual running on the laptop, no malware, no weird scheduled tasks.

Thought I’d mention it.

Cheers

Rog.

 
Avatar SubTegmineFagi 1 post

Hi,
JBW always shows (FP) and never let bid auctions, only buy!
I’m using ebay.it and pre3 and pre4

thanks

Sat Dec 21 14:00:22 CET 2013: PMQ Caught exception: java.lang.NullPointerException

Sat Dec 21 14:00:22 CET 2013: Parsing URL http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=221337451143
Sat Dec 21 14:00:22 CET 2013: Parsing URL http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=221337451143
Sat Dec 21 14:00:24 CET 2013: Parsing URL http://thumbs1.ebaystatic.com/d/l225/m/mXctActv-VerykGsJUzRIIw.jpg
Sat Dec 21 14:00:25 CET 2013: Parsing URL http://offer.ebay.co.uk/ws/eBayISAPI.dll?ViewBids&item=221337451143
Sat Dec 21 14:00:29 CET 2013: PMQ Caught exception: java.lang.NullPointerException

1 3 Next →