JBidwatcher Forums are in Read-Only mode for a server move

[PreRelease] JBidwatcher 2.1.6pre6

Subscribe to [PreRelease] JBidwatcher 2.1.6pre6 18 post(s), 10 voice(s)

 
Avatar Morgan Schweers Administrator 1,200 post(s)

Greetings,
This pre-release version is being put out there mainly to fix the ‘n/a’ time issues and eBay’s new ‘/itm/’ format URLs. The full list of changes is at the bottom of this message.

This is a pre-release, so I really need feedback on how it’s doing, if anything new breaks, etc…

You can download it here:

Mac OS X: http://www.jbidwatcher.com/download/JBidwatcher-2.1.6pre6.dmg

Windows (non-installer): http://www.jbidwatcher.com/download/JBidwatcher-2.1.6pre6.exe

Linux (jar file): http://www.jbidwatcher.com/download/JBidwatcher-2.1.6pre6.jar

Please let me know if you run into any problems with this version; I’m really hoping to get it released soon, but I need it vetted by you folks first!

— Morgan Schweers, CyberFOX!


Changelog:

User Visible

  • Remove Mature Audiences from the eBay configuration display. It’s my #1 support problem for user having trouble logging in. It’s still accessible from the Advanced Configuration setting, as ‘ebay.mature’ (without the quotes), and it’s described in the FAQ.
  • Fix a longstanding bug that you couldn’t really change username/password while running JBidwatcher; you had to shut it down and restart JBidwatcher. Now it takes effect immediately!
  • Fix another longstanding bug where on a bid, JBidwatcher would forget who the seller was, replacing them with the high bidder’s id, and thus items would fall out of the selling tab.
  • Some price detection improvements.
  • Don’t stomp on user-entered or previously-correctly detected shipping amounts.
  • Dragging an image from your browser onto an auction sets that auction’s thumbnail to that image.
  • When adding an auction that is already in your auction list, it now switches to the category it’s in, selects the auction referenced, and scrolls to it.
  • Show the actual version/build information on Windows and Linux.
  • Better end date detection (fixes the ‘n/a’ problem)
  • Recognize eBay’s new ‘/itm/’ URL format
  • Recognize seller-ended auctiosn.

Internals

  • Hopefully improve sleep-detection and handling.
  • Failing to load the tray.dll (as on Windows 7 64 bit) shouldn’t cause the program to fail to start up.
  • Lots of changes for debugging and testing.
  • Improved scripting interface.
  • Small improvements to thread safety.
  • Lots of refactorings and cleanups.
 
Avatar FredThompson 6 post(s)

It’s working great for me except the highlight color is very dark blue. There is not enough contrast with the black text. Please set a light tone for the selection highlight color.

 
Avatar zappram 269 post(s)

so far, so good, been winning sniping :D
Don’t have highlight color issue (OS X). Perhaps it’s your Windows preferences on settings?

 
Avatar Morgan Schweers Administrator 1,200 post(s)

Greetings,
@FredThompson – Try changing the highlight color yourself and see if that helps.

@zappram – Glad to know it’s working well for you!

— Morgan Schweers, CyberFOX!

 
Avatar MEC2 53 post(s)

Issues I’ve noticed -

- Auctions not updating
- Auctions not moving to completed

Sniping is working though, so it’s doing the one important thing still.

 
Avatar Liam 16 post(s)

Hi Morgan

I tried 2.1.6 today (2.1.6pre6-0-g5357648) on MacOS 10.7.1 with this java:
java -version
java version “1.6.0_26”
Java™ SE Runtime Environment (build 1.6.0_26-b03-383-11A511)
Java HotSpot™ 64-Bit Server VM (build 20.1-b02-383, mixed mode)

My saved searches weren’t working on 2.1.5 – I created them and they didn’t return any results. They are working in 2.1.6 however the results are showing up in both the Current tab and the tab I specified in the search templates.

Is that the correct behaviour? If it is I can’t see the point of specifying a specific tab – I do so to keep the current tab clearer.

Cheers, Liam

 
Avatar Liam 16 post(s)

Upon closer inspection – some get put in the right tab and some get put in Current, from the same search – but not duplicated as I first thought.

Let me know if you want me to send you anything to help you see it clearer than my words :-)

Cheers, Liam

 
Avatar Liam 16 post(s)

In addition, completed auctions aren’t moving to the completed tab automatically, I had to quit and re-start to get them to move.

Cheers, Liam

 
Avatar io 24 post(s)

Hi Morgan,

- Like said above, auctions update doesn’t seem to be done automatically.
- Very often the color doesn’t change. For instance, I become the highest bidder, but the description stays red.

I don’t know of the following is a problem or not, but it makes deleting a bunch of auctions very slow.
In the right part of the status bar, there’s the total of selected auctions and the total value of all these auctions.
Then if, for instance, I delete 70 auctions at $2 ($2 is chosen to simplify things) I will see 2 counters scrolling from 1 to 70 and from $2 to $140, then an auction is deleted, and counters start again from 1 to 69 and from $2 to $138, a second auction is deleted and again, 1 to 68 and $2 to $136, and so on.
I don’t remember seeing that in the previous version, but I may be wrong.

Thanks.

io

 
Avatar FredThompson 6 post(s)

I’ve found custom destination tabs for searches are being ignored sometimes. Some of the results go into the custom tab, some go into “current.” Win XP SP3 ro Win7 SP1. pure java version, not the Windows installer version. Java SE Runtime Environment 7.0.0.147. I’m also seeing the weird repeating counter display and long delete times when deleting large numbers of items.

 
Avatar Frank P. fro... 71 post(s)

non-paypal fixed price auctions show with “null(FP)” instead of price …
example http://www.ebay.de/itm/ws/eBayISAPI.dll?ViewItem&item=300607271287
JBidwatcher (2.1.6-0-geb75036) on MacOSX 10.4.11

 
Avatar FTL 3 post(s)

Same problem here with auctions not updating. Servers → Update auctions also doesn’t seem to be working; have to use the right-click update on individual entries.

Sniping working well, though!

Bill

 
Avatar art3048 4 post(s)

I have tried version 2.1.6-0-geb75036 and also 2.1.6pre6-0-g5357648 and have been unable to login to ebay. I get a popup from the taskbar indicating the login failed and anything requiring to be logged in would not be allowed. I am on XP Pro SP3. I have checked the configuration information and my ebay login info there is correct. Any suggestions appreciated.

 
Avatar zappram 269 post(s)

we are on JBW 2.2Pre2. Look around the forum, and find the link for the new version and try ? (sorry, I don’t have a direct link for you). Failed login maybe something else other than you are just running an older version of JBW. Do you login to eBay with just a browser okay?

 
Avatar art3048 4 post(s)

Did a search for 2.2pre on here, on sourceforge.net and a google search on the internet – all came up blank. Yes, I can login to ebay okay from IE or from Firefox. JBW works okay for monitoring and searches – just can’t use it for bidding. Thanks anyway.

 
Avatar Ivanovich 36 post(s)

latest version is here:

http://forum.jbidwatcher.com/forums/1/topics/2950

Ivan

 
Avatar art3048 4 post(s)

Tried that version (2.2pre2-0-g707d922) and have same problem. In the logs I see an error “RSA premaster secret error” followed by a lot of trace lines. Should I submit the Activity and Error logs?

 
Avatar art3048 4 post(s)

I just installed 2.5 and still had the same problem. I then completely uninstalled Java – there were 2 versions installed, and uninstalled JBidwatcher and then re-installed Java and JBidwatcher. All now appears to be working. I suspect something was missed up in Java that the uninstall/reinstall cleaned up.