1.0.1 Crashes and burns...

Subscribe to 1.0.1 Crashes and burns... 3 post(s), 2 voice(s)

Avatar chuck585a 4 post(s)


I just downloaded the new 1.0.1 jar file, and when I try to run it, it very slowly puts up a grey rectangle where the JBidWatcher logo is to go, and freezes. I am using Fedora Core 4 linux, and 1.0 worked just fine.

If I run the jar from a console, I get the following:

$ java -Xmx512m -jar JBidWatcher-1.0.1.jar
Exception in thread “main” java.lang.ExceptionInInitializerError
at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.6.0.0)
at FilterManager$AuctionListHolder.FilterManager$AuctionListHolder(FilterManager, java.lang.String) (Unknown Source)
at FilterManager.loadFilters() (Unknown Source)
at JBidWatch.JBidWatch(JSplashScreen) (Unknown Source)
at JBidWatch.main(java.lang.String[]) (Unknown Source)
at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)
Caused by: java.lang.IllegalArgumentException: classname: java.io.InputStream;
at java.awt.datatransfer.DataFlavor.getRepresentationClassFromMime(java.lang.String, java.lang.ClassLoader) (/usr/lib/libgcj.so.6.0.0)
at java.awt.datatransfer.DataFlavor.DataFlavor(java.lang.String, java.lang.String) (/usr/lib/libgcj.so.6.0.0)
at java.awt.datatransfer.DataFlavor.DataFlavor(java.lang.String) (/usr/lib/libgcj.so.6.0.0)
at JDropListener.getDataFlavor(java.awt.datatransfer.DataFlavor, java.lang.String) (Unknown Source)
at JDropListener.setupFlavors() (Unknown Source)
at JDropListener.JDropListener(JDropHandler) (Unknown Source)
at JBidMouse.JBidMouse() (Unknown Source)
at AuctionsUIModel.() (Unknown Source)
at java.lang.Class.initializeClass() (/usr/lib/libgcj.so.6.0.0)
…6 more



Avatar Morgan Schweers Administrator 1,204 post(s)

You’re running gcj, not Sun’s version of Java. JBidwatcher doesn’t work with that, and never has. It’s not a complete implementation of Java. I address it in two separate FAQs:

The key thing is to refer to the Java launcher by path, because otherwise it’ll default to the wrong version of Java. There’s supposedly some way to set the default version of Java, but I don’t know what it is offhand. Google may help here. :)

I hope that helps…

— Morgan Schweers, CyberFOX!

Avatar chuck585a 4 post(s)

Hi Morgan,

OOPS! I just noticed that when I upgraded to 1.0.1, I accidentally blew away
the path to jdk1.5.

Thanks, and sorry for the false alarm.