Syncs up time but nothing else

Subscribe to Syncs up time but nothing else 3 post(s), 2 voice(s)

 
Avatar (SF) Kurt Se... 2 post(s)

Tried with XP Java 1.3.1
also redhat 8.0 java 1.3.1 and 1.4.1
recompiled with cvs source, gets the same error.
I believe is may have something to do with my 2way direcway satellite isp. Could it be timing out because of the delay from the satellite?
I used the same .jar at the office on radhat 9.0 and it works fine.

Here is the error I receive:
Wed May 14 19:20:55 CDT 2003: Error loading page: http://signin.ebay.com/aw-cgi/eBayISAPI.dll
java.net.SocketException: Unexpected end of file from server
at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:802)
at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:828)
at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:702)
at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:800)
at sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:828)
at sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:702)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:583)
at sun.net.www.protocol.http.HttpURLConnection.getHeaderFieldKey(HttpURLConnection.java:1208)
at CookieJar.getAllCookiesFromPage(CookieJar.java:93)
at CookieJar.getAllCookiesAndPage(CookieJar.java:18)
at ebayServer.getSignInCookie(ebayServer.java:728)
at ebayServer.getNecessaryCookie(ebayServer.java:675)
at AuctionServer.getAuction(AuctionServer.java:446)
at AuctionServer.loadAuction(AuctionServer.java:502)
at AuctionServer.loadAuction(AuctionServer.java:537)
at AuctionServer.addAuction(AuctionServer.java:434)
at AuctionServer.addAuction(AuctionServer.java:195)
at AuctionEntry.prepareAuctionEntry(AuctionEntry.java:280)
at AuctionEntry.(AuctionEntry.java:196)
at JBidMouse.messageAction(JBidMouse.java:76)
at PlainMessageQueue.run(PlainMessageQueue.java:26)
at java.lang.Thread.run(Thread.java:536)
Wed May 14 19:20:55 CDT 2003: Error loading the eBay sign-in page!
Wed May 14 19:20:57 CDT 2003: Failed to parse auction! Bad return result from auction server.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Hmmm… It really seems like it is a link problem, as it’s happening in the Sun library.

If I were to guess, I’d say it’s taking too long to load the login page, the timeout happens before it gets the headers, and it confuses Java’s networking library.

One really unfortunate thing is that if there’s that high a latency, tight sniping might be a little risky. You should make sure your snipe time is set around 20 seconds or more.

It should work in general, despite the lag, but you’ll occasionally get errors like that in the log, and in the worst case you might miss some snipes because of excessive latency.

I’ll look into ways to tell Java to wait longer to get the page, but I’m not sure it’s doable yet. If I find anything, I’ll mention it in this thread.

— Morgan Schweers, CyberFOX!

 
Avatar (SF) Kurt Se... 2 post(s)

I did a little more digging and found that when I put jbidwatcher on the pc that the satellite is connected to, it works fine. It’s the other two pc’s that go through XP’s “internet connection sharing” that still will not work.