Multiple copies of JBW causes error (warning?

Subscribe to Multiple copies of JBW causes error (warning? 3 post(s), 2 voice(s)

Avatar (SF) ptone 4 post(s)

I get the following error when launching a second instance of JBW from the command line using a command like:

java -jar JBidWatcher-1.0.jar /pathTo.cfg

2007-02-21 21:41:35.927 java2644 CFLog (0): CFMessagePort: bootstrap_register(): failed 1103 (0×44f), port = 0×10603, name = ‘java.ServiceProvider’
See /usr/include/servers/bootstrap_defs.h for the error codes.
2007-02-21 21:41:35.930 java2644 CFLog (99): CFMessagePortCreateLocal(): failed to name Mach port (java.ServiceProvider)

This seems to be related to Mac OS X’s java JRE? CF is s prefix for core foundation I think.

However, so far, it does seem to work…


Avatar (SF) ptone 4 post(s)

Some googling turned up this quote related to the same error (different java app)

“The message is a system diagnostic telling you that more than one process tried to register Services (i.e. the “Services” submenu of your Application menu) with the process name “java”.

It should be harmless; "

Avatar Morgan Schweers Administrator 1,204 post(s)

Heh! Shows how well I know the Mac, unfortunately. I expected it was because it was trying to open up a web server port that another process already had open.

I didn’t realize that Java was a service… I’ve never tried running two copies simultaneously on Mac OS X, except via user switching.

— Morgan Schweers, CyberFOX!