Emergeny fix needed for random ebay times?

Subscribe to Emergeny fix needed for random ebay times? 7 post(s), 2 voice(s)

 
Avatar bushytails 55 post(s)

I don’t know if ebay is having time sync issues of their own, or if it’s a way of trying to detect and penalize snipe programs, but the incidences of wrong time syncs are increasing. I figured it was just me, but then someone in another thread posted the exact same issue and times.

I’ve confirmed ebay’s time page, http://viv.ebay.com/ws/eBayISAPI.dll?EbayTime, is returning incorrect times. Reloading the page repeatedly in a browser sometimes gives the bogus times that jbidwatcher is getting. The page is loading quickly; it’s not a network delay anywhere.

The current offset seems to be a minute behind.

jbidwatcher might need code to ignore time syncs more than some number of seconds different from the previous time sync, get the time from other sources (like the time remaining returned when updating soon-ending auctions), or something… because the bogus syncs are guaranteed failed snipes.

As a workaround, I’ve disabled time syncing… hopefully it doesn’t cause other issues…

—Bushytails
EDIT: The title should, of course, be Emergency… but I can’t seem to edit it.

 
Avatar bushytails 55 post(s)

BUG! Disabling time sync only disables it for the time shown in the UI. It still gets a time from ebay and offsets the time remaining by it.

 
Avatar bushytails 55 post(s)

I have unchecked the “Time Synchronization” box and restarted jbidwatcher. I’ve checked the advanced tab and timesync.enabled is false. But it’s still syncing time, and still missing snipes due to ebay returning bogus times. How do I disable time sync? Time sync is currently badly badly broken.

 
Avatar bushytails 55 post(s)

Everything failed today due to the time sync issue. Another person started another thread with the same issue. This needs a fix ASAP, even if it’s just making the option to disable time sync actually disable time sync…

—Bushytails

 
Avatar troytempest 4 post(s)

I sniped an auction today, 05/04/16 without any problems, precisely on time.

Note – 2.99pre5, ebay.co.uk, login “green dot”

 
Avatar bushytails 55 post(s)

Every snipe I’ve done the last two days has failed. It now seems I’m getting the bogus server times every time now.

errors.110.log:Tue Apr 05 14:17:48 PDT 2016: Time delta with ebay.com is -29177
errors.110.log:Tue Apr 05 16:51:50 PDT 2016: Time delta with ebay.com is -29887
errors.110.log:Tue Apr 05 16:56:58 PDT 2016: Time delta with ebay.com is -29807
errors.111.log:Wed Apr 06 10:01:21 PDT 2016: Time delta with ebay.com is -31016

I just set my snipe time to 45 seconds before the end of the auction to compensate, but if I get a non-bogus time, I’ll be bidding too early.

The option to disable time sync needs to work…

 
Avatar bushytails 55 post(s)

I just added viv.ebay.com as 127.0.0.1 in my hosts, so now time sync fails, instead of getting a bogus time. Hopefully no more snipes lost due to this. I rather wanted the one that ended this morning!