2.99.pre4 dies early on 10.6

Subscribe to 2.99.pre4 dies early on 10.6 6 post(s), 2 voice(s)

 
Avatar Hauke Fath 14 post(s)

See title; here is what the crash reporter window has, if that is of any help:

[…crash log elided…]

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
I’m very sorry, but JBidwatcher 2.99pre4 and later requires OS X 10.8 or later.

Unfortunately OS X 10.6 can’t run the recent Java runtime which is included in JBidwatcher with this version.

I wish you the best of luck with your auctions, and if you definitely cannot upgrade, I would suggest Gixen as an alternative sniping service. I have no relationship to them other than a respect for the developer.

— Morgan

 
Avatar Hauke Fath 14 post(s)

Hm, pity, that.

It would be nice, though, if 3.0 had a friendlier, less crashdumpy reaction to inadequate OS versions.

hauke

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
I agree completely; unfortunately I’m using Oracle’s app launcher internally, and apparently that’s all their code does in that circumstance. :(

It’s something else for me to look into fixing before I release 3.0; it’ll take modifying their code, but thankfully it’s open source so I can do that.

— Morgan

 
Avatar Hauke Fath 14 post(s)

Another issue is that the update function will happily overwrite v2.5.6 with code that then crashes in flames. I guess it would be too much of an effort to ship a 2.5.7 which checks requirements before updating automatically; but maybe you could make 2.5.6 available for download permanently?

Out of curiosity: What is it that keeps v3 from working with the Snow Leopard Java 1.7?

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
I’ve checked in a version that should behave better in the face of older OS X versions, and I hope to ship it this evening.

Actually 2.5.6 is still on the download servers. (In fact every version since 2.5.2 in late 2012 is still available.) I just don’t give explicit links, but if you copy the download URL and tweak it to 2.5.6 you can download the older versions. I actually do that, when I’m testing upgrading.

The problem with making 2.5.6 available ‘permanently’ is that it will eventually become out of date. eBay will make changes that break 2.5.6 and it won’t receive updates. This is mainly because it’s a real pain to change the parsing on 2.5.6.

Snow Leopard only allows Java 1.6, and forcing a later version of Java onto the platform is sketchy at best.

Unfortunately between Apple and Oracle, when the transition of ownership of Mac Java happened, a lot of things broke, and it required an entirely new way of handling Java applications. I’ve been skating on it for a while, using the old method, but more and more folks were upset that it was requiring an install of a version of Java that was originally released 10 years ago.

The only good solution was to embed the Java version inside of JBidwatcher, because otherwise the installation process is nuts, and a support nightmare. That took me a REALLY long time to get right. The main problem was Gatekeeper, and figuring out how to sign everything so that Gatekeeper wouldn’t throw a fit once it was downloaded.

Last, and DEFINITELY not least, there’s a security issue. The PCI standard (a security standard for companies that deal with credit cards) requires the expiration of older versions of SSL/TLS, and that sites using them stop allowing fallback to them by mid-2016. Unfortunately the first version of Java that supports TLS 1.2 out of the box (the current required standard) is Java 1.8. You can do it with 1.7, but every user would have to manually do a configuration operation, and that’s just a non-starter for thousands of users.

So, in theory, JBidwatcher 2.5.6 will stop working in mid-2016 anyway, as eBay transitions to TLS 1.2, which is definitely not supported under Java 6.

It all pointed to Java 1.8 being the right version to embed, and to embedding being the right choice. I knew that it would mean some folks couldn’t run it, and that sucks, but 10.6 is five and a half years old. I know it’s the last version that ran 32 bit, and that means it’s as far as some folks can go, but security issues put it over the top for me.

I will put a visible warning in the Changelog to not update if you are running a pre-10.8 version of OS X, which should help, in addition to making the newer version alert if it’s running on a pre-10.8 version instead of crash-dumping.

I’m very sorry,

— Morgan

[Edit: I’ve made a change to the Changelog, so auto-update users should see the warning front-and-center now.]