Finally got 2.5.5-0-g9fecd73 to work on MAC

Subscribe to Finally got 2.5.5-0-g9fecd73 to work on MAC 5 post(s), 4 voice(s)

 
Avatar americantoys 2 post(s)

I’ve been having all the same problems that have been mentioned with this latest build (high cpu usage, multiple listings for same auction, etc.). To begin….Although I read a reference to “app nap” by zappram? I had no idea what it was. Forgive me if you know all this, but I didn’t. Now I do. MAC’s new OS, Mavericks has a new feature to conserve cpu usage and power when an application is running in the background (such as Jbidwatcher). It automatically powers down the app if it’s not running in the foreground regardless of how you’ve set your “sleep” times in System Preferences. I did two things and now it runs beautifully. All the duplicates, triplicates, and more are gone, and cpu usage has decreased from 50% to 4.6% (this will however increase during a snipe, but it’s never gone above 20%).

1) Turn off Jbidwatcher’s app nap. To do this click on your monitor’s background, click “Go”, click “Applications”, select but don’t launch jbidwatcher by clicking once only on jbidwatcher’s icon (I prefer using icons). Now the icon’s text should be highlighted. Once you’ve done that press the command key (the thing with the four squiggles in the corners) plus the letter “i” (as in iris). This brings up jbidwatcher’s info panel. About 1/4 of the way down you’ll see “Prevent App Nap”. Click on the box to check it which turns it off. Make sure it’s checked. Close the window, close the program, and relaunch.

2) Click on System Preferences, then click on Energy Saver. Set both Computer Sleep and Display sleep all the way to the right to “Never”. Make sure the “Put hard disks to sleep…” is unchecked. Now I know this prevents screen burn, excessive usage etc. but this is what worked for me. Don’t worry…there’s a way to manually put it to sleep whenever you want to. Simultaneously click and hold down the “control”, “shift” and believe it or not the “Eject Disk” buttons (hold down all 3 at one time). The Eject Disk is in the upper right corner on the keyboard. This will manually force the display to sleep whenever you want. To “unsleep” click the “space bar” key. (Any key will work, but this way you won’t click and activate something by mistake). So even though I’ve set it to “Never” I can manually still make it sleep whenever I want.

I’m not a techie guy so my terminology may not be exactly correct, but I do know one thing. Once I did both these things all of the Jbidwatcher problems went away for me. I haven’t lost a snipe, there’s no duplication of auctions, and I was even able to get the shipping column to work again. You may get other results, but this is what I did and it worked for me. I have no idea what the corresponding actions would be for a Windows system. Sorry for the long post and basic clicking commands, but I wanted to be specific for all those other non-techies out there. DannyK

 
Avatar zappram 290 post(s)

Thanks – I got what you meant, and it I finally had time to run my sniping test under JBW2.5.5 and it WORKS.

I setup NEW install of JBW under OS X Maverick 10.9.1 and all thumb images showed up, and it seem to be quite nice, but I didn’t run any test on sniping. Then I finally got time to setup to a snipe, but it did not snipe :-(

Then I realized that although the settings for app.nap is set to OFF, but my MacBook Pro 17" core i7 had all others taking naps, so the laptop actually shut down most all and did not have internet connection, so JBW error log shows JBW cannot make any contact to any listings (no internet connection, airport was probably taking a nap).

So, for sniping test, I setup the HDD not to sleep, and Computer not to sleep, (but set the screen goes to sleep after 15 minutes), and left the machine and later I woke up the next morning, I have email notification that I WON the item …. paid for the winning purchase, and are happy about it.

Don’t know how others are doing with their windows and unix/linux, and others probably have more issues if they are not using USA ebay servers. I think they are all running a bit different than the ebay.com servers….

I think JBW will run well (until eBay monkey “I mean, rookie” programmers change their pms schedule again)….. so far, so far…. you know… it snipes and I won…

As I mentioned before, I have my iMac running 10.6.8 for the reasons of 5 other apps I need and it’s running JBW2.5.3pre3 and it’s doing well (well, I only see some of the thumbs, but that’s okay), it will snipe and win most items I wish….. so I will probably keep doing that till 2.5.3 breaks. But I will run more testing later on the laptop also, and have both machines sniping from different versions of JBW (at the same time) … see if that will freak out ebay some…. Okay, more snipe test results later when I get around to it….

 
Avatar ToKa 9 post(s) JBidwatcher (2.5.3pre3-2-g03a9bc3 i’am using too on 10.6.8.

Now no more FP auction – seems ebay changed their format again.

 
Avatar zappram 290 post(s)

hmmmm My setup here still works well… just sniped 3 days ago and won with perfect prediction, and perfect sniping…. winning the item by a hair ($I think my max bid is only $0.12 higher than the others, so my sniping price is the winning price a few seconds before the end of the auction).

Anyhow, my FP items are still in my JBW…. when I added new FP items, it also shows up (now even with thumb pic). I search and locate the item on my browser, and drag and drop in JBW. That’s all… same as before.

What FP does not work for you? any sample listings? The one I tested working is item# 331020969030

Did you updated all your Java and Flash lately?

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Just a note, I think I’ve got a fix for the App Nap problem. That threw me for a loop, pretty badly.

Anyway, I’ve committed a fix, and I’m not seeing napping currently, where I was before. Hopefully I can push it up in the next week or so.

— Morgan