sniping not working

Subscribe to sniping not working 11 post(s), 8 voice(s)

 
Avatar McBarry 1 post

I’m in Australia, running version 2.5.3pre3-2-g03a9bc3.
The last month or so I’ve been unable to snipe via right-clicking on the item..

The snipe item in the drop-down menu seems to work..

Any ideas??
Cheers,Dave B

 
Avatar Frank P. fro... 71 post(s)

same version here, seems to work doesn’t really mean it works unfortunately, I had to face two lost auctions yesterday, on one the connection to ebay was cut for no visible reason (connection in the browser worked), on the other sniping just didn’t fire … today I can’t even add some auction (“No entries matched” message no matter if added by drag and drop or using the plus sign and copy/pasting the auction number). JBW is not usable any more again … btw all auction appear as fixed price :(

 
Avatar Habitant 2 post(s)

Hmmm. I’ve been having problems, too. Are you, by any chance, running OSX 10.9, aka Mavericks?

 
Avatar Frank P. fro... 71 post(s)

…no, it’s still Snow Leopard here. And whenever we had to face problems like this with JBW before it wasn’t OS-related anyway … if you ever have a look at ebay page sources you will admire Morgan’s work even more, I wouldn’t like to run through that buggy jungle of code …

 
Avatar zappram 290 post(s)

I kept my OS X 10.6.8, now still running JBidwatcher (2.5.3pre3-2-g03a9bc3)

Sniping is working well (but I am in the USA)
Adding items are working well
only some items the thumbs are not showing up, but that’s fine.

I win all those I can if I snipe at a high enough bid price. I am still happy.
I keep the machine running 24/7
even set iTunes to play music (sometimes with volume muted) all the time to make sure the machine will not go to sleep mode.

I am keeping this setup to use with JBW, one of my favorite game, and my old scanner that no longer has driver support when going to higher level OS X. My other machines are going to 10.8 and I have not yet have any incentive to go to Maverick other than trying to figure out more on what software I have are not going to be working….. (sigh). I just don’t have much time to deal with that yet.

Just to let you know what I have and how they still work well.

 
Avatar Habitant 2 post(s)

I totally agree, a great program(me), as long as you remember not to let the machine sleep and so on. However, it seems not to fire properly since I went to 10.9. I need to do a definitive test to see if that’s correct, or just system glitches. It used to work perfectly on 10.8….

 
Avatar konocti 1 post

Sniping has not been working for me either (on OS X 10.9). It’s fine when I’m sitting right here working on the computer, but even if I tell the machine to NOT sleep (sleep is turned off, hard disk won’t spin down, etc.) none of my snipes go while I’m away from home.

So I’ve lost all the items I’ve had set up for bids over the past few weeks, save the ones that have fired while I was here working on the computer.

Any ideas?

Dave

 
Avatar albeant 2 post(s)

Has anyone tried disabling “app nap” in the app’s “Info” panel in 10.9? I’ve checked “Prevent App Nap,” but haven’t tried sniping on an auction yet.

 
Avatar LinuxDan 4 post(s)

I will let you know in about 8 hours !

 
Avatar LinuxDan 4 post(s)

‘Prevent App Nap’ appears to have worked, but there are errors in the logs:

Sun Jan 12 21:31:03 EST 2014: eBay says my max bid is a different type of currency than I have stored!
at com.jbidwatcher.util.Currency.less(Currency.java:629)
at com.jbidwatcher.auction.server.ebay.ebayAuction.
setMaxBidFromServer(ebayAuction.java:806)
at com.jbidwatcher.auction.server.ebay.ebayAuction.
parseAuction(ebayAuction.java:493)
at com.jbidwatcher.auction.server.AuctionServer.doParse(AuctionServer.java:274)
at com.jbidwatcher.auction.server.AuctionServer.loadAuction(AuctionServer.java:218)
at com.jbidwatcher.auction.server.AuctionServer.reload(AuctionServer.java:187)
at com.jbidwatcher.auction.AuctionEntry.update(AuctionEntry.java:901)
at com.jbidwatcher.ui.JBWDropHandler.messageAction(JBWDropHandler.java:31)
at com.jbidwatcher.util.queue.PlainMessageQueue.run(PlainMessageQueue.java:56)
at java.lang.Thread.run(Thread.java:695)

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
That’s because currency parsing is having issues for non-US listings. The code for the fix is in the tree, but I haven’t done a release in a while. I think I just this weekend fixed a last big breakage for non-US shipping prices, as part of the whole currency issues, so hopefully it’ll be stable enough to release this next weekend.

— Morgan Schweers, CyberFOX!