Cannot add auction...either invalid or communication error

Subscribe to Cannot add auction...either invalid or communication error 42 post(s), 28 voice(s)

← Previous 1
 
Avatar hayfever 1 post

Having a problem adding an auction to JBidwatcher, not sure if it’s a problem with my installed copy or reflects a change on eBay’s site. Auction 330774024502 is an eBay Motors auction ending in a little over a day. When I try to add it to my JBidwatcher I get the error message “Cannot add auction 330774024502, either invalid or communication error talking to server.” Likewise, when I added the auction to My eBay and ran the search JBidwatcher detects that there is an auction in My eBay that is not in my list and claims it added it to my list, but the auction never shows up in JBidwatcher. Given the discussion in the other thread about (FP) problems figured I’d better post this up in case there was a page layout change at work. Let me know if you need screenshots or a copy of my config file to try and replicate the problem.

 
Avatar zappram 277 post(s)

well, I can’t add that particular one either.

I am Mac OS X using JBidwatcher (2.5-0-g8f10beb)

ebay is chaing every minuites, quite annoying

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Should be fixed as of JBidwatcher 2.5.2.

— Morgan Schweers, CyberFOX!

 
Avatar monette999 4 post(s)

Sorry Morgan to say but ther problem is still present. I have had it many times with Win 7.

Any proposal how to fix it?

BR
Bob

 
Avatar monette999 4 post(s)

Here my error log file

I am using Ebay.de

Thu Aug 30 21:02:43 CEST 2012: JBidwatcher 2.5.2-0-g8e3723d
Thu Aug 30 21:02:43 CEST 2012: Sun Microsystems Inc. Java, version 1.6.0_30 on Windows 7
Thu Aug 30 21:02:43 CEST 2012: Logging to C:\Users\Bob\.jbidwatcher\errors.3.log
Thu Aug 30 21:02:49 CEST 2012: Loading listings from the database (9/11/11 entries, 11/11 auctions)
Thu Aug 30 21:02:49 CEST 2012: Done with the initial load (got 9 active entries)
Thu Aug 30 21:02:54 CEST 2012: Scripting is enabled.
Thu Aug 30 21:02:54 CEST 2012: About to try to instantiate the jdic tray
Thu Aug 30 21:02:54 CEST 2012: Done trying to instantiate the jdic tray
Thu Aug 30 21:02:57 CEST 2012: Time delta with ebay.com is -17622
Thu Aug 30 21:02:58 CEST 2012: Time delta with ebay.co.uk is -18153
Thu Aug 30 21:03:22 CEST 2012: PMQ Caught exception: java.lang.IllegalMonitorStateException
java.lang.IllegalMonitorStateException
at java.util.concurrent.locks.ReentrantLock$Sync.tryRelease(Unknown Source)
at java.util.concurrent.locks.AbstractQueuedSynchronizer.release(Unknown Source)
at java.util.concurrent.locks.ReentrantLock.unlock(Unknown Source)
at com.jbidwatcher.auction.EntryCorralTemplate.erase(EntryCorral.java:104)
at com.jbidwatcher.auction.EntryCorralTemplate.clear(EntryCorral.java:115)
at com.jbidwatcher.ui.commands.UserActions.DoUpdateAll(UserActions.java:1034)
at com.jbidwatcher.ui.commands.UserActions.DoAction(UserActions.java:1462)
at com.jbidwatcher.ui.commands.UserActions.DoAction(UserActions.java:1426)
at com.jbidwatcher.ui.commands.UserActions.messageAction(UserActions.java:92)
at com.jbidwatcher.util.queue.PlainMessageQueue.run(PlainMessageQueue.java:56)
at java.lang.Thread.run(Unknown Source)
Thu Aug 30 21:03:25 CEST 2012: Error from columns: (3,category_id, INTEGER, 2)
Thu Aug 30 21:03:25 CEST 2012: Failing to insert “2012-08-30 21:03:25” into column 4 of table entries
Thu Aug 30 21:03:25 CEST 2012: Error from columns: (5,updated_at, TIMESTAMP, 2012-08-30 21:03:25)
Thu Aug 30 21:03:30 CEST 2012: Time delta with ebay.com is -17504
Thu Aug 30 21:03:31 CEST 2012: Time delta with ebay.co.uk is -18221
Thu Aug 30 21:03:38 CEST 2012: Setting auction #251069399217 to be a ‘Far Future’ listing, as it has no date info.
Thu Aug 30 21:03:41 CEST 2012: Setting auction #120916932463 to be a ‘Far Future’ listing, as it has no date info.
Thu Aug 30 21:03:44 CEST 2012: Setting auction #390448203264 to be a ‘Far Future’ listing, as it has no date info.
Thu Aug 30 21:03:46 CEST 2012: Setting auction #250965857751 to be a ‘Far Future’ listing, as it has no date info.
Thu Aug 30 21:04:17 CEST 2012: Time delta with ebay.com is -18700
Thu Aug 30 21:04:18 CEST 2012: Time delta with ebay.co.uk is -18199
Thu Aug 30 21:04:41 CEST 2012: Setting auction #251069399217 to be a ‘Far Future’ listing, as it has no date info.
Thu Aug 30 21:04:43 CEST 2012: Setting auction #120916932463 to be a ‘Far Future’ listing, as it has no date info.
Thu Aug 30 21:04:46 CEST 2012: Setting auction #390448203264 to be a ‘Far Future’ listing, as it has no date info.
Thu Aug 30 21:04:48 CEST 2012: Setting auction #250965857751 to be a ‘Far Future’ listing, as it has no date info.
Thu Aug 30 21:07:19 CEST 2012: Shutting down JBidwatcher.

 
Avatar mhawk 1 post

Since 2.5.2 I have the same problem here.

Here is my log while trying to add a new auction:
Sat Sep 15 09:59:12 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=280965749852
Sat Sep 15 09:59:12 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=280965749852
Sat Sep 15 09:59:13 CEST 2012: Redirecting from: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=280965749852
Sat Sep 15 09:59:13 CEST 2012: Redirecting to: http://www.ebay.com/itm/Error?item=280965749852
Sat Sep 15 09:59:13 CEST 2012: Parsing URL http://www.ebay.com/itm/Error?item=280965749852
Sat Sep 15 09:59:14 CEST 2012: Item not found: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=280965749852
Sat Sep 15 09:59:14 CEST 2012: Failed to parse auction! Bad return result from auction server.

TIA, mhawk.

 
Avatar wiesel 7 post(s)

Same for me. Using Ubuntu neither ebay.de nor ebay.com or ebay.uk is working. Had this from time to time the last days but it still worked after shutting jbidatcher down and starting it again. Now it’s absolutely impossible to add an auction. As well if I try to get my ebay items – does not work.

 
Avatar hirsch 5 post(s)

Same for me. Can’t add any auctions by search or even manually any more… so i can’t use Jbidwatcher any longer? would like to…
Preferences is adjusted to ebay.de

Sun Sep 16 08:55:21 CEST 2012: Parsing URL https://signin.ebay.com/ws/eBayISAPI.dll?co_partnerId=2&siteid=0&UsingSSL=1
Sun Sep 16 08:55:22 CEST 2012: Done getting the sign in cookie for ebay.com
Sun Sep 16 08:56:07 CEST 2012: Parsing URL https://my.jbidwatcher.com/services/account?browse_to=1
Sun Sep 16 08:56:08 CEST 2012: Failed to get https://my.jbidwatcher.com/services/account?browse_to=1: I’m sorry Dave, I’m afraid I can’t do that.
Sun Sep 16 08:56:08 CEST 2012: Saving to: /Users/sfichtel/Library/Preferences/JBidwatcher/JBidWatch.cfg
Sun Sep 16 08:56:12 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=110949973393
Sun Sep 16 08:56:12 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=110949973393
Sun Sep 16 08:56:12 CEST 2012: Redirecting from: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=110949973393
Sun Sep 16 08:56:12 CEST 2012: Redirecting to: http://www.ebay.com/itm/Error?item=110949973393
Sun Sep 16 08:56:12 CEST 2012: Parsing URL http://www.ebay.com/itm/Error?item=110949973393
Sun Sep 16 08:56:13 CEST 2012: Item not found: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=110949973393
Sun Sep 16 08:56:13 CEST 2012: Failed to parse auction! Bad return result from auction server.

Sun Sep 16 09:07:01 CEST 2012: Parsing URL http://www.ebay.com/itm/271054664838?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1438.l2648
Sun Sep 16 09:07:01 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=271054664838
Sun Sep 16 09:07:01 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=271054664838
Sun Sep 16 09:07:01 CEST 2012: Redirecting from: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=271054664838
Sun Sep 16 09:07:01 CEST 2012: Redirecting to: http://www.ebay.com/itm/Error?item=271054664838
Sun Sep 16 09:07:01 CEST 2012: Parsing URL http://www.ebay.com/itm/Error?item=271054664838
Sun Sep 16 09:07:02 CEST 2012: Item not found: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=271054664838
Sun Sep 16 09:07:02 CEST 2012: Failed to parse auction! Bad return result from auction server.
Sun Sep 16 09:07:02 CEST 2012: Not loaded (271054664838).

 
Avatar eZ 8 post(s)

I also can’t add any auctions since about Sept. 16th. Same error message. Account registered at ebay.de. In the JBitWatcher config it doesn’t make a difference what the browse target is.

The “mostly FP” issue is at least not a show-stopper, but this is. So there will be at the weekend some retro sniping.

 
Avatar Dominik Schmid 14 post(s)

Same here. Problems adding items located in Germany manually and through “Get my eBay items”.
Version 2.5.2-0-g8e3723d on OS X 10.6.8

 
Avatar Frank P. fro... 71 post(s)

…yes, Dominik, same configuration here, the items that produce the problems seem to be just the same that cause a communication break down when added via drag and drop or the “add auction” menu function.

 
Avatar Eric 22 post(s)

Same from me

Eric
Germany

 
Avatar Yfirstrumpur 1 post

Same for me in Germany
Try different Logins ebay.com, ebay. de, ebay.co.uk all pass test-login well.
When I update an action the status on right top changes from crossed out to well (even it has the FP-Problem here),
But Add an action end in a crossed out status.

After a while it comes out, that I can add one auction, the second failed again for x-times.

Testing: Today I was succesfull for adding 2 auctions before getting everything crossed out.
I checked the logs: No message!
Item
251152032202

Using
JBidwatcher (2.5.2-0-g8e3723d)
on
Linux Suse linux-n4ge 2.6.37.1-1.2-desktop
with java
java version “1.6.0_20”

 
Avatar rr 6 post(s)

ebay.de has changed it’s view host. Change the following line in the ebay_com.properties file (it’s in JBidwatcher-2.5.2.jar/main/main.jar/ )
ebayServer.viewHost=cgi.ebay.com -> ebayServer.viewHost=cgi.ebay.de and anything works well again.

@Morgan: It would be glad if you could fix this with the next release.

 
Avatar hirsch 5 post(s)

Hi rr,

thanxs a lot for discovering the problem, but i actually do not know how and where to adjust it…. where do i find the ebay_com.properties in OSX?

 
Avatar rr 6 post(s)

Okay, problem is more difficult. JBidWatcher did not have german locales and some of the string detections won’t work with the german ebay text. The german ebay auction numbers could no longer be found on ebay.com but formerly ebay.com deliveres also the german auction in JBidWatcher understandable english.

 
Avatar hirsch 5 post(s)

so i hope there will just be a fix for jbidwatcher… soon (?)….

 
Avatar gizmatron 3 post(s)

seems to be an ebay.de problem only.. I can add auctions from any european ebay site except germany.. get the “invalid auction or error talking to server” message.. I’m also getting periodically ALL auctions displaying 1.00 (FP) AS CURRENT PRICES. QUITTING AND REBOOTING BIDWATCHER AND CLICKING UPDATE ALL AUCTIONS RESTORES THE CORRECT PRICES THOUGH… ooops caps.. sorry not retyping all that…

 
Avatar manray1 1 post

Hello,
I am also having the same problem from france.

 
Avatar isnobid 2 post(s)

Dear Morgan,

same here when I add a German auction item, the first few might work. Subsequently adding auctions fails for unknown reason.
I have added the log of successfully adding two items and one failing. Somehow it does not find the redirect to the german cgi.ebay.de site after a few attempts.

I also tried to look up the items on ebay.com using the URLs in the log, but now all of them fail with the following message:

> This listing (330802949011) has been removed, or this item is not available.
> Please check that you’ve entered the correct item number
> Listings that have ended 90 or more days ago will not be available for viewing.

Changing the ebayServer.viewHost to cgi.ebay.de made things worse, i.e. no date and other item details, though adding worked.

Kind regards,
isnobid

Tue Oct 02 09:36:14 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=330802949011
Tue Oct 02 09:36:14 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=330802949011
Tue Oct 02 09:36:15 CEST 2012: Need to redirect to: http://cgi.ebay.de/ws/eBayISAPI.dll?ViewItemnext&item=330802949011.html
Tue Oct 02 09:36:15 CEST 2012: Parsing URL http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=330802949011
Tue Oct 02 09:36:15 CEST 2012: Parsing URL http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=330802949011
Tue Oct 02 09:36:16 CEST 2012: Parsing URL http://i.ebayimg.com/t/AVM-FRITZBox-6360-Cable-300-Mbps-4-Port-Gigabit-Wireless-N-Router-20002507-/00/$(KGrHqMOKpIE5W!19tj-BOWl2HV(kQ~~8.JPG?set_id=89040003C1
Tue Oct 02 09:36:34 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=330802949126
Tue Oct 02 09:36:35 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=330802949126
Tue Oct 02 09:36:35 CEST 2012: Need to redirect to: http://cgi.ebay.de/ws/eBayISAPI.dll?ViewItemnext&item=330802949126.html
Tue Oct 02 09:36:35 CEST 2012: Parsing URL http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=330802949126
Tue Oct 02 09:36:35 CEST 2012: Parsing URL http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=330802949126
Tue Oct 02 09:36:36 CEST 2012: Parsing URL http://i.ebayimg.com/t/AVM-FRITZBox-6360-Cable-300-Mbps-4-Port-Gigabit-Wireless-N-Router-20002507-/00/$(KGrHqMOKpIE5W!19tj-BOWl2HV(kQ~~_8.JPG?set
id=89040003C1
Tue Oct 02 09:37:04 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=330802949428
Tue Oct 02 09:37:04 CEST 2012: Parsing URL http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=330802949428
Tue Oct 02 09:37:05 CEST 2012: Redirecting from: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=330802949428
Tue Oct 02 09:37:05 CEST 2012: Redirecting to: http://www.ebay.com/itm/Error?item=330802949428
Tue Oct 02 09:37:05 CEST 2012: Parsing URL http://www.ebay.com/itm/Error?item=330802949428
Tue Oct 02 09:37:05 CEST 2012: Item not found: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=330802949428
Tue Oct 02 09:37:05 CEST 2012: Failed to parse auction! Bad return result from auction server.

 
Avatar hobbes 12 post(s)

Hello,

this communication error hit me today, also. Debugging into the problem will show a FileNotFound exception for the “http://cpi.ebay.com/itm/Error?item=xxx” URL, while at the same time the URL typed into the browser will deliver the correct “item remove or not available” information.

I’m not so deep in web programming. jbidwatcher tries to access to the error URL with the current login credentials. I also tried to access without a correct login, but still get the same “FileNotFound” exception:

bq.
if(curCook != null) {
uc = curCook.connect(auctionURL.toString());
} else {
uc = Http.net().makeRequest(auctionURL, null);
}
loadedPage = Http.net().receivePage(uc);

 
Avatar videokunst 1 post

Hi.

actually the program has been working great (thanks to the developer!), however I can confirm the problem above. My tests showed that only auction numbers visible from ebay.com (hence not ebay.de!) are added to the list.

 
Avatar kltxfm 3 post(s)

Hi,

I’ve had the same problem. I could only add auctions that existed on ebay.com. You should be able to resolve it by checking the “Prefer non-US auction server?” checkbox on the eBay panel in the preferences. The program will then use ebay.co.uk, and the auctions in question should exist there. However, in my case I was not able to make the selection permanent so after looking at the code I found that I could by manually editing the ‘JBidWatch.cfg’ preference file by adding:

ebay.non_us=true
ebay.alternate=ebay.co.uk

There is also a setting called

ebay.us_only=true

which I thought I had to change to false but that didn’t help. Maybe Morgan could elaborate? The settings seem a bit contradictory.

Regards,
Klaus

 
Avatar hirsch 5 post(s)

Even with new Beta Version not all auctions are shown.

JBidwatcher (2.5.3pre3-2-g03a9bc3) – A program to manage auction bids!

Wed Dec 05 10:15:57 CET 2012: Loading page 1 of My eBay for user
Wed Dec 05 10:15:57 CET 2012: URL: http://my.ebay.com/ws/eBayISAPI.dll?MyEbayBeta&SortOrder=ASCEND&GotoPage=1&View=SellingNext&Column=EndTime&CurrentPage=MyeBayNextSelling&SellingNext.Filter=All&&tagname=All%20Lists&ssPageName=STRK:ME:PAGE&StoreCatFilter=0&SubmitAction.ChangePage=x&FormatFilter=AllFormat
Wed Dec 05 10:15:57 CET 2012: Parsing URL http://my.ebay.com/ws/eBayISAPI.dll?MyEbayBeta&SortOrder=ASCEND&GotoPage=1&View=SellingNext&Column=EndTime&CurrentPage=MyeBayNextSelling&SellingNext.Filter=All&&tagname=All%20Lists&ssPageName=STRK:ME:PAGE&StoreCatFilter=0&SubmitAction.ChangePage=x&FormatFilter=AllFormat
Wed Dec 05 10:15:58 CET 2012: Got a bad end of compressed input stream.
Wed Dec 05 10:15:58 CET 2012: Bad input tag (ignoring): button id=“EditButton_5152” style=“padding:0;width:auto;overflow:visible;” class=“sfbtn”
Wed Dec 05 10:15:58 CET 2012: Parsing URL http://www.ebay.com/itm/330775842499?var=540074443168&ssPageName=STRK:MEWAX:IT&trksid=p3984.m1438.l2648
Wed Dec 05 10:15:58 CET 2012: Not loaded (330775842499).
Wed Dec 05 10:15:58 CET 2012: Parsing URL http://www.ebay.com/itm/221159532820?ssPageName=STRK:MEWAX:IT&
trksid=p3984.m1438.l2648
Wed Dec 05 10:15:58 CET 2012: Not loaded (221159532820).
Wed Dec 05 10:16:09 CET 2012: Whoops! Click-point not found!

 
Avatar eZ 8 post(s)

Yup. Auction 140895521146 can be added and viewed on .uk even so it is only shipping to Germany. Don’t know if a snipe would work. 300829905785 is shipping worldwide with lots of exceptions and can be viewed on .uk, but it can’t be added. 121030992955 is shipping worldwide, can be viewed on .uk and can be added, but does not show the photo icon.

← Previous 1