2.1pre6 problems: Java loading, changing seller name

Subscribe to 2.1pre6 problems: Java loading, changing seller name 21 post(s), 9 voice(s)

 
Avatar doomkrad 54 post(s)

Hi!
I just noticed 2 issues on the freshly installed 2.1pre6:
1. closing and reopening the application causes a warning window to appear: ‘Could not create the Java virtual machine’, JBidwatcher doesn’t start, a reboot is needed to make it work again and
2. when adding new auctions the seller name is changed to (until now): ‘a question’ or ‘- opens in a new window’.
To exclude a PC infection I just updated ZoneAlarm to Extreme Security 9.1.008.000 and immediately ran a full scan, no infection is shown.

 
Avatar santa 11 post(s)

I have exactly the same behavior with the seller names. This appeared suddenly. I would be inclined it is due to some recent eBay protocol changes.

 
Avatar BugMagnet 26 post(s)

I 3rd this report as to part 2

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
eBay changed the way things are laid out on their item pages…again.

I’m trying out a new way of getting versions out; I need folks to test them before I release them… I’d like you to try out a pre-prerelease, and let me know if it resolves your issues. (It may warn about a ‘newer version’, 2.1pre6. Ignore it.)

Standalone Windows: http://www.jbidwatcher.com/download/JBidwatcher-2.1pre7.exe
Disk Image (Mac OS X): http://www.jbidwatcher.com/download/JBidwatcher-2.1pre7.dmg
Linux .jar: http://www.jbidwatcher.com/download/JBidwatcher-2.1pre7.jar

As per usual, please let me know in as much detail as you can, about any issues you run into! This isn’t an official 2.1pre7 release, but it’s for folks who are willing to spend some extra time helping with the debugging.

— Morgan Schweers, CyberFOX!

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
@doomkrad – For problem #1, I’d watch out for memory issues, mainly. Check that JBidwatcher and any Java processes have completely closed down before running JBidwatcher again, and see if that helps. (Force them to quit only if absolutely necessary.) Reading around (I googled the text you quoted) suggests that there are some problems with applications that set custom environment variables, and other issues.

— Morgan Schweers, CyberFOX!

 
Avatar willer 3 post(s)

hi – tested windows version on Xp sp3 – problem seller name solved – have a nice day

 
Avatar engoulevent 1 post

Hi,
The problem of name of ebayer seems resolute on linux/ubuntu with 2.1pre7.

Thanks

 
Avatar doomkrad 54 post(s)

Hi Morgan,
I just discovered 2.1pre7, I (monitoring this topic didn’t show any effect unfortunately), I started it and now the seller names are shown correctly again after its ‘startup initialization’. Many Thanks for 2.1pre7.
Now to the ‘Java virtual machine’ issue: with both processes closed down (the Jbidwatcher process and jqs) I still need to reboot to make the application work.
I’ll keep an eye on both matters and also keep you up-to-date with anything worth mentioning.
Thanks again for the fix to the eBay seller issue.

 
Avatar santa 11 post(s)

Hi Morgan,

2.1pre7 was working fine, displaying correctly seller names. However, about one hour ago, the seller names started again to be replaced by “a question”,
“open a new window”, etc. I would bet eBay changed again the page format.

Thanks.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
@santa – I’m not seeing that; can you give me some item numbers that are failing?

Is there a possibility that you ran the wrong version…? It would have started up with the seller names correct from the last time JBidwatcher was run, and then as it walked through them, updating the seller info, it would pull the wrong data again. Use ‘About JBidwatcher’ and make sure you’re running version 2.1pre7-0-ga318f67.

— Morgan Schweers, CyberFOX!

 
Avatar doomkrad 54 post(s)

Hi Morgan,
2.1pre7 has now completely stopped working because of the Java virtual machine issue. I cannot even start the 2.1pre7 Installer, to try a new installation: I’m getting the same error window.
I have also googled the topic JVM tuning etc., that’s a science in itself…
I’m doomed.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
@doomkrad

Bleh.

Step back, bring your system up without anything running. No anti-virus, no extensions/services/etc., bring it up in a clean mode, so nothing is running in the background. (Caveat: Don’t do this if your system doesn’t have a hardware firewall/NAT between you and the internet. This is most likely the case if your IP address is a public-facing one (doesn’t start with 10, or 192.168.)

Try to run JBidwatcher in that clean mode, without any extraneous services running. Not because you want JBidwatcher to be running like that always, but rather because it will tell you if something else you run under normal circumstances is interfering.

It can be a real pain to get a Windows box to that state, and again, if your system faces directly into the maelstrom that is the Internet, without a NAT or hardware firewall between you and the world, then don’t do this. It’s terrifying how fast an internet-facing Windows PC gets taken over.

It really sounds like something is interfering with your JVM, though, so it’s the best test I can think of.

— Morgan Schweers, CyberFOX!

 
Avatar doomkrad 54 post(s)

Many thanks Morgan.
I have finally managed to make 2.1pre7 work again, but it took some (cold) sweat & tears before I saw it start.
Since my PC is indeed public-facing, it wasn’t possible go for the radical solution you kindly provided.
Instead, I chose a milder version of the same method:

1. I uninstalled ALL Java components, from within and outside of Firefox. For that I also needed to do the somewhat risky job of fiddling with Firefox’s config.
2. I uninstalled eMule, SoulSeek and every other application I don’t need ‘to survive’.
After very single step that involved deleting files and/or folders I ran TuneUp 1-Click Mainenance until it showed ZERO issues.
3. after being Absolutely Sure I left no traces of Java software, I TuneUp-defragged the registry, which of course implied a reboot.
4. now, having a ‘system free of Java software’, I went to java.com and downloaded the complete environment again.
5. finally, I added 2.1pre7 to Autostart and rebooted again.

It is under these circumstances ONLY does it agree to work: closing and restarting it after the Autostart sequence further triggers the error window.

I really hope at least some of these details will come in handy for you.
Thanks A LOT for your help.

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
Erf; drastic, but understandable.

Wait…‘Added it to Autostart’? Tell me more about this; what did you do? I’m not familiar with that.

What happens if you don’t add it to Autostart, just run it on its own?

— Morgan Schweers, CyberFOX!

 
Avatar doomkrad 54 post(s)

Hi Morgan.
First of all, I apologize for my mistake: it’s XP’s Startup, not Autostart like I stated before.
Let me put it this way:
Added to Startup – there it follows the first entry: Logitech Setpoint, the trackball software – Jbidwatcher seems to get its memory management right.
BUT:
If I later need to close it for some reason, the next time I try to start it I will get the dreaded warning window informing me that it ‘Could not create the Java virtual machine’. This latter is the ‘on-its-own situation’.

 
Avatar santa 11 post(s)

@ Morgan.

Yes , you are right. Since you said to test version “7”, I had only changed one shortcut. The shortcut in the startup menu was still pointing to V6.
A reboot put me silently back to V6.

3 Hints for useful additions/modifications :
- Display the item picture only when the pointer is over the left column
- A search function for specific text in the tabs (complete tab is the most important)
- When I add my own tab, it disappears after some time. Perhaps when empty. I don’t know how to reproduce that.

Best regards. Thanks for your nice job.

 
Avatar Fluid 11 post(s)

Hi Morgan,

just to inform you that the “seller name” problem is also solved on Linux/Opensuse 11.1 with pre7. regards,

Charles

 
Avatar Liam 20 post(s)

I just found this, after I posted in the Beta forum – http://forum.jbidwatcher.com/forums/8/topics/2227

I’m getting the seller name issue in JBidwatcher (2.1pre7-8-g61363f2) on MacOS 10.6.3. Also getting auctions showing in JB as Buy it Now, so can’t set a snipe. Details, with pointers to specific auctions, in the post I link to above.

Cheers, Liam

 
Avatar slicer127 1 post

Just reporting in: pre7 fixed the seller name issue for me on XP SP3.
Cheers, Matt

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
I’m just letting folks know, I’ve pushed up a 2.1pre7-28-gcd0e285 version to the same download spot described above and will be releasing it as a 2.1pre7 officially tomorrow evening, unless some showstoppers come up.

So…please try it out and let me know if there are any showstoppers! :)

It fixes…snipes failing, bad seller names, bad bidder names, auctions seen as fixed price, unable to retrieve prices, selection color customization, private listing recognition, some sticky search and update infinite loops, and it reduces the amount of derby.log data dumped out when debugging is set to true. There’s also a bunch of improvements internally, and some work towards a new feature that a bunch of users have been asking about.

Yeah…there’s a lot of code in there.

It’s about as tested as I can manage personally, so I’d love some more eyes on it! Feedback is all I ask…!

Best of luck with your auctions!

— Morgan Schweers, CyberFOX!

 
Avatar Morgan Schweers Administrator 1,204 post(s)

Greetings,
I believe 2.1pre7 fixed this, but this should definitely be resolved in the most recent version (2.1pre8 at this time).

— Morgan Schweers, CyberFOX!